Last Comment Bug 726015 - "Firefox is in offline mode" is misleading when there is no network connection
: "Firefox is in offline mode" is misleading when there is no network connection
Status: RESOLVED FIXED
: regression, uiwanted, ux-jargon
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 14 Branch
: All All
: -- normal (vote)
: Firefox 24
Assigned To: Bruce Wu
:
Mentors:
: 845356 (view as bug list)
Depends on:
Blocks: 729951
  Show dependency treegraph
 
Reported: 2012-02-10 08:19 PST by Gervase Markham [:gerv]
Modified: 2013-05-14 05:27 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
+


Attachments
change description of netError to match connectionFailure (3.63 KB, patch)
2013-04-28 00:21 PDT, Bruce Wu
mbrubeck: review-
Details | Diff | Review
patch_v2 - this patch affect all locale (3.32 KB, patch)
2013-04-29 13:33 PDT, Bruce Wu
mark.finkle: review+
mbrubeck: feedback+
Details | Diff | Review

Description Gervase Markham [:gerv] 2012-02-10 08:19:28 PST
If I don't have a network connection and try and visit a site, it tells me "Firefox is in offline mode". While perhaps technically true, this is spectacularly unhelpful, because it leads me to look for some sort of switch within Firefox to switch to "online" mode, like there is on Desktop, while wondering how on earth it got into that state.

A better message would be something like "Firefox cannot access the Internet. Please check that you have a working Internet connection. [ Try Again ]".

Gerv
Comment 1 Matt Brubeck (:mbrubeck) 2012-03-08 09:39:53 PST
Not blocking release on this, but we'll continue tracking this bug.
Comment 2 :Margaret Leibovic 2013-03-01 12:24:59 PST
I wonder why we're getting this error page instead of the "Server not found" error page that shows up on desktop.

If we haven't done this intentionally, it seems like a bug somewhere it our networking code, rather than in the error page itself.
Comment 3 Aaron Train [:aaronmt] 2013-03-01 12:35:46 PST
In all the months passed, I havn't seen this; although there is a recent report here which I will dupe in a second.
Comment 4 Aaron Train [:aaronmt] 2013-03-01 12:36:01 PST
*** Bug 845356 has been marked as a duplicate of this bug. ***
Comment 5 :Margaret Leibovic 2013-03-01 13:40:33 PST
I reproduced this by turning off my wifi and trying to navigate to a webpage.
Comment 6 Tony Green 2013-03-08 10:19:39 PST
I'm not 100% certain that my bug 845356 IS a duplicate of this.

I actually HAVE a network connection (can ping my device and can visit other websites using the default browser).

But when I take the option to sync from the menu, I get a message "No internet connection available".

And (apparently randomly) trying to visit websites gives "Firefox is currently in offline mode and can't browse the web". Though weirdly, at the present moment, although I'm unable to sync, I can actually get websites. But ten minutes ago I couldn't.

My device is currently sitting no more than 20cm from my WiFi router and is (not surprisingly) showing high signal strength.
Comment 7 Tony Green 2013-03-08 11:29:32 PST
Update. I can stop this behaviour by following the instructions at http://superuser.com/questions/208146/can-firefoxs-offline-mode-be-disabled

Just in case it helps anybody else who lands here looking for a solution.
Comment 8 Bruce Wu 2013-04-06 15:38:09 PDT
I am wondering if anyone is working on this bug, if not I would love to contribute some development time into it. 

If anyone have editing privileges see this, please assign the bug to me. 

Thanks~
Comment 9 Matt Brubeck (:mbrubeck) 2013-04-06 23:11:19 PDT
(In reply to Bruce Wu from comment #8)
> If anyone have editing privileges see this, please assign the bug to me. 

Done; thanks for spending time on this! If you have any questions about the bug, you can ask them here, or you can try asking in #ux or #fx-team on irc.mozilla.org.
Comment 10 David Hsu 2013-04-16 23:45:43 PDT
From what I can see, it seems like Firefox for Android doesn't have offline mode; it just states that it's in "offline mode" when it has no network connection. If so, why not just change the error message in chrome/overrides/appstrings.properties?

This has been a problem before as well, and it seems like they just overrided the string: bug 523296.
Comment 11 Bruce Wu 2013-04-17 01:03:40 PDT
(In reply to David Hsu from comment #10)
> This has been a problem before as well, and it seems like they just
> overrided the string: bug 523296.

So far I am trying to reproduce Tony Green's finding (comment #6). Otherwise,
I agree with you that this is simply the matter of word choice.
Comment 12 Bruce Wu 2013-04-28 00:21:26 PDT
Created attachment 742783 [details] [diff] [review]
change description of netError to match connectionFailure

I changed the message content instead of inspect all statement involve netError to see if they should be substitute with connectionFailure. 

Since Fennec do not have an "Offline mode" right now, changing the message is ok.. but in the future when we do introduce Offline Mode .. this will be a problem.
Comment 13 Matt Brubeck (:mbrubeck) 2013-04-28 08:55:58 PDT
Comment on attachment 742783 [details] [diff] [review]
change description of netError to match connectionFailure

Review of attachment 742783 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch!  The new strings look good; but unfortunately this version of the patch will only affect English-language builds.  Since it keeps the same names for the strings, other locales will continue using their current strings.

Normally we would just change each string name to something like "netOffline2.title" and then making the corresponding change in the file that uses it:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/netError.xhtml

...but in this case, one of the strings is used in Gecko code that's shared with other platforms (B2G, desktop) so we can't easily change it just for mobile.  This is a known problem with the way we do string overrides:
http://mxr.mozilla.org/mozilla-central/source/docshell/base/nsDocShell.cpp#4288

I'm not sure yet of the best way to fix this...  We might consider changing the string for all platforms, or adding a separate string for cases (like Android) where "network.manage-offline-status" is enabled.
Comment 14 Bruce Wu 2013-04-29 13:33:00 PDT
Created attachment 743250 [details] [diff] [review]
patch_v2 - this patch affect all locale

Since the shortDesc cannot be change easily without effecting other platform, I left it alone and changed only the title / longDesc. This way at least the user will know the situation is "Unable to Connect", and the description also suggest user to check for data/wifi connection.
Comment 15 Matt Brubeck (:mbrubeck) 2013-04-29 14:28:54 PDT
Comment on attachment 743250 [details] [diff] [review]
patch_v2 - this patch affect all locale

Review of attachment 743250 [details] [diff] [review]:
-----------------------------------------------------------------

I like this; it seems like a good pragmatic compromise.  If you think this is ready to be reviewed and checked in, please set the review? flag and enter :mfinkle as the reviwer.
Comment 16 Mark Finkle (:mfinkle) (use needinfo?) 2013-05-01 15:08:44 PDT
Comment on attachment 743250 [details] [diff] [review]
patch_v2 - this patch affect all locale

Agreed. This seems like better text to display to the user.
Comment 17 Ryan VanderMeulen [:RyanVM] 2013-05-13 14:30:07 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3a2756741ff0
Comment 18 Ed Morley [:emorley] 2013-05-14 05:27:26 PDT
https://hg.mozilla.org/mozilla-central/rev/3a2756741ff0

Note You need to log in before you can comment on or make changes to this bug.