Some drop-downs do not open anymore on Linux

RESOLVED DUPLICATE of bug 726443

Status

MailNews Core
Filters
--
critical
RESOLVED DUPLICATE of bug 726443
7 years ago
3 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
With current trunk SM/TB nightlies, some drop-downs do not open anymore on Linux, e.g.:
* anything on the Address Book dialogs for New/Edit Contact/List
* anything on the Filter Rules dialog (New/Edit Filter)

Many other drop-downs are not affected, though (e.g. Preferences, Mail & Newsgroup Preferences) so maybe it's limited to dialogs?

This may very well be a Core bug, but since I couldn't find anything that's broken with Minefield, I chose MailNews Core for now. Feel free to move to a more appropriate location.

Comment 1

7 years ago
It does happen for me also in the Account manager (the folder selectors).
Sometimes after playing with [window focus|changing virtual desktops|doing the same action in TB8 and then trying it in TB13] does make the dropdowns appear for a while.

(Wayne, this is the problem I talked to you about on IRC.)

Comment 2

7 years ago
It doesn't happen for me at all, but then again my VM doesn't support graphics acceleration. I can't remember whether you can turn that off for test purposes.

I assume the problem isn't theme-dependent?

When you attempt to open the drop-downs do they still react as expected? On Modern the text colour changes, while on Classic it follows the OS settings; I don't know what my VM's configured with but in my case the background changes.

Comment 3

7 years ago
It started only several days ago. Thunderbird HW acceleration is turned off by default. Only acceleration could be in the X server (like EXA). The theme is default.
In the case of folder pickers they do react to arrow keys and move onto next value in the list. They just do not expand and show the list.
In the case of the "Account Actions" drop-down, that can be shown with space.

Comment 4

7 years ago
(In reply to aceman from comment #3)
> In the case of folder pickers they do react to arrow keys and move onto next
> value in the list.
Actually that's almost expected because the code for the arrow keys only requires that the popup exists, not that it's showing. What might be slightly more interesting is whether the arrow keys still work after you press F4.

Comment 5

7 years ago
When I am in the folder picker and switch values via arrows and then press F4 (the picker is focused) then it continues to work.
Hm - problems with popups - the Mozmill test failures over the past few days also involve popups.  I wonder if these problems are related (bug 725685).
I just reproduced locally.

Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120212 Thunderbird/13.0a1

Steps to reproduce:

1)  Open up Thunderbird's Address Book, and ensure that you have more than 2 address books.
2)  Hit the "New Contact" button
3)  In the New Contact dialog, try changing the "Add to" dropdown.

What happens?

No popup is displayed.

What is expected?

A popup should display, listing the available address books that the user can add the new contact to.

Updated

7 years ago
Depends on: 725685
After some bisecting, I've found the regression revision on mozilla-central:

changeset:   86343:b45785802731
user:        Karl Tomlinson <karlt+@karlt.net>
date:        Wed Feb 08 09:51:15 2012 +1300
summary:     b=724966 make sure to set sRetryGrabTime for retrying grabs r=roc


CC'ing roc / karlt.

Comment 9

7 years ago
But see my comments in bug 725685. Reverting another commit fixed this for me too.
(In reply to :aceman from comment #9)
> But see my comments in bug 725685. Reverting another commit fixed this for
> me too.

And that bug introduced the static var that Bug 724966 moved
I started NSPR logging for "Widget:5", and then tried clicking on the New Contact window's dropdown menu (which, again, failed to open).

This was the log output:

-1220307232[b721a270]: OnEnterNotify: b72132e0
-1220307232[b721a270]: Button 1 press on b72132e0
-1220307232[b721a270]: CaptureRollupEvents b7213880
-1220307232[b721a270]: GrabPointer time=0x0382aa55 retry=0
-1220307232[b721a270]: GrabPointer: window not visible
-1220307232[b721a270]: nsWindow::NativeResize [b7213880] 206 237 234 100
-1220307232[b721a270]: nsWindow::Show [b7213880] state 1
-1220307232[b721a270]: size_allocate [b7213880] 0 0 234 100
-1220307232[b721a270]: GrabPointer time=0x0382aa55 retry=1
-1220307232[b721a270]: GrabPointer: window not visible
-1220307232[b721a270]: nsWindow::OnWindowStateEvent [b7213880] changed 1 new_win
dow_state 0
-1220307232[b721a270]: nsWindow::OnWindowStateEvent [b7213880] changed 1 new_win
dow_state 0
-1220307232[b721a270]: GrabPointer time=0x0382aa55 retry=1
-1220307232[b721a270]: GrabPointer: pointer grab failed: 2
-1220307232[b721a270]: CaptureRollupEvents b7213880
-1220307232[b721a270]: ReleaseGrabs
-1220307232[b721a270]: nsWindow::Show [b7213880] state 0
-1220307232[b721a270]: nsWindow::OnWindowStateEvent [b7213880] changed 1 new_win
dow_state 1
-1220307232[b721a270]: nsWindow::OnWindowStateEvent [b7213880] changed 1 new_win
dow_state 1
-1220307232[b721a270]: Button 1 release on b72132e0
-1220307232[b721a270]: OnLeaveNotify: b72132e0

karlt / roc:  Does anything in there look suspicious?
Depends on: 726443
Well, events have overtaken me, but just for completeness...

(In reply to :aceman from comment #5)
> When I am in the folder picker and switch values via arrows and then press
> F4 (the picker is focused) then it continues to work.
This indicates that the popup fails to open at all; if the popup opens but fails to paint then you would expect the arrow keys to stop working.
(In reply to Mike Conley (:mconley) from comment #7)
> Steps to reproduce:
> 
> 1)  Open up Thunderbird's Address Book, and ensure that you have more than 2
> address books.
> 2)  Hit the "New Contact" button
> 3)  In the New Contact dialog, try changing the "Add to" dropdown.
Aha, this is why I couldn't reproduce the problem - I'm too used to using the keyboard to open dialogs! I see the problem when clicking the button.
I expect this should now be fixed in mozilla-central.  (See Bug 726443 comment 9.)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726443
No longer depends on: 726443

Comment 15

7 years ago
Fixed in my just compiled SM 2.10a1.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.