Last Comment Bug 726560 - Add support of Panorama group name (FF10+) for titlebar customization
: Add support of Panorama group name (FF10+) for titlebar customization
Status: RESOLVED INCOMPLETE
:
Product: Other Applications Graveyard
Classification: Graveyard
Component: Nightly Tester Tools (show other bugs)
: Trunk
: All All
: -- enhancement
: ---
Assigned To: Szabolcs Hubai (:xabolcs)
:
Mentors:
Depends on: 624394 682996
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-13 03:52 PST by Szabolcs Hubai (:xabolcs)
Modified: 2012-04-30 03:51 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Nightly Tester Tools with v1 patch for early adopters (132.15 KB, application/octet-stream)
2012-02-21 16:33 PST, Szabolcs Hubai (:xabolcs)
no flags Details
add support of Panorama group name v1 (7.30 KB, patch)
2012-02-21 17:02 PST, Szabolcs Hubai (:xabolcs)
no flags Details | Diff | Review
Nightly Tester Tools with v4 patch for early adopters (132.20 KB, application/x-xpinstall)
2012-03-26 12:19 PDT, Szabolcs Hubai (:xabolcs)
no flags Details

Description Szabolcs Hubai (:xabolcs) 2012-02-13 03:52:16 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0a2) Gecko/20120212 Firefox/12.0a2
Build ID: 20120212042014

Steps to reproduce:

Displaying of the active group name in the titlebar was discounted by Bug 682996 which is landed in FF10.

Enhancing NTT's titlebar customizing template with such an element, 
users could have the ability to "revert" the removing of TabView.getActiveGroupName()
Comment 1 dinesy91 2012-02-19 15:10:04 PST
I second this. I think it would be good to have an "about:config" option at least to display the group name in the title bar.

It is quite important for me.
Comment 2 John Chase 2012-02-20 12:36:10 PST
I would appreciate this very much. +1
Comment 3 Szabolcs Hubai (:xabolcs) 2012-02-21 16:33:47 PST
Created attachment 599408 [details]
Nightly Tester Tools with v1 patch for early adopters

Attaching an installable package of NTT with a work-in-progress patch.

Dear dinesy and John: could You test this patched NTT?
Comment 4 Szabolcs Hubai (:xabolcs) 2012-02-21 17:02:55 PST
Created attachment 599416 [details] [diff] [review]
add support of Panorama group name v1

In this v1 patch I:
- added a lot stuff to nightlyApp, heavily based on Bug 682996's changeset: a constant, a getter, a listener and a little initializing code
- added a new variable with ActiveTabGroupName, and it's related strings
- moved nightly.init's main code to run delayed: nightly.initLazy,
    because NTT gets initialized earlier than TabView and therefore the 
    variable remains empty


Please help me! I have got some question while implementing this patch.
What about the comments which originates from TabView?
What about the new names?
What about the places of the insertions?

Thank You for Your answers!

And the r? - freely after Tony. :)
"Heather, Henrik, whoever of you two comes around first to review the patch may remove the other. 
Or of course, if you think that some other reviewer would be better qualified, feel free to change the reviewer's name."
Comment 5 Szabolcs Hubai (:xabolcs) 2012-02-21 21:32:50 PST
(In reply to Szabolcs Hubai from comment #4)
> Created attachment 599416 [details] [diff] [review]
> [...]
>     because NTT gets initialized earlier than TabView and therefore the 
>     variable remains empty
> [...]

s/TabView/SessionStore/
Comment 6 Henrik Skupin (:whimboo) 2012-02-27 03:09:30 PST
Thanks Szabolcs for starting to work on a patch. Would you mind to transfer the patch over to a github pull request? 

https://github.com/mozilla/nightlytt/pulls

We are considering to get rid of the Bugzilla component in favor of handling everything directly via github. I would be happy to have a look at your patch as soon as it will be available as pull request.
Comment 7 Szabolcs Hubai (:xabolcs) 2012-02-27 04:54:46 PST
Hi Henrik,

OK, I'll transfer them to GitHub.

In the meantime would You mind to create a wiki page (on MozWiki or even on GitHub)
about the GitHub routine? See Tony's comment in Bug 715557 Comment 1 and #C9!

Because I really like that Bugzilla filters out the pollution generated by the reviewing system.
In other words: I like the one commit - one issue/bug commit history. :) (Of course: part 1, part 2, part ... are welcome)
In other words, again: I don't like the commits like "assigned nits". :P
Comment 8 Szabolcs Hubai (:xabolcs) 2012-03-26 12:09:07 PDT
Comment on attachment 599416 [details] [diff] [review]
add support of Panorama group name v1

At GitHub there is a more recent patch. This is obsolete now.
Comment 9 Szabolcs Hubai (:xabolcs) 2012-03-26 12:19:36 PDT
Created attachment 609416 [details]
Nightly Tester Tools with v4 patch for early adopters

I saw noticeable activity in Bug 682996, therefore I packed up an NTT version which contains my recent work up to commit e11907e1 [1].

Please feel free to comment / report problems with it at Github Issue 19! [2]

[1] - https://github.com/xabolcs/nightlytt/commit/e11907e1b0e5cfeccffb7013cf42c27671a3b561
[2] - https://github.com/mozilla/nightlytt/pull/19
Comment 10 Szabolcs Hubai (:xabolcs) 2012-04-09 02:38:20 PDT
Resolving as INCOMPLETE due to the Bugzilla Component cleanup.
Comment 11 Ravi Pina [:ravi] 2012-04-09 09:19:16 PDT
I'm confused. This is still a bug regardless of the component status. Is this just a clever way of sweeping this under the rug?
Comment 12 Henrik Skupin (:whimboo) 2012-04-10 06:02:21 PDT
Ravi, we are in the process to move all the existing and open bugs over to Github where we can track the whole development efforts on a single place as forcing users to learn two different systems. So if you are still interested in this bug feel free to watch the activity on the Github repository.

The existing NTT component on Bugzilla will be abandoned soon.

Note You need to log in before you can comment on or make changes to this bug.