Closed Bug 726770 Opened 8 years ago Closed 4 years ago

Mostly-Permanent orange: TEST-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_apply_to_folder_and_children

Categories

(Thunderbird :: Testing Infrastructure, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mconley, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [disabled])

Attachments

(2 files)

We're getting this pretty consistently on our Linux Mozmill tests:

SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_apply_to_folder_and_children
  EXCEPTION: Popup never opened at action depth: 3
    at: utils.js line 429
       TimeoutError("Popup never opened at action depth: 3") utils.js 429
       waitFor((function () curPopup.state == "open"),"Popup never opened at action depth: 3",1000,50) utils.js 467
       _click_menus([object XULElement],[object Array]) test-window-helpers.js 976
       invoke_column_picker_option([object Array]) test-columns.js 373
       _apply_to_folder_common(true) test-columns.js 411
       test_apply_to_folder_and_children() test-columns.js 479
            frame.js 557
            frame.js 626
            frame.js 669
            frame.js 497
            frame.js 675
            server.js 179
            server.js 183
Whiteboard: [tb-orange]
I can reproduce this failure locally, and it does pass on occasion.
Summary: Permanent orange: TEST-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_apply_to_folder_and_children → Mostly-Permanent orange: TEST-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_apply_to_folder_and_children
May it be a problem enumerating subfolders as in bug 751562 ?
This issue does not happen with --disable-accessibility option.

So I guess the root cause of this issue is the same as bug 617311.
I'd suggest this test is disabled on Linux until bug 617311 is fixed.
Attachment #638931 - Flags: review?(mconley)
Comment on attachment 638931 [details] [diff] [review]
Disable the test on Linux

Review of attachment 638931 [details] [diff] [review]:
-----------------------------------------------------------------

Good idea - thanks Hiro.

We should file a bug to remove that constraint once bug 617311 is fixed.
Attachment #638931 - Flags: review?(mconley) → review+
Depends on: 617311
No longer depends on: 617311
Whiteboard: [tb-orange]
Depends on: 617311
No longer depends on: 617311
For me --disable-accessibility does not fix the failure. The linux menu failures in tests are intermittent and happen at random on my machine. But the accessibility does not fix it.
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
This is not fixed, see the comments. The test is just disabled.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [disabled][leave open]
The patch for bug 977253 also fixes this bug. So now we can re-enable the test.

Please see try server results.
https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=46c47ddb3bec
Attachment #8489825 - Flags: review?(standard8)
Attachment #8489825 - Flags: review?(standard8) → review+
Looks like this is no longer an issue, closing.
Status: REOPENED → RESOLVED
Closed: 7 years ago4 years ago
Resolution: --- → WORKSFORME
It is "no longer and issue" because one of the patches were checked in to disable the test.
Resolution: WORKSFORME → FIXED
Whiteboard: [disabled][leave open] → [disabled]
Blocks: 1276472
You need to log in before you can comment on or make changes to this bug.