If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Using Back Button on a previously submitted form treat the form as new form to be submitted.

VERIFIED DUPLICATE of bug 55055

Status

()

Core
HTML: Form Submission
--
critical
VERIFIED DUPLICATE of bug 55055
17 years ago
17 years ago

People

(Reporter: esther, Assigned: Eric Pollmann)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Here's the scenario using bugzilla
1. Enter a new bug
2. Click the link (not the back button)to go back to edit the bug
3. Edit the bug and submit
4.Click Back button 2x because you want to go back to the Enter Bug page to use
most of the existing data to enter a new bug.  
 
Result: After the second click of the Back button, you get the repost alert "The
page you are trying to view was generated from data you entered in an online
form earlier in this browser session.  If you resend the data, any action that
the form carried out (such as a search or online purchase) will be repeated.  To
resend the data, click OK.  Otherwise, click Cancel."

Expected: User should be able to continue clicking the Back button to the
original page.  In this case you can't, you are forced to Cancel or you end up
submitting a new form.  (In my scenario, a new duplicate bug).  This does not
happen in 4.7.

Comment 1

17 years ago
reassigning
Assignee: rods → pollmann
Um... isn't this just a cache issue?  and a dup?
Whiteboard: DUPEME
In fact, duplicate of "Go Back broken for form post results"

*** This bug has been marked as a duplicate of 55055 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 4

17 years ago
Verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.