Last Comment Bug 727131 - Pref needed to allow "Search Google for" tabs to open in background
: Pref needed to allow "Search Google for" tabs to open in background
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: Firefox 13
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on: 695482
Blocks: 701903
  Show dependency treegraph
 
Reported: 2012-02-14 10:03 PST by tracy.cooperjr
Modified: 2012-03-27 02:28 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.32 KB, patch)
2012-02-14 17:55 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
dao+bmo: review+
Details | Diff | Splinter Review

Description tracy.cooperjr 2012-02-14 10:03:39 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120214 Firefox/13.0a1
Build ID: 20120214031227

Steps to reproduce:

Searched using context menu option "Search Google for".


Actual results:

Tab opened in Foreground.


Expected results:

Should have opened in background per "browser.tabs.loadInBackground" setting but due to Bug 695482 it no longer does.
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2012-02-14 11:08:49 PST
A new pref in about:config to override the changes in bug 695482 is required.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-14 17:55:27 PST
"is required" is a little strong. "is humbly requested" perhaps? :)

I want to be clear that the reason I'm going to fix this is:
- our previous behavior was long-standing, and some people have gotten used to it
- adding a pref is trivial, and introduces very little maintenance overhead

I don't want this to be perceived as a precedent that implies we'll be adding prefs to every new behavior change, because we aren't going to do that.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-14 17:55:54 PST
Created attachment 597265 [details] [diff] [review]
patch
Comment 4 Jim Jeffery not reading bug-mail 1/2/11 2012-02-14 18:12:31 PST
Thanks Gavin.  My statement 'is required' was meant to mean a new pref would be needed, rather than hooking the behavior of "browser.tabs.loadInBackground".  

Fully understood about it 'not becoming a norm' for changes.
Comment 5 Dão Gottwald [:dao] 2012-02-15 04:21:27 PST
Comment on attachment 597265 [details] [diff] [review]
patch

>+pref("browser.search.context.inBackground", false);

*.loadInBackground for consistency with similar prefs
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-15 12:21:41 PST
https://hg.mozilla.org/mozilla-central/rev/dbf20cd5526f

Note You need to log in before you can comment on or make changes to this bug.