Same new groups list every time, new groups not saved unless after full refreshing

VERIFIED FIXED in Thunderbird 13.0

Status

defect
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: luweitest, Assigned: jcranmer)

Tracking

52 Branch
Thunderbird 13.0
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120208060813

Steps to reproduce:

click the "New groups" in TB's subscribe window.


Actual results:

TB begin reloading the full group list. I checked the server log and find TB just issue "List" command to news server when click the "New groups" tab. 


Expected results:

TB should check new groups only and issue "newgroups" command, IIRC.
(Reporter)

Updated

7 years ago
Version: unspecified → 10
(Assignee)

Comment 1

7 years ago
Posted patch FixSplinter Review
Huh. Easy enough to fix, though.
Assignee: nobody → Pidgeot18
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #604708 - Flags: review?(dbienvenu)

Updated

7 years ago
Attachment #604708 - Flags: review?(dbienvenu) → review+
(Assignee)

Comment 2

7 years ago
Pushed: http://hg.mozilla.org/comm-central/pushloghtml?changeset=594a1c24f23f
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
(Reporter)

Comment 3

7 years ago
Thank you. Hope it be implemented soon.
(Reporter)

Comment 4

2 years ago
I'd like to reopen this bug but seems not privileged to. The cause is I just happened to find that the "new groups" TB shows are always the same. After some tests I see that TB did not add the new groups that it retrieved to the local list, but send NEWGROUPS command with the same timestamp again and again, until I did a full refresh of all groups. 

As I may stuck in WindowsXP for quite some time, hope it could be fixed in ESR. Thanks.
Summary: reloading full group list every time → Same new groups list every time, new groups not saved unless after full refreshing
Version: 10 Branch → 52 Branch
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.