Closed Bug 727903 Opened 8 years ago Closed 8 years ago

remove buildbot and other automation related to pageloader and fennecmark

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: k0scist, Assigned: k0scist)

References

Details

(Whiteboard: [cleanup])

Attachments

(1 file)

with bug 725414 pageloader and fennecmark now live in talos.  While downloading the pageloader.xpi does not do any harm, it is no longer necessary and won't be used by newest talos.

Once all branches point to a talos.zip with pageloader/fennecmark included, all steps related to fetching and futzing with the resources may be eliminated
Duplicate of this bug: 727904
All we have to do is modify this line:
http://hg.mozilla.org/mozilla-central/file/default/testing/talos/talos_from_code.py#l47
and remove the entry from talos.json:
http://hg.mozilla.org/mozilla-central/raw-file/default/testing/talos/talos.json

I don't even see the need to move pageloader.xpi to talos/page_load_test:
http://hg.mozilla.org/build/talos/file/56020a3a3bba/talos/page_load_test

I think all we need to do is submit such a patch with your new talos.zip to the try server and see how it fairs.

You can see both old and new code paths in this if clause:
http://hg.mozilla.org/build/buildbotcustom/file/default/process/factory.py#l7587

Do you want to give it a try and let me know how it goes?

== For more context ==

Right now all project branches, m-c and m-a do *not* download pageloader.xpi through the talos factory but through the talos_from_code.py script.

m-b and m-r will get there after merge days:
http://hg.mozilla.org/build/buildbot-configs/file/default/mozilla-tests/config.py#l1268

The branches using talos_from_source_code.py hit this path code:
http://hg.mozilla.org/build/buildbotcustom/file/tip/process/factory.py#l7588
> Do you want to give it a try and let me know how it goes?

Sure!
Component: Release Engineering → Release Engineering: Automation
QA Contact: release → catlee
Whiteboard: [cleanup]
sounds like you got volunteered!
Assignee: nobody → jhammel
Attachment #603517 - Flags: review?(armenzg)
Not sure the magical invocation of getting correct try syntax these days with autoland. This should be tried with, who would have guessed, talos runs
Whiteboard: [cleanup] → [cleanup][autoland-try]
Whiteboard: [cleanup][autoland-try] → [cleanup][autoland-in-queue]
Autoland Patchset:
	Patches: 603517
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=bfa19d2d445c
Try run started, revision bfa19d2d445c. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=bfa19d2d445c
Try run for bfa19d2d445c is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=bfa19d2d445c
Results (out of 100 total builds):
    success: 99
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-bfa19d2d445c
 Timed out after 06 hours without completing.
Whiteboard: [cleanup][autoland-in-queue] → [cleanup]
FYI your try push did not get any talos coverage, therefore, did not get tested.

You probably want to use (which I have added):
[autoland-try: -b o -p all -u none -t all]

FTR, the patch looks good but I would like to be 100% sure.

https://wiki.mozilla.org/Build:Autoland#Sample_Valid_tags
Whiteboard: [cleanup] → [cleanup][autoland-try: -b o -p all -u none -t all]
Whiteboard: [cleanup][autoland-try: -b o -p all -u none -t all] → [cleanup][autoland-in-queue]
Autoland Patchset:
	Patches: 603517
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=a5edb129f0dd
Try run started, revision a5edb129f0dd. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=a5edb129f0dd
Comment on attachment 603517 [details] [diff] [review]
remove extraneous pieces

This looks good. Thanks a lot!
Attachment #603517 - Flags: review?(armenzg) → review+
Could someone with m-c push access push this please?
Whiteboard: [cleanup][autoland-in-queue] → [cleanup][autoland-in-queue][checkin-needed]
I will land this in the morning.
Whiteboard: [cleanup][autoland-in-queue][checkin-needed] → [cleanup][autoland-in-queue]
Try run for a5edb129f0dd is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=a5edb129f0dd
Results (out of 53 total builds):
    exception: 2
    success: 48
    failure: 3
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-a5edb129f0dd
Whiteboard: [cleanup][autoland-in-queue] → [cleanup]
Can we mark this as fixed? Or are there other pieces I don't know about?
Marking as fixed.  Please reopen with details if i've missed anything
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.