Last Comment Bug 727951 - removing expired news articles broken
: removing expired news articles broken
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Networking: NNTP (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 13.0
Assigned To: David :Bienvenu
:
:
Mentors:
: 739934 743432 749803 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 12:01 PST by David :Bienvenu
Modified: 2012-04-27 15:08 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (629 bytes, patch)
2012-02-16 12:01 PST, David :Bienvenu
Pidgeot18: review+
Details | Diff | Splinter Review

Description David :Bienvenu 2012-02-16 12:01:54 PST
Created attachment 597934 [details] [diff] [review]
proposed fix

the url we run to get rid of expired articles is failing. Patch upcoming
Comment 1 Joshua Cranmer [:jcranmer] 2012-02-17 17:53:02 PST
I'd feel a lot better about this if we could test it.
Comment 2 Joshua Cranmer [:jcranmer] 2012-02-19 07:26:57 PST
I don't think this is quite enough--I tested it briefly (by accident, natch) and the result I got appears to be that it cleared the newsgroup but it also opened up the file dialog "do you want to open the file mozilla.dev.test.multimedia?"...
Comment 3 David :Bienvenu 2012-02-19 07:37:26 PST
(In reply to Joshua Cranmer [:jcranmer] from comment #2)
> I don't think this is quite enough--I tested it briefly (by accident, natch)
> and the result I got appears to be that it cleared the newsgroup but it also
> opened up the file dialog "do you want to open the file
> mozilla.dev.test.multimedia?"...

Did you try it with the patch in bug 492329 ? That's the only way I've tried it, and I did not get the file dialog.
Comment 4 Joshua Cranmer [:jcranmer] 2012-03-04 15:19:18 PST
Comment on attachment 597934 [details] [diff] [review]
proposed fix

I finally did a more purposeful test of this, and it worked this time. The UI for clearing messages kind of sucks (you see no apparent visual cue that anything is happening until the operation finishes, when messages disappear), but that's probably worth another bug.

Some other notes:
1. Lose the comment (or at least the "I think")
2. return rv; probably ought to be return NS_OK;
3. It's probably cleaner to separate the if statement from the rest of the code with blank lines.
Comment 5 David :Bienvenu 2012-03-08 08:02:45 PST
fixed on trunk - forgot to address the comments; I'll do that later today
Comment 6 David :Bienvenu 2012-03-08 09:36:18 PST
http://hg.mozilla.org/comm-central/rev/c7d25333f38a pushed for review comments.
Comment 7 Magnus Melin 2012-03-28 04:32:52 PDT
*** Bug 739934 has been marked as a duplicate of this bug. ***
Comment 8 Joshua Cranmer [:jcranmer] 2012-04-08 09:39:53 PDT
*** Bug 743432 has been marked as a duplicate of this bug. ***
Comment 9 Joshua Cranmer [:jcranmer] 2012-04-27 15:08:56 PDT
*** Bug 749803 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.