simile timeplot display regressed between firefox 10 and 12

VERIFIED FIXED in Firefox 12

Status

()

Core
Canvas: 2D
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Axel Hecht, Assigned: jrmuizel)

Tracking

({regression})

12 Branch
mozilla13
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox12+ fixed, firefox13+ fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The timeplot we use on the l10n dashboard doesn't show up correctly on aurora and nightly, but works fine on 10.

https://l10n-stage-sj.mozilla.org/dashboard/tree-status/fx_aurora?&bound=7&hideBad shows that, the grey graph seems to be upside down.

Filing in canvas as that's what's actually drawing, didn't do a ton of investigation myself so far.
m-c regression range seems to be http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=005488525c43&tochange=402b394b6623

Unfortunately, there's a huge number of changes in there.  :(
Axel, are you on Mac?  I can't seem to reproduce this on Linux, but I do see it on Mac...
(Reporter)

Comment 3

5 years ago
Yes, I'm on mac.
Yeah, definitely not reproducible on Linux.  I guess we get to bisect on Mac.  :(
OS: All → Mac OS X
The first bad revision is:
changeset:   85317:3c47bcef2ce4
user:        Jeff Muizelaar <jmuizelaar@mozilla.com>
date:        Tue Jan 24 15:14:50 2012 -0500
summary:     Bug 720721. Properly transform the clip path in DrawTargetCG. r=mwoodrow
Blocks: 720721
tracking-firefox12: --- → ?
tracking-firefox13: --- → ?
Jeff M - this looks like a novel regression in FF12 from some of your work. tracking-firefox12+ and can you tell us the cost of backing out the offending changeset, and/or suggest some other remedy?
tracking-firefox12: ? → +

Updated

5 years ago
tracking-firefox13: ? → +
(Assignee)

Comment 7

5 years ago
Created attachment 599878 [details] [diff] [review]
Another rememdy

When we fixed transformed clips it caused us to double transform gradients. We fix this by avoiding ::PushClip when drawing gradients. This has the advantage of saving a save and restore pair and it makes Fill() more closely match Stroke()
Attachment #599878 - Flags: review?(matt.woodrow)
Attachment #599878 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/0de785d6345a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13

Updated

5 years ago
Assignee: nobody → jmuizelaar

Comment 9

5 years ago
Verified on nightly.

Should this be uplifted?
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

5 years ago
Comment on attachment 599878 [details] [diff] [review]
Another rememdy

[Approval Request Comment]
Regression caused by (bug #): 720721
User impact if declined: Gradients may draw in the wrong spot
Testing completed (on m-c, etc.): on m-c, test case included
Risk to taking this patch (and alternatives if risky): Low, the new code is easier to reason about than the old code
String changes made by this patch: none
Attachment #599878 - Flags: approval-mozilla-aurora?
Comment on attachment 599878 [details] [diff] [review]
Another rememdy

[Triage Comment]
Low risk, verified fix for Aurora 12.
Attachment #599878 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/086fa692e38b
status-firefox12: --- → fixed
status-firefox13: --- → fixed
You need to log in before you can comment on or make changes to this bug.