bookmarks copy/cut/paste messed up

RESOLVED INVALID

Status

P5
major
RESOLVED INVALID
18 years ago
14 years ago

People

(Reporter: ratman, Assigned: bugs)

Tracking

({regression})

Trunk
Future
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
using mtrunk win32 installer build 2001032004, but i've seen this for most of
the month.

1) in bookmark manager, select three folders that are not in the base level of
the bookmarks tree (i.e., not at the same level as the default personal toolbar
folder)
2) select edit -> copy.
3) select the last folder in the bookmark tree (default is mozilla project).
4) select edit -> paste.  you will notice the three folders will paste in
reverse order at the end of the list.
5) select the new three folders.
6) select edit -> cut.
7) select the last folder in the bookmark tree again.
8) i forgot what eight was for.
9) select edit -> paste. you will now only see two of the three folders.
10) collapse the bookmark tree.
11) expand to the first level of the bookmark tree.  you will now see all three
folders, but in random order.
12) select the new three folders.
13) select edit -> delete or hit the delete key or click "delete" on the toolbar.
14) collapse and expand the bookmark tree again.  you will see that two of the
folders have remained.
15) try to delete the two folders (same as above)
16) collapse and expand again - now one folder still remains.
17) deleting the folder now completely removes the folder.

variations on this technique show that pasting after a copy will reverse the
folder order and pasting after a cut will arrange the folders randomly. 
deleting more than one folder after a cut and paste never fully removes the
selected folders.

repeatable but with lots of random varation, especially with the cut and delete
issues.  works with folders from imported i.e. favorites as well.
(Reporter)

Comment 1

18 years ago
btw, this appears in the 0.8.1 milestone as well.

i'm guessing that this may be a dupe of more than one other bug out there, but i
can't find any of them, unfortunately.

i'd be shocked if this behaviour isn't repeatable by others, though.

Comment 2

18 years ago
I cant reproduce this because when i try and paste folders in nothing happens.
Cant do much with it until that is fixed.
(Reporter)

Comment 3

18 years ago
currently using win32 mtrunk installer build 2001043004.

the following is the behavior i have noticed in this build:

1) copy, cut, paste, and delete are nonfunctional when accessed in the edit menu.
2) delete is nonfunctional when accessed in the toolbar.
3) copy, cut, paste, and delete are fully functional when operating on single
bookmarks only.
4) when multiple bookmarks are selected, delete will only delete every other
bookmark selected, i.e., selected items one, three, five, etc.
5) when multiple bookmarks are selected, copied, and pasted to the same level of
the bookmarks tree, nothing happens (i.e., no duplicates are created).
6) when multiple bookmarks are selected, copied, and pasted to a different level
of the bookmarks tree, the bookmarks are pasted in reverse order.
7) when multiple bookmarks are selected, cut, and pasted to a different level of
the bookmarks tree, the bookmarks are pasted in reverse order, *and* only every
other bookmark cut is removed from the original location (i.e., the second,
fourth, sixth, etc. remain).
8) when multiple bookmarks are selected, cut, pasted to a different level of the
tree, selected again, copied, and pasted to their original location, the first,
third, fifth, etc. are at the beginning of the directory, followed later by the
second, fourth, sixth, etc.

a variety of variations on this theme may be performed to achieve varying
results, but the key appears to be that pasting multiple selections reverses
their order, and deleting/cutting only operates on every other member of a
selection.


can nobody confirm this?  this is a serious and ongoing problem and definitely
needs to be fixed before the commercial beta (i.e., suggesting nsbeta+).
Keywords: 4xp, correctness
Summary: bookmark folder copy/cut/paste messed up → bookmarks copy/cut/paste messed up
(Reporter)

Updated

18 years ago
Keywords: regression

Comment 4

18 years ago
Confirming. There isn't a general tracking bug for cut/paste errors that I can 
find. this one lists many.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
The pasting folder problem is described in bug 79904.

Comment 6

18 years ago
Still got problems with (Cut&)paste of bookmarks in version 0.9.1 (Win32 Build)
under Windows 95C. 

After importing a (quite a large - 209kB) Netscape bookmark file (with missing
some links in trhe root), I tried to cut links from the beginning and paste them
at the end. As result they are found after the first seperator. Doing Cut and
Paste again work correct. I tried to do it again, but deleting all entries and
importing the second time seem to import only one link out of the root (but all
folders). Closing "manage bookmarks" and reopening showw all links but in wild
order. Doing cut and paste again, sometimes work but some links are not shown
again. After closing and reopening the bookmarks they are there again and you
can move these down. Just to copy 16 links from the root from inbetween to the
end takes me about 15 minutes.

  
(Reporter)

Updated

18 years ago
Blocks: 68550
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 8

17 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 9

17 years ago
reporter can you try this again with a new nightly, bookmarks outliner just
landed and may fix, or change behavior here.

Comment 10

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 11

17 years ago
2002031303

Steps to reproduce:
1. Open Manage Bookmarks Ctrl-B
2. Select a bookmark
3. Slect from the mouse popup Cut
4. Select another folder 
5. Select from the mouse popup Paste
6. The bookmark does not show up in the new place

Drag-and-drop still works

Comment 12

17 years ago
Ok, this bug has morphed too many times.  We don't have any reproducible 
steps, or even any general concensus as to what this bug is exactly about.

Please open specific bugs for your individual issues.  If you really disagree 
with me, feel free to reopen this bug, but know that no developer will touch 
this as it stands.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.