AMO pages and their URLs frustrate alternative Mozilla products

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20120208 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120208081240

Steps to reproduce:

1. Start SeaMonkey or the Mobile (Fennec? Android?) browser.
2. Google search for a popular add-on available for multiple browsers, like "AdBlock Plus addons.mozilla.org"
3. Click the first a.m.o search result.


Actual results:

The most popular result will be for Firefox, so most likely you're taken to the add-on's Firefox page, e.g. https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/ . But then bug 666303 (or bug 671085) kicks in and you're told it's not available for your browser (or on Mobile you're invited to "get Firefox").

But many add-ons are available for Mobile, SeaMonkey, even Thunderbird! Just substitute the lowercase product name in the URL and there's a match. It seems you can just visit the URL without language or product, e.g. https://addons.mozilla.org/adblock-plus/ and a.m.o. will redirect to the page for the language and product you're using (if available), but the problem is search results and people never link to generic URLs, all the URLs include en-US/firefox. (It seems product- and language-free a.m.o. URLs result in 404's when I request them wirh curl and lynx, so maybe search engines aren't indexing them.)


Expected results:

Maybe fixing those other bugs I reference will make this do the right thing, but before marking this as a duplicate please consider the common use case where some blog post or search result hands you an AMO URL which currently hardcodes "firefox". Some overlapping fixes that occur to me:

* Stop putting the product in AMO URLs. The supported products are an aspect of the add-on just like supported versions.

* Use <link rel="canonical" href="http://addons.mozilla.org/addon/ADDON_NAME/"/> so that search engines will refer to the product-free URL.

* It's fine to default to Firefox, but always provide prominent "This add-on is available for other Mozilla products: _SeaMonkey_, _Mobile Firefox_, _Thunderbird_, ..." text and links.

* Be smart about this and detect that you're visiting with some other product, see if the add-on is available for that product: if so highlight the link to it, if not say "This add-on is not available for xxx, but is available for _Firefox_, _Mobile Firefox_, _Thunderbird_, ...".

Cheers.

Comment 1

6 years ago
A call to https://addons.mozilla.org/firebug redirects to https://addons.mozilla.org/de/seamonkey/firebug but the real page would be https://addons.mozilla.org/de/seamonkey/addon/firebug which redirects me to https://addons.mozilla.org/de/firefox/addon/firebug/

Thats frustrating, there you need to select "install anyway"

Updated

6 years ago
Duplicate of this bug: 808976
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.