Closed Bug 728652 Opened 9 years ago Closed 9 years ago

Crash @ nsPlaintextEditor::InsertFromDataTransfer

Categories

(Core :: DOM: Editor, defect)

13 Branch
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: scoobidiver, Assigned: enndeakin)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

Attachments

(1 file)

It's a new crash signature that first appeared in 13.a1/20120218.
The regression window is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2271cb92cc05&tochange=550779e6bab4
The likely culprit is bug 499008.

One comment tells:
"I tried to drag a tab out to create a new window and the browser crashed."

Signature 	nsPlaintextEditor::InsertFromDataTransfer(nsIDOMDataTransfer*, int, nsIDOMDocument*, nsIDOMNode*, int, bool) More Reports Search
UUID	acbe61c7-6f6f-4166-821e-817712120219
Date Processed	2012-02-19 05:40:21
Uptime	41063
Install Age	12.1 hours since version was first installed.
Install Time	2012-02-18 17:35:08
Product	Firefox
Version	13.0a1
Build ID	20120218031156
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7600
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x2a02, AdapterSubsysID: 012b1025, AdapterDriverVersion: 8.15.10.1930
D3D10 Layers? D3D10 Layers-
D3D9 Layers? D3D9 Layers+
EMCheckCompatibility	True	
Total Virtual Memory	4294836224
Available Virtual Memory	3749609472
System Memory Use Percentage	85
Available Page File	608366592
Available Physical Memory	156692480

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsPlaintextEditor::InsertFromDataTransfer 	editor/libeditor/text/nsPlaintextDataTransfer.cpp:173
1 	xul.dll 	nsGlobalWindow::QueryInterface 	dom/base/nsGlobalWindow.cpp:1405
2 	mozjs.dll 	js_ExpandErrorArguments 	js/src/jscntxt.cpp:680
3 	xul.dll 	nsScriptSecurityManager::IsCapabilityEnabled 	caps/src/nsScriptSecurityManager.cpp:2564
4 	xul.dll 	nsBindingManager::GetBindingImplementation 	content/xbl/src/nsBindingManager.cpp:1303
5 	xul.dll 	nsBindingManager::GetBindingImplementation 	content/xbl/src/nsBindingManager.cpp:1303
6 	xul.dll 	nsPrincipal::Equals 	caps/src/nsPrincipal.cpp:338
7 	xul.dll 	AbortIfOffMainThreadIfCheckFast 	xpcom/base/nsCycleCollector.cpp:1334
8 	xul.dll 	nsTextNode::AddRef 	content/base/src/nsTextNode.cpp:156
9 	xul.dll 	nsHTMLSharedElement::QueryInterface 	content/html/content/src/nsHTMLSharedElement.cpp:205
10 	xul.dll 	nsCycleCollectingAutoRefCnt::decr 	obj-firefox/dist/include/nsISupportsImpl.h:211
11 	xul.dll 	nsPlaintextEditor::InsertFromDrop 	editor/libeditor/text/nsPlaintextDataTransfer.cpp:326
12 	xul.dll 	nsEditorEventListener::Drop 	editor/libeditor/base/nsEditorEventListener.cpp:776

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsPlaintextEditor%3A%3AInsertFromDataTransfer%28nsIDOMDataTransfer*%2C%20int%2C%20nsIDOMDocument*%2C%20nsIDOMNode*%2C%20int%2C%20bool%29
Crash Signature: [@ nsPlaintextEditor::InsertFromDataTransfer(nsIDOMDataTransfer*, int, nsIDOMDocument*, nsIDOMNode*, int, bool)] → [@ nsPlaintextEditor::InsertFromDataTransfer(nsIDOMDataTransfer*, int, nsIDOMDocument*, nsIDOMNode*, int, bool)] [@ nsPlaintextEditor::InsertFromDataTransfer]
OS: Windows 7 → All
It's #7 top crasher in 13.0a1 over the last day.
Keywords: topcrash
Attached patch Fix crashSplinter Review
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #599144 - Flags: review?(ehsan)
Attachment #599144 - Flags: review?(ehsan) → review+
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/9c3ddd19d964
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Duplicate of this bug: 730307
You need to log in before you can comment on or make changes to this bug.