[New Tab Page] add drop-down to preference dialog

RESOLVED DUPLICATE of bug 743613

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 743613
6 years ago
6 years ago

People

(Reporter: ttaubert, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 5 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 599086 [details]
Example of the 'new tab' drop-down menu

I think we should remove the toolbar (the buttons in the upper right) from the New Tab Page. Bug 716543 has already been filed to remove the refresh/reset button and lots of people didn't understand how to disable the NTP.

We should introduce a simple drop-down menu in "Preferences > Tabs" and implement bug 722234 (and not bug 716543, imho). This wouldn't only simplify the NTP and its code but also make it more obvious how to enable/disable the feature.

This would also provide a good solution for bug 724239 as it's not an empty about:newtab page, but really about:blank when the NTP is disabled.
Attachment #599086 - Flags: feedback?(ux-review)
(Reporter)

Comment 1

6 years ago
Created attachment 599105 [details] [diff] [review]
Part 1 - Remove the New Tab Page's toolbar
(Reporter)

Comment 2

6 years ago
Created attachment 599106 [details] [diff] [review]
Part 2 - Correct CSS files and remove old assets after removing the toolbar
(Reporter)

Comment 3

6 years ago
Created attachment 599107 [details] [diff] [review]
Part 3 - Correct and remove tests after removing the toolbar
(Reporter)

Comment 4

6 years ago
Created attachment 599108 [details] [diff] [review]
Part 4 - Add browser.newtab.page preference and adapt BROWSER_NEW_TAB_URL
(Reporter)

Comment 5

6 years ago
Created attachment 599109 [details] [diff] [review]
Part 5 - Add browser.newtab.page drop-down to the preferences dialog
(Reporter)

Comment 6

6 years ago
Created attachment 599146 [details] [diff] [review]
Part 1 - Remove the New Tab Page's toolbar
Attachment #599105 - Attachment is obsolete: true
(Reporter)

Comment 7

6 years ago
Created attachment 599168 [details] [diff] [review]
Part 1 - Remove the New Tab Page's toolbar
Attachment #599146 - Attachment is obsolete: true

Comment 8

6 years ago
So there will be no way to turn off the new tab page from the new tab page itself? You'll have to go to preferences?

That doesn't seem discoverable.

What about just a simple checkbox that says "Don't show this again" or something like that?
(Reporter)

Comment 9

6 years ago
I don't think it makes sense to include this directly on the New Tab Page itself. Users that want to turn it off can easily go to the Preferences dialog. We don't want a permanent checkbox saying "don't show this again" if the user decides to keep it.

Also, there will be add-ons setting browser.newtab.url to a different value. All these add-ons would need to implement their own UI to disable a custom New Tab Page. By offering this setting in the Preferences dialog it's predictable and easy.
> Also, there will be add-ons setting browser.newtab.url to a different value. All these add-ons would need to implement their own UI to disable a custom New Tab Page. By offering this setting in the Preferences dialog it's predictable and easy.

Good point.

So if an add-on does override it, which of the menuitems will be displayed? Neither of the two correspond to a new URL...
(Reporter)

Comment 11

6 years ago
The first one. That's only my suggestion for now - it basically means the default new tab page configured in Firefox. This may be "about:newtab" or some custom page.
(Reporter)

Updated

6 years ago
No longer blocks: 716543
(Reporter)

Updated

6 years ago
No longer depends on: 722234
(Reporter)

Updated

6 years ago
No longer blocks: 722263
(Reporter)

Updated

6 years ago
Attachment #599086 - Flags: feedback?(ux-review)
(Reporter)

Updated

6 years ago
Assignee: ttaubert → nobody
Severity: normal → enhancement
Status: ASSIGNED → NEW
Summary: [New Tab Page] remove toolbar and add drop-down to preference dialog → [New Tab Page] add drop-down to preference dialog
(Reporter)

Updated

6 years ago
Attachment #599107 - Attachment is obsolete: true
(Reporter)

Updated

6 years ago
Attachment #599106 - Attachment is obsolete: true
(Reporter)

Updated

6 years ago
Attachment #599168 - Attachment is obsolete: true

Updated

6 years ago
Blocks: 763259
Bug 743613 is basically the same as this bug but with a slightly different approach. I'm duping over to that bug since it has more discussion.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 743613

Updated

6 years ago
No longer blocks: 763259
You need to log in before you can comment on or make changes to this bug.