change text of "View -> Messages -> Unread" based on threaded state

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
18 years ago
14 years ago

People

(Reporter: tim.taylor, Assigned: sspitzer)

Tracking

({polish})

Trunk
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Current Behavior:

The expected behavior of selecting the menu item
View -> Messages -> [ ] Unread
is unclear when messages are being displayed in "threaded" mode.

Desired Behavior:

The text for the "unread" menu item changes based on "threaded" state.  For example:

View -> Messages:
[ ] All
[ ] Unread
------------
[ ] Threaded
------------

View -> Messages:
[ ] All
[ ] Threads with Unread
------------
[X] Threaded
------------

This is assuming that /all/ messages within a thread containing unread messages
are displayed even when the "unread" menu item is selected.  In bug 68925 I
suggest that this is the expected behavior.

BTW, I'm not particularly fond of the text "Threads with Unread", but "Threads
with Unread Messages" is too long.  Perhaps "Unread Threads" is clear enough.

Updated

18 years ago
QA Contact: esther → fenella

Comment 1

18 years ago
cc jglick for input
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Sounds like a good idea to me. 

Updated

17 years ago
QA Contact: fenella → laurel

Updated

17 years ago
Keywords: polish

Comment 3

17 years ago
looks like this is done in latest builds?

Comment 4

17 years ago
> looks like this is done in latest builds?

Nope.

Comment 5

17 years ago
fyi, "View: Messages: Threaded" was never implemented correctly and there is a 
bug to remove it. see bug 127881. (it is working as sort but displayed as a 
checkbox)

Comment 6

15 years ago
This bug is no longer relevant, is it?  The View | Messages menu has been 
substantially reworked.

Comment 7

15 years ago
This bug makes no sense anymore in the current menu architecture; =>Invalid
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Component: Networking: News → Mail Window Front End
Resolution: --- → INVALID

Comment 8

15 years ago
The 'Threaded' item is back (due to work in bug 72493), but the View menu still 
has separate Messages and Threads subitems.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.