Closed Bug 729421 Opened 12 years ago Closed 12 years ago

Google sends the basic mobile homepage instead of their fancy touch-optimized homepage (that Stock/Chrome get)

Categories

(Web Compatibility :: Site Reports, defect)

ARM
Android
defect
Not set
normal

Tracking

(blocking-kilimanjaro:+)

VERIFIED FIXED
blocking-kilimanjaro +

People

(Reporter: pretzer, Unassigned)

References

Details

(Keywords: top50)

Attachments

(4 files)

With the new UA-String (bug 721632) Google now sends the desktop version of its homepage to Firefox instead of the touch optimized version its sending to Android stock browser. Before that we recieved a 'light' version of the mobile optimized site (bug 668286), which is not what we want either, I think, but still better than the desktop site.
Keywords: top50
New UA being: 'Mozilla/5.0 (Android; Mobile; rv:13.0) Gecko/13.0 Firefox/13.0a1'
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking-kilimanjaro: --- → ?
blocking-kilimanjaro: ? → +
No longer blocks: google-evangelism
Attached image Stock Browser
This is how Google looks from the stock Browser.
If you use the Android global search, and let it send the request to Firefox, you get the desktop version.
If you type a search term into the Awesomebar, and then select Google Search from Firefox's drop down, you get the stripped down mobile Google view.
Google now redirects Fennec to their stripped down Mobile site. Is this bug considered FIXED with that or are we aiming for their fancy version? We'll probably want the fancy version, although it seems to be Googles policy to not give that to any browser except Stock/Chrome.
(In reply to pretzer from comment #9)
> Google now redirects Fennec to their stripped down Mobile site. Is this bug
> considered FIXED with that or are we aiming for their fancy version? We'll
> probably want the fancy version, although it seems to be Googles policy to
> not give that to any browser except Stock/Chrome.

Google is not redirecting, we are redirecting on searches in the AwesomeScreen [1].

This bug is far from fixed as Google is still sending their desktop website when you input www.google.com.

[1] http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/searchplugins/google.xml#18
I'm not talking about the awesomebar search, I know that it's hardcoded. See the screenshot for what I get when typing 'google.com' into the address bar. The day before I still got the desktop version. 
I should mention though that I am based in Germany and thus am redirected to 'google.de' even though I typed 'google.com'. 
Maybe the switch is only live in Germany for now? Can you try navigating to 'google.de' and see what happens?
Ah, yes, they are sending the basic mobile site now. I believe we're pushing for the optimal touch-version.
(In reply to Aaron Train [:aaronmt] from comment #12)
> I believe we're pushing for the optimal touch-version.

Changing the summary to reflect that. 
This bug is about the homepage (when navigating to www.google.com).
Summary: Google sends desktop version instead of their mobile optimized site → Google sends the basic mobile homepage instead of their fancy touch-optimized homepage (that Stock/Chrome get)
As of 08/07, Google is sending us their touch-site!

I'm also confirming that with the (Gonk, like Android) token for B2G, this is also the case too.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to Aaron Train [:aaronmt] from comment #16)
> As of 08/07, Google is sending us their touch-site!
> 
> I'm also confirming that with the (Gonk, like Android) token for B2G, this
> is also the case too.

We're definitely getting a mobile-optimized site, although it's not the same site that Webkit gets. It's a much better situation though that's acceptable.
Status: RESOLVED → VERIFIED
I'll file a followup bug for the Webkit vs. Gecko difference.
It appears it this fix on Google's end only works if Android is in the user agent also.
Also, the Google Image search results served to us are very different.  Should this be reopened?
(In reply to Ehsan Akhgari [:ehsan] from comment #21)
> Also, the Google Image search results served to us are very different. 
> Should this be reopened?

Right. The root cause of that is being tracked in bug 780896. Let's track that there.
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Product: Tech Evangelism → Web Compatibility
Component: Mobile → Site Reports
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: