news:// links try to open in browser

VERIFIED FIXED in mozilla0.9.1

Status

MailNews Core
Backend
P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Luke Morey, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.9.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+] have reviews, seeking approval.)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I'm using the latest nightly 20010320 under Windows 2000 with SP1.

Clicking on any news: hyperlink in the browser does not launch mail-news, it
tries to open in the browser.  The location in the navigation bar changes to
news://servername:119/news.group.name

Try following any n.p.m.* link on the community/newsgroups page for example.

Updated

17 years ago
QA Contact: esther → stephend
Confirming.  Oddly enough, if you open a mail/news window right after this, we
Do the Right Thing, that is, we fire up the Account Wizard, and add (in my case)
netscape.public.mozilla.announce to my default news server (news.mozilla.org). 
Build 2001032204.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think Seth might own this.
OS: Windows 2000 → All
Hardware: PC → All
If you have a server like news.mozilla.org already in the Folder Pane, clicking 
news://news.mozilla.org/netscape.public.mozilla.mail-news no longer tries to 
auto-subscribe you to that group, nor will it open that newsgroup up, if you're 
already subscribed to it.  We do the right thing when you don't have the server 
defined in the account manager.  
Keywords: nsbeta1
Summary: news: links try to open in browser → news:// links try to open in browser

Updated

17 years ago
Priority: -- → P3
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.1
*** Bug 77951 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
moving to 0.9.2
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 6

17 years ago
what are the chances of this getting fixed in the next few days...
might help us getting better feedback on the nscp beta...

Comment 7

17 years ago
adding another test page
http://home.netscape.com/browsers/6/feedback/index.html
which has many such news links embedded in it.

Comment 8

17 years ago
reassigning to cavin
Assignee: mscott → cavin
Priority: P3 → P2
notes to cavin:  this regressed, not sure when.

at a certain point "autosubscribe urls" (like news://host/group) would open
another 3 pane window to that group.  if you had never subscribed to a group on
"host", you'd get the 3 pane window, and an new account wizard (so you could
configure the new news account)

we may have always opened up a browser window, I can't remember off the top of
my head.  try the official NS 6.0 bits to see what's regressed.

I'm trying the official builds now.
6.01 does this right (or partially right?), that is, when you click a link in a
mail/news message like news://news.mozilla.org/netscape.public.mozilla.mail-news
we spawn a new 3-pane mail window, with news.mozilla.org as the server, and
n.p.m.mail-news subscribed, then we popup the Account Wizard.  We don't touch
the URL bar of the browser (as current behavior does).
ok, I think I broke this when I cleaned up / rewrote a lot of the news code 
(during the perf landing.)

right now, news://host/group urls have the content type of "message/rfc-822" 
instead of "x-application-newsgroup".

investigating a fix now.

taking back from cavin, I think I can have something for 0.9.1
Assignee: cavin → sspitzer
Target Milestone: mozilla0.9.2 → mozilla0.9.1
I've got a simple patch that returns us to the 6.0 behaviour.

there are still some issues, but they can moved off to another milestone.

specifically, 

1) we still need to select the new newsgroup in the 3 pane we just opened
2) [eventually] we need to heed the pref for whether or not to open a new 3 
pane, or use existing ones.

#1 is the most interesting, and ties in heavily with some code the that 
suresh/gayatrib/prass and I were working on for loading the 3 pane to a 
selected folder for search.

I think both of these were known issues back in 6.0.

here comes the fix...
Status: NEW → ASSIGNED
Created attachment 36618 [details] [diff] [review]
fix

Comment 15

17 years ago
rs=bienvenu

Comment 16

17 years ago
r=mscott. 
updating status.

thanks for the speedy reviews.
Whiteboard: [nsbeta1+] → [nsbeta1+] have reviews, seeking approval.
#36662 is the outstanding bug about not selecting the newsgroup.

I'm pretty sure the other bug is in bugzilla.  it would be about fixing the 
messenger window service to heed that pref.  (we may also have to add that pref 
back to the pref UI)
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Verified FIXED, clicking on a link such as
news://news.mozilla.org/netscape.public.mozilla.mail-news opens a new mail/news
window, with that server & newsgroup in the folder pane, and brings up the
account wizard, on the following platforms/builds:

Windows 2000 build 2001-05-31-04
Mac OS 9.1   build 2001-05-31-08
RedHat 7.0   build 2001-05-31-08

There are other outstanding bugs, but we are back from the regression.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 21

16 years ago
Is this right?

news://news.mozilla.org:119/3BCD1FE7.60208@meer.net (current link for the
Mozilla 1.0 manifesto under _news_ on the front page) opens a browser window,
not mail-news.

Not re-openening yet, but I'm not at all convinced by this behaviour...
Luke, all of the comments and patches in this bug were for the format of
news://host/group.

For message-ids, that should be covered in bug 11076.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.