If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

User should not be able to delete all screenshots for a submitted apps.

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Victor Carciu, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 600020 [details]
Error message displayed during app submission for empty screenshot section.

Prerequisites:
Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0

Steps to reproduce:
1.Go to APPS marketplace : https://marketplace-dev.allizom.org/en-US/developers/ ,login with valid credentials and be sure that you already have some apps submitted.
2.From My Submissions , select an app and open it.
3.At "Images" section click edit and delete all available screenshots.

Expected results:
An error saying that at least one screenshot is needed should be displayed.

Actual results:
All screenshots are deleted 

NOTES: I logged this issue because I observed that during app submission process, the user is forced to upload at least one screenshot, so it is not normal that the same user is able to delete all screenshots when editing the app(Attached screenshot from submission process).

Please see screencast for this bug:http://screencast.com/t/OOJklPwM
The user may want to replace the screenshots by removing all them first and then uploading a new single screenshot. It would be annoying if we always enforced one image to be present - even if you haven't clicked "Submit" yet.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.