Last Comment Bug 730285 - No update channel is found after restoring the OS to a previous point.
: No update channel is found after restoring the OS to a previous point.
Status: RESOLVED DUPLICATE of bug 351216
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 11 Branch
: x86 All
-- normal with 10 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 351216
Blocks: 702045
  Show dependency treegraph
 
Reported: 2012-02-24 06:47 PST by Vlad [QA]
Modified: 2014-12-12 10:00 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
-
-


Attachments
screenshot (428.53 KB, image/jpeg)
2012-02-24 06:47 PST, Vlad [QA]
no flags Details

Description User image Vlad [QA] 2012-02-24 06:47:59 PST
Created attachment 600378 [details]
screenshot

The update channel isn't found (releasetest channel) after the OS (Win 7 and XP) is restored to a previous point.

OSes: Windows 7 x86 , Windows XP

Steps to reproduce:
1.Install Firefox 10 beta 6 (or any other Fx 10 beta)
2.Change the update channel to releasetest. Do not check for update afterwards.
3.Create a restore point.
4.Browse around and create a big profile.
5.Perform an update to Firefox 11 beta 4 on releasetest channel.
6.Restore the OS to the restore point from step 3.

Actual results:
After step 6, the OS reverts to Firefox 10 beta 6 that had been previously installed and all the history/bookmarks/addons are present.
If however you try to update again to Firefox 11 beta 4, no channel is found even though  the releasetest channel is listed in about:config - see screenshot

Expected results:
Firefox should recognize the releasetest channel and perform the update.

Note: If I don't change the channel and perform the same steps from above from Fx 11b1 to Fx11b3 on beta channel, everything is performed as expected. the update after reverting to the previous point is made without problems.
Comment 1 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-24 09:01:11 PST
What is in the %firefox%/defaults/prefs/channel-prefs.js file?
Comment 2 User image Vlad [QA] 2012-02-27 00:28:51 PST
This is what is in the file:

"//@line 2 "e:\builds\moz2_slave\rel-m-beta-w32-bld\build\browser\app\profile\channel-prefs.js"
pref("app.update.channel", "releasetest");
"

(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #1)
> What is in the %firefox%/defaults/prefs/channel-prefs.js file?
Comment 3 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-27 11:36:30 PST
Yeah, that should definitely find updates. Can you see if you get the same result with the current Beta? (ie. if you don't change the channel?)
Comment 4 User image Vlad [QA] 2012-02-28 02:03:11 PST
I've repeated the steps from the description without changing the channel.
After restoring the OS to a previous point the update channel isn't found even though it's the default channel: "beta"

So this issue it's not related to channel changing.
Comment 5 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-28 11:04:47 PST
Can you turn on app.update.log in about:config and see if anything is reported to error console when you check for updates after restore?
Comment 6 User image Vlad [QA] 2012-02-29 02:37:22 PST
This is the error that I'm getting:

Error: uncaught exception: [Exception... "update.locale file doesn't exist in either the XCurProcD or GreD directories"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource:///components/nsUpdateService.js :: getLocale :: line 592"  data: no]

(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #5)
> Can you turn on app.update.log in about:config and see if anything is
> reported to error console when you check for updates after restore?
Comment 7 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-29 10:08:30 PST
Asking for tracking given that this *could* result in a user not being able to get updates (at least not without reinstalling Firefox).
Comment 8 User image Alex Keybl [:akeybl] 2012-02-29 11:17:01 PST
(In reply to Vlad [QA] from comment #4)
> So this issue it's not related to channel changing.

When this was first reported, it wasn't clear that channel changing was involved. Given this new info, we'll track for FF11. Sending over to Rob Strong since he did much of the work in bug 702045. This isn't a strict blocker for release considering we're already mitigating Patch Tuesday OS restore risk by throttling, however.
Comment 9 User image Robert Strong [:rstrong] (use needinfo to contact me) 2012-03-08 19:12:14 PST
This is just one of the many cases we have had during update where a system restore would break if files were removed or changed. At best we should mitigate this as we do now by avoiding patch Tuesday. The bug that will fix this is bug 351216.
Comment 10 User image Alex Keybl [:akeybl] 2012-03-19 16:11:51 PDT
(In reply to Robert Strong [:rstrong] (do not email) from comment #9)
> This is just one of the many cases we have had during update where a system
> restore would break if files were removed or changed. At best we should
> mitigate this as we do now by avoiding patch Tuesday. The bug that will fix
> this is bug 351216.

Given that, untracking.
Comment 11 User image Robert Strong [:rstrong] (use needinfo to contact me) 2014-12-12 10:00:05 PST

*** This bug has been marked as a duplicate of bug 351216 ***

Note You need to log in before you can comment on or make changes to this bug.