quicksearch does not include custom contact names

RESOLVED DUPLICATE of bug 460737

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 460737
6 years ago
6 years ago

People

(Reporter: Johannes Linke, Unassigned)

Tracking

10 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

6 years ago
to reproduce: change the name of a contact, lets call him abc, to abcd. then quicksearch for abcd, and you wont find these messages anymore.

i have a contact which i renamed months, if not years ago, and i noticed today that i can't quicksearch for his messages.

my humble guess is, that quicksearch only searches for the name embedded in the mail. Quicksearch searches in the complete "From:"- part of the header,  but apparently not for the mail adresses connected with contact names that match the search text. That is counterintuitive as the contact name is shown as sender or receiver in the message overview and should therefore be included in the quicksearch.

Comment 1

6 years ago
(In reply to Johannes Linke from comment #0)
Confirmed here; display name is not being considered in quick search.
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.2) Gecko/20120216 Thunderbird/10.0.2
Application Build ID: 20120216022139
Whiteboard: dupme
(In reply to Hashem Masoud from comment #1)
> (In reply to Johannes Linke from comment #0)
> Confirmed here; display name is not being considered in quick search.

Hashem, that's very correct.
As a next step, I've searched for duplicates as suggested by Ludovic:

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=%3Athun%2Cmail%20quick%20search%2Cfilter%20%22display%20name%22;list_id=3085909

That's a bmo quicksearch for
:thun,mail quick search,filter "display name"

So this becomes a duplicate of
Bug 460737 - Quickfilter ignores searches for friendly display names from address book contacts, as displayed on message header and message list by default (no or incomplete results for From, To, CC, BCC)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460737
You need to log in before you can comment on or make changes to this bug.