Last Comment Bug 730530 - alliances.commandandconquer.com - Buttons not visible in Tiberium Alliances
: alliances.commandandconquer.com - Buttons not visible in Tiberium Alliances
Status: RESOLVED FIXED
[topapps], [website-compatibility]
: regression
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: All All
: -- normal
: ---
Assigned To: english-us
:
Mentors:
Depends on: 497995 713643
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-24 18:56 PST by David Mandelin [:dmandelin]
Modified: 2015-04-19 23:39 PDT (History)
12 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David Mandelin [:dmandelin] 2012-02-24 18:56:13 PST
It's a game that's in closed beta. I should be able to get a key for someone who needs to test this. I also have it, so you could use my machine to run some tests.

The basic STR are:

1. Go to http://alliances.commandandconquer.com/en/
2. Log in (if not already logged in)

Expected result: See "My Games", then a header thingy, then "Closed Beta 2", going down the page.
Actual result: the header thingy is invisible, although you can still click on it.

The bug also affects buttons and dialogs in the game: instead of having the desired background, they have a mostly transparent (and thus pretty hard to use) background.

This was regressed by bug 497995, specifically:

changeset:   83265:dda1146d1ec3
user:        William Chen <wchen@mozilla.com>
date:        Thu Dec 22 18:34:45 2011 -0500
summary:     Bug 497995: Part 1 - Implement border-image revisions in latest css3-background spec. r=dbaron

It looks like bug 713643 might be for some related issues.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-24 19:45:48 PST
The relevant bits of CSS from the website would be useful here.
Comment 2 David Mandelin [:dmandelin] 2012-02-28 18:59:17 PST
According to the DOM inspector, the element in question is (URL removed):

<div style="-moz-border-image: url("blah.png") 6 6 6 6 / 1 1 1 1 / 0 0 0 0 stretch stretch; position: absolute; line-height: 0; font-size: 0px; overflow: hidden; -moz-box-sizing: border-box; border-width: 6px; top: 0px; left: 0px; pointer-events: none; width: 399px; height: 36px; z-index: 5;"></div>
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-07 11:25:40 PST
They need a border-style of some sort now.  This is a TE bug.
Comment 4 Jean-Yves Perrier [:teoli] 2012-03-07 23:35:02 PST
It would useful if somebody who got a key directly from them for the closed beta contact them. I bet they are listening to their beta testers.
Comment 5 Chris Lawson (gone) 2012-03-08 05:09:43 PST
David: why don't you act as a contact person, since you're a "beta tester"?
Comment 6 David Mandelin [:dmandelin] 2012-03-09 14:31:18 PST
(In reply to Chris Lawson from comment #5)
> David: why don't you act as a contact person, since you're a "beta tester"?

Sure thing. I'm no expert on CSS, so could you please clarify for me what

>They need a border-style of some sort now.

means, and I'll communicate with the EA devs?
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-09 15:09:11 PST
(In reply to David Mandelin from comment #6)
> (In reply to Chris Lawson from comment #5)
> > David: why don't you act as a contact person, since you're a "beta tester"?
> 
> Sure thing. I'm no expert on CSS, so could you please clarify for me what
> 
> >They need a border-style of some sort now.
> 
> means, and I'll communicate with the EA devs?

Basically, -moz-border-image implies border-style: solid.  With the unprefixed version (which will probably ship in 13) it no longer implies that.
Comment 8 David Mandelin [:dmandelin] 2012-03-09 18:26:39 PST
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #7)
> Basically, -moz-border-image implies border-style: solid.  With the
> unprefixed version (which will probably ship in 13) it no longer implies
> that.

Thanks. I passed that on to one of the devs.
Comment 9 Jason Smith [:jsmith] 2012-06-08 17:45:07 PDT
(In reply to David Mandelin from comment #8)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #7)
> > Basically, -moz-border-image implies border-style: solid.  With the
> > unprefixed version (which will probably ship in 13) it no longer implies
> > that.
> 
> Thanks. I passed that on to one of the devs.

David - Do you know if the devs got back to you on this? Was this problem fixed? This happens to be a tier 1 app for the mozilla marketplace, so if we need to get traction on this, let me know.
Comment 10 Bryan Price 2012-07-23 10:17:48 PDT
This bug has existed since version 15 (funny, since I was running 15.0A1 nightly when I signed up and couldn't figure out what was going on with the game, I assumed it was the game, not the browser...)

14, 13 and 12 have all worked well with this game for me.

Which means when 15 does get released, all of us FF players will be screwed, as I can't think of anyone who doesn't use Firefox and Greasemonkey for some nice game addons.

From my eye, it just seems that some of the textures aren't being downloaded and/or used.  On a very slow connection, 13 looked a lot like 15 shows until everything gets downloaded from the server.  I had that experience a couple weeks ago while I was on vacation. :S  I never noticed an issue with game mechanics though.

And I'm replying because an alliance mate running 15 Beta has found he can't read what's written now.
Comment 11 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-07-23 10:22:09 PDT
This is a website bug.

David, what was the result of your outreach efforts?
Comment 12 Jason Smith [:jsmith] 2012-07-23 10:26:44 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #11)
> This is a website bug.
> 
> David, what was the result of your outreach efforts?

FYI - I also outreached via BD (Thomas Elin) to EA directly with a report of what to do to fix their site. Tom might be a good person to also ask about this.
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-23 14:04:30 PDT
Tracking so can try to avoid shipping this regression.
Comment 14 David Mandelin [:dmandelin] 2012-07-25 16:01:08 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #11)
> This is a website bug.
> 
> David, what was the result of your outreach efforts?

Someone at EA told me the bug was in the framework they use to build the site, not in their code, so they couldn't fix it directly. I think they said they could try to report a bug, or fix it, or something, but clearly nothing's happened yet. I'll ask again.
Comment 15 Lawrence Mandel [:lmandel] (use needinfo) 2012-07-27 19:45:09 PDT
(In reply to David Mandelin [:dmandelin] from comment #14)
> Someone at EA told me the bug was in the framework they use to build the
> site, not in their code, so they couldn't fix it directly. I think they said
> they could try to report a bug, or fix it, or something, but clearly
> nothing's happened yet. I'll ask again.

Can you ask what framework EA uses so that we can work to get the framework updated?
Comment 16 Tobias Tost 2012-07-29 23:41:57 PDT
We use qooxdoo - rolled out to revision 1.4 in production which still have the issue. But they already did some changes to the framework a while ago with 

https://github.com/qooxdoo/qooxdoo/commit/d64a808153c79434c9c09ff3fe0dea3a67443a45

which means that the issue no longer exists in our products - we upgraded to revision 2.0.1 which got the fix in, already. It should be out on production servers during the next 2-3 weeks.
Comment 17 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-20 15:57:48 PDT
We're shipping FF15 on August 28th - will your framework be updated by then? Does bug 778137 still exist once updated?
Comment 18 Bryan Price 2012-08-20 16:11:07 PDT
The current 15.0 beta renders the game properly.  I believe this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.