Last Comment Bug 713643 - [css3-background] fix followup issues from bug 497995 and unprefix border-image property
: [css3-background] fix followup issues from bug 497995 and unprefix border-ima...
Status: RESOLVED FIXED
[qa+]
: dev-doc-complete
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: mozilla15
Assigned To: David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
:
Mentors:
Depends on: 776538 778137 770797
Blocks: css3-background k9o-web-platform 460146 714941 715515 720531 730530 ringmark-ring1 748253
  Show dependency treegraph
 
Reported: 2011-12-27 06:27 PST by David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
Modified: 2012-09-04 00:13 PDT (History)
33 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
+
fixed
+
verified
+
verified
fixed
-
15+


Attachments
Backout patch for aurora (226.34 KB, patch)
2012-02-13 14:10 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review
Backout for 13 (229.22 KB, patch)
2012-04-24 13:07 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
no flags Details | Diff | Splinter Review
Serialize border-image shorthand to shortest form, with the exception that we'll always serialize 'border-image-source'. (, patch 1) (7.32 KB, patch)
2012-05-30 20:33 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
bzbarsky: review+
Details | Diff | Splinter Review
Make the serialization of the 'border' shorthand fail when we have a 'border-image' subproperty or a '-moz-border-*-colors' property with a non-default value. (, patch 2) (2.12 KB, patch)
2012-05-30 20:33 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
bzbarsky: review+
Details | Diff | Splinter Review
Remove nsStyleBorder::GetActualBorder, since it now does the same thing as nsStyleBorder::GetComputedBorder. (, patch 3) (16.59 KB, patch)
2012-05-30 20:33 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
bzbarsky: review+
Details | Diff | Splinter Review
Rename nsStyleBorder::GetActualBorderWidth to GetComputedBorderWidth. (, patch 4) (13.21 KB, patch)
2012-05-30 20:34 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
bzbarsky: review+
Details | Diff | Splinter Review
Unprefix the border-image-* properties and add a temporary alias for -moz-border-image (but not for its subproperties, which we haven't shipped prefixed). (, patch 5) (106.22 KB, patch)
2012-05-30 20:34 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
bzbarsky: review+
Details | Diff | Splinter Review
screenshot compare 6-02 nightly vs FF13RC1 (1.37 MB, image/png)
2012-06-02 10:35 PDT, Tony Chung [:tchung]
no flags Details

Description David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-12-27 06:27:33 PST
Bug 497995 landed major changes to border-image for Firefox 12.  Since the spec is now in CR, we can unprefix the property.  Additionally, we really shouldn't inflict a second, incompatible prefixed version on Web developers, which means we should do the unprefixing in the same release as bug 497995, i.e., Firefox 12.  This requires submitting some tests to the CSS Working Group.

There are also a bunch of followup issues to fix described in that bug, in particular, from bug 497995 comment 29:

> Declaration.cpp:
> 
>   Maybe this should be better about serializing to shorter forms when
>   possible?  In other words, there's a principle in CSS serialization
>   (suggested by DOM Level 2 Style) that it's best to output the shortest
>   form possible.  This should probably be a FOLLOWUP BUG.
> 
>   The serialization code for the 'border' shorthand needs to check that
>   border-image-* are initial values (and -moz-border-*-colors).  This is
>   an existing bug, so best handled in a FOLLOWUP BUG.
> 
> nsStyleStruct.cpp:
> 
>   Based on my reading of the spec, GetActualBorder() is basically no
>   longer needed.  You should, for now, make it an inline method that
>   just returns mComputedBorder.  You need tests to cover this as well.
>   A FOLLOWUP PATCH should remove the method.
> 
> However, additionally, before this lands, we'll also want to get a patch
> to unprefix these properties.  We can do this since the spec is in CR,
> as long as we contribute tests to the CSS working group simultaneously.
> I want the unprefixing to land in the SAME RELEASE as this patch.  In
> order to unprefix, I'd also like to look through our test suite and make
> sure I'm happy with the coverage.  (One gap that I noticed is that I
> don't think we have tests of the border-image slices overlapping, which
> should also be fixed in a FOLLOWUP BUG.)
> 
> We need to get a FOLLOWUP BUG filed on supporting
> 'border-image-repeat: space', which is also new, and which this patch
> does not add support for.
Comment 1 Alex Keybl [:akeybl] 2012-01-03 10:10:30 PST
(In reply to David Baron [:dbaron] from comment #0)
> Additionally, we really
> shouldn't inflict a second, incompatible prefixed version on Web developers,
> which means we should do the unprefixing in the same release as bug 497995,
> i.e., Firefox 12.  This requires submitting some tests to the CSS Working
> Group.

Tracking to either fix this bug or backout 497995 due to the concern of releasing the incompatible (and unfinalized) version.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-02-01 01:11:48 PST
Time to backout bug 497995, I guess.
Comment 3 Alex Keybl [:akeybl] 2012-02-05 12:36:54 PST
Hey Kyle - do you agree that the best next action is to backout bug 497995 from Aurora 12?
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-05 12:39:10 PST
That's a question for David.
Comment 5 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-02-05 14:23:03 PST
(In reply to Alex Keybl [:akeybl] from comment #3)
> Hey Kyle - do you agree that the best next action is to backout bug 497995
> from Aurora 12?

Yes, I think we should do this.
Comment 6 Maxim Iorsh 2012-02-06 10:30:51 PST
Please note: the newly submitted pageInfo.js patch uses getPropertyCSSValue("-moz-border-image-source"). If it breaks upon backing out (I don't know if it should), replace "-moz-border-image-source" with "-moz-border-image". Regression test browser_bug460146.js is expected to detect this.
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-02-13 14:10:23 PST
Created attachment 596785 [details] [diff] [review]
Backout patch for aurora

We don't want to ship this in the current state, so lets back it out on Aurora.
Comment 8 Alex Keybl [:akeybl] 2012-02-14 11:22:05 PST
Comment on attachment 596785 [details] [diff] [review]
Backout patch for aurora

[Triage Comment]
Low-risk backout - approved for Aurora 12.
Comment 9 Justin Wood (:Callek) 2012-03-08 23:23:12 PST
Kyle.... Can you either verify this backout landed on aurora (with a cset) or correct the problem applying it:

$ hg qpush
applying diff.diff
patching file browser/app/profile/extensions/testpilot@labs.mozilla.com/content/browser.css
Hunk #1 FAILED at 29
1 out of 1 hunks FAILED -- saving rejects to file browser/app/profile/extensions/testpilot@labs.mozi
lla.com/content/browser.css.rej
patching file browser/themes/gnomestripe/browser.css
Hunk #1 FAILED at 1226
Hunk #2 FAILED at 1487
Hunk #3 FAILED at 1661
Hunk #4 FAILED at 2108
Hunk #5 FAILED at 2140
5 out of 5 hunks FAILED -- saving rejects to file browser/themes/gnomestripe/browser.css.rej
patching file browser/themes/pinstripe/browser.css
Hunk #1 FAILED at 1841
Hunk #2 FAILED at 2075
Hunk #3 FAILED at 2299
Hunk #4 FAILED at 2851
Hunk #5 FAILED at 2883
5 out of 5 hunks FAILED -- saving rejects to file browser/themes/pinstripe/browser.css.rej
patching file browser/themes/winstripe/browser.css
Hunk #1 FAILED at 1808
Hunk #2 FAILED at 2005
Hunk #3 FAILED at 2305
Hunk #4 FAILED at 2788
Hunk #5 FAILED at 2820
5 out of 5 hunks FAILED -- saving rejects to file browser/themes/winstripe/browser.css.rej
patching file dom/interfaces/css/nsIDOMCSS2Properties.idl
Hunk #1 FAILED at 45
Hunk #2 FAILED at 767
2 out of 2 hunks FAILED -- saving rejects to file dom/interfaces/css/nsIDOMCSS2Properties.idl.rej
patching file layout/base/nsCSSRendering.cpp
Hunk #1 FAILED at 2707
Hunk #2 FAILED at 2729
Hunk #3 FAILED at 3004
3 out of 3 hunks FAILED -- saving rejects to file layout/base/nsCSSRendering.cpp.rej
patching file layout/base/nsDisplayList.cpp
Hunk #1 FAILED at 1446
1 out of 1 hunks FAILED -- saving rejects to file layout/base/nsDisplayList.cpp.rej
patching file layout/base/nsImageLoader.cpp
Hunk #1 FAILED at 173
Hunk #2 FAILED at 200
Hunk #3 FAILED at 230
3 out of 3 hunks FAILED -- saving rejects to file layout/base/nsImageLoader.cpp.rej
patching file layout/base/nsImageLoader.h
Hunk #1 FAILED at 63
Hunk #2 FAILED at 95
2 out of 2 hunks FAILED -- saving rejects to file layout/base/nsImageLoader.h.rej
patching file layout/base/nsPresContext.cpp
Hunk #1 FAILED at 1414
1 out of 1 hunks FAILED -- saving rejects to file layout/base/nsPresContext.cpp.rej
patching file layout/base/nsStyleConsts.h
Hunk #1 FAILED at 322
1 out of 1 hunks FAILED -- saving rejects to file layout/base/nsStyleConsts.h.rej
patching file layout/base/tests/Makefile.in
Hunk #1 FAILED at 83
1 out of 1 hunks FAILED -- saving rejects to file layout/base/tests/Makefile.in.rej
file layout/base/tests/test_bug445810.html already exists
1 out of 1 hunks FAILED -- saving rejects to file layout/base/tests/test_bug445810.html.rej
patching file layout/generic/nsFrame.cpp
Hunk #1 FAILED at 4792
1 out of 1 hunks FAILED -- saving rejects to file layout/generic/nsFrame.cpp.rej
patching file layout/reftests/border-image/470250-1.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/470250-1.html.rej
patching file layout/reftests/border-image/470250-2.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/470250-2.html.rej
unable to find 'layout/reftests/border-image/border-image-nofill-1-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-nofill-1
-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-nofill-1.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-nofill-1
.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-1-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-1
-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-1a.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-1
a.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-1b.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-1
b.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-1c.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-1
c.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-move-1-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-m
ove-1-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-move-1.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-m
ove-1.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-resize-1-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-r
esize-1-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-outset-resize-1.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-outset-r
esize-1.html.rej
unable to find 'layout/reftests/border-image/border-image-style-none-auto-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-style-no
ne-auto-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-style-none-auto.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-style-no
ne-auto.html.rej
unable to find 'layout/reftests/border-image/border-image-style-none-length-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-style-no
ne-length-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-style-none-length.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-style-no
ne-length.html.rej
unable to find 'layout/reftests/border-image/border-image-style-none-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-style-no
ne-ref.html.rej
unable to find 'layout/reftests/border-image/border-image-style-none.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-style-no
ne.html.rej
unable to find 'layout/reftests/border-image/border-image-width-1-ref.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-width-1-
ref.html.rej
unable to find 'layout/reftests/border-image/border-image-width-1a.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-width-1a
.html.rej
unable to find 'layout/reftests/border-image/border-image-width-1b.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-width-1b
.html.rej
unable to find 'layout/reftests/border-image/border-image-width-1c.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/border-image-width-1c
.html.rej
patching file layout/reftests/border-image/center-scaling-1.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-1.html
.rej
patching file layout/reftests/border-image/center-scaling-2.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-2.html
.rej
patching file layout/reftests/border-image/center-scaling-3.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-3.html
.rej
patching file layout/reftests/border-image/center-scaling-4b.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-4b.htm
l.rej
patching file layout/reftests/border-image/center-scaling-4l.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-4l.htm
l.rej
patching file layout/reftests/border-image/center-scaling-4lr.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-4lr.ht
ml.rej
patching file layout/reftests/border-image/center-scaling-4r.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-4r.htm
l.rej
patching file layout/reftests/border-image/center-scaling-4t.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-4t.htm
l.rej
patching file layout/reftests/border-image/center-scaling-4tb.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/center-scaling-4tb.ht
ml.rej
patching file layout/reftests/border-image/different-h-v-1.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/different-h-v-1.html.
rej
patching file layout/reftests/border-image/different-h-v-2.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/different-h-v-2.html.
rej
patching file layout/reftests/border-image/multicolor-image-1.html
Hunk #1 FAILED at 1
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/multicolor-image-1.ht
ml.rej
patching file layout/reftests/border-image/multicolor-image-2.html
Hunk #1 FAILED at 7
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/multicolor-image-2.ht
ml.rej
patching file layout/reftests/border-image/multicolor-image-3-ref.html
Hunk #1 FAILED at 7
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/multicolor-image-3-re
f.html.rej
patching file layout/reftests/border-image/multicolor-image-3.html
Hunk #1 FAILED at 7
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/multicolor-image-3.ht
ml.rej
patching file layout/reftests/border-image/multicolor-image-4.html
Hunk #1 FAILED at 24
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/multicolor-image-4.ht
ml.rej
patching file layout/reftests/border-image/multicolor-image-5.html
Hunk #1 FAILED at 25
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/multicolor-image-5.ht
ml.rej
patching file layout/reftests/border-image/reftest.list
Hunk #1 FAILED at 0
Hunk #2 FAILED at 19
2 out of 2 hunks FAILED -- saving rejects to file layout/reftests/border-image/reftest.list.rej
patching file layout/reftests/border-image/repeat-image-1.html
Hunk #1 FAILED at 3
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/repeat-image-1.html.r
ej
patching file layout/reftests/border-image/solid-image-1.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/solid-image-1.html.re
j
unable to find 'layout/reftests/border-image/solid-image-1a.html' for patching
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/solid-image-1a.html.r
ej
patching file layout/reftests/border-image/solid-image-2.html
Hunk #1 FAILED at 1
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/solid-image-2.html.re
j
patching file layout/reftests/border-image/solid-image-2a.html
Hunk #1 FAILED at 1
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/border-image/solid-image-2a.html.r
ej
patching file layout/reftests/bugs/468473-1.xul
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/bugs/468473-1.xul.rej
patching file layout/reftests/pixel-rounding/border-image-width-0.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/pixel-rounding/border-image-width-
0.html.rej
patching file layout/reftests/pixel-rounding/border-image-width-10.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/pixel-rounding/border-image-width-
10.html.rej
patching file layout/reftests/pixel-rounding/border-image-width-4.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/pixel-rounding/border-image-width-
4.html.rej
patching file layout/reftests/pixel-rounding/border-image-width-9.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/pixel-rounding/border-image-width-
9.html.rej
patching file layout/reftests/svg/as-image/border-image-simple-1.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/svg/as-image/border-image-simple-1
.html.rej
patching file layout/reftests/svg/as-image/border-image-simple-2.html
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/svg/as-image/border-image-simple-2
.html.rej
patching file layout/style/Declaration.cpp
Hunk #1 FAILED at 293
1 out of 1 hunks FAILED -- saving rejects to file layout/style/Declaration.cpp.rej
patching file layout/style/nsCSSParser.cpp
Hunk #1 FAILED at 0
Hunk #2 FAILED at 123
Hunk #3 FAILED at 150
Hunk #4 FAILED at 476
Hunk #5 FAILED at 558
Hunk #6 FAILED at 5219
Hunk #7 FAILED at 5476
Hunk #8 FAILED at 6305
Hunk #9 FAILED at 6641
9 out of 9 hunks FAILED -- saving rejects to file layout/style/nsCSSParser.cpp.rej
patching file layout/style/nsCSSPropList.h
Hunk #1 FAILED at 693
1 out of 1 hunks FAILED -- saving rejects to file layout/style/nsCSSPropList.h.rej
patching file layout/style/nsCSSProps.cpp
Hunk #1 FAILED at 645
Hunk #2 FAILED at 1680
Hunk #3 FAILED at 2074
3 out of 3 hunks FAILED -- saving rejects to file layout/style/nsCSSProps.cpp.rej
patching file layout/style/nsCSSProps.h
Hunk #1 FAILED at 337
1 out of 1 hunks FAILED -- saving rejects to file layout/style/nsCSSProps.h.rej
patching file layout/style/nsCSSValue.cpp
Hunk #1 FAILED at 0
Hunk #2 FAILED at 746
Hunk #3 FAILED at 1198
3 out of 3 hunks FAILED -- saving rejects to file layout/style/nsCSSValue.cpp.rej
patching file layout/style/nsCSSValue.h
Hunk #1 FAILED at 757
1 out of 1 hunks FAILED -- saving rejects to file layout/style/nsCSSValue.h.rej
patching file layout/style/nsComputedDOMStyle.cpp
Hunk #1 FAILED at 0
Hunk #2 FAILED at 2834
Hunk #3 FAILED at 4612
3 out of 3 hunks FAILED -- saving rejects to file layout/style/nsComputedDOMStyle.cpp.rej
patching file layout/style/nsComputedDOMStyle.h
Hunk #1 FAILED at 254
1 out of 1 hunks FAILED -- saving rejects to file layout/style/nsComputedDOMStyle.h.rej
patching file layout/style/nsRuleNode.cpp
Hunk #1 FAILED at 0
Hunk #2 FAILED at 568
Hunk #3 FAILED at 599
Hunk #4 FAILED at 653
Hunk #5 FAILED at 5266
Hunk #6 FAILED at 5625
6 out of 6 hunks FAILED -- saving rejects to file layout/style/nsRuleNode.cpp.rej
patching file layout/style/nsStyleStruct.cpp
Hunk #1 FAILED at 392
Hunk #2 FAILED at 442
Hunk #3 FAILED at 496
Hunk #4 FAILED at 566
Hunk #5 FAILED at 596
5 out of 5 hunks FAILED -- saving rejects to file layout/style/nsStyleStruct.cpp.rej
patching file layout/style/nsStyleStruct.h
Hunk #1 FAILED at 738
Hunk #2 FAILED at 775
Hunk #3 FAILED at 841
Hunk #4 FAILED at 883
4 out of 4 hunks FAILED -- saving rejects to file layout/style/nsStyleStruct.h.rej
patching file layout/style/nsStyleStructInlines.h
Hunk #1 FAILED at 45
1 out of 1 hunks FAILED -- saving rejects to file layout/style/nsStyleStructInlines.h.rej
patching file layout/style/test/property_database.js
Hunk #1 FAILED at 227
Hunk #2 FAILED at 1608
2 out of 2 hunks FAILED -- saving rejects to file layout/style/test/property_database.js.rej
patching file layout/style/test/test_shorthand_property_getters.html
Hunk #1 FAILED at 163
1 out of 1 hunks FAILED -- saving rejects to file layout/style/test/test_shorthand_property_getters.
html.rej
patching file toolkit/themes/pinstripe/global/preferences.css
Hunk #1 FAILED at 79
1 out of 1 hunks FAILED -- saving rejects to file toolkit/themes/pinstripe/global/preferences.css.re
j
patch failed, unable to continue (try -v)
layout/reftests/border-image/border-image-nofill-1-ref.html not tracked!
layout/reftests/border-image/border-image-nofill-1.html not tracked!
layout/reftests/border-image/border-image-outset-1-ref.html not tracked!
layout/reftests/border-image/border-image-outset-1a.html not tracked!
layout/reftests/border-image/border-image-outset-1b.html not tracked!
layout/reftests/border-image/border-image-outset-1c.html not tracked!
layout/reftests/border-image/border-image-outset-move-1-ref.html not tracked!
layout/reftests/border-image/border-image-outset-move-1.html not tracked!
layout/reftests/border-image/border-image-outset-resize-1-ref.html not tracked!
layout/reftests/border-image/border-image-outset-resize-1.html not tracked!
layout/reftests/border-image/border-image-style-none-auto-ref.html not tracked!
layout/reftests/border-image/border-image-style-none-auto.html not tracked!
layout/reftests/border-image/border-image-style-none-length-ref.html not tracked!
layout/reftests/border-image/border-image-style-none-length.html not tracked!
layout/reftests/border-image/border-image-style-none-ref.html not tracked!
layout/reftests/border-image/border-image-style-none.html not tracked!
layout/reftests/border-image/border-image-width-1-ref.html not tracked!
layout/reftests/border-image/border-image-width-1a.html not tracked!
layout/reftests/border-image/border-image-width-1b.html not tracked!
layout/reftests/border-image/border-image-width-1c.html not tracked!
layout/reftests/border-image/solid-image-1a.html not tracked!
layout\reftests\border-image\border-image-nofill-1-ref.html: The system cannot find the file specifi
ed
layout\reftests\border-image\border-image-nofill-1.html: The system cannot find the file specified
layout\reftests\border-image\border-image-outset-1-ref.html: The system cannot find the file specifi
ed
layout\reftests\border-image\border-image-outset-1a.html: The system cannot find the file specified
layout\reftests\border-image\border-image-outset-1b.html: The system cannot find the file specified
layout\reftests\border-image\border-image-outset-1c.html: The system cannot find the file specified
layout\reftests\border-image\border-image-outset-move-1-ref.html: The system cannot find the file sp
ecified
layout\reftests\border-image\border-image-outset-move-1.html: The system cannot find the file specif
ied
layout\reftests\border-image\border-image-outset-resize-1-ref.html: The system cannot find the file
specified
layout\reftests\border-image\border-image-outset-resize-1.html: The system cannot find the file spec
ified
layout\reftests\border-image\border-image-style-none-auto-ref.html: The system cannot find the file
specified
layout\reftests\border-image\border-image-style-none-auto.html: The system cannot find the file spec
ified
layout\reftests\border-image\border-image-style-none-length-ref.html: The system cannot find the fil
e specified
layout\reftests\border-image\border-image-style-none-length.html: The system cannot find the file sp
ecified
layout\reftests\border-image\border-image-style-none-ref.html: The system cannot find the file speci
fied
layout\reftests\border-image\border-image-style-none.html: The system cannot find the file specified

layout\reftests\border-image\border-image-width-1-ref.html: The system cannot find the file specifie
d
layout\reftests\border-image\border-image-width-1a.html: The system cannot find the file specified
layout\reftests\border-image\border-image-width-1b.html: The system cannot find the file specified
layout\reftests\border-image\border-image-width-1c.html: The system cannot find the file specified
layout\reftests\border-image\solid-image-1a.html: The system cannot find the file specified
patch failed, rejects left in working dir
errors during apply, please fix and refresh diff.diff
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-09 07:32:34 PST
It was backed out of Aurora in http://hg.mozilla.org/releases/mozilla-aurora/rev/c81d62b02d19
Comment 11 Alex Keybl [:akeybl] 2012-04-04 14:45:55 PDT
Kyle - should we prepare a backout for Aurora 13, and also FF14 to prevent the need for future backouts?
Comment 12 rob64rock 2012-04-13 06:53:12 PDT
(In reply to Alex Keybl [:akeybl] from comment #11)
> Kyle - should we prepare a backout for Aurora 13, and also FF14 to prevent
> the need for future backouts?

I would think so, since there's only 10 days left until Aurora 13 shifts to the Beta channel and the issues caused by bug 497995 landing still haven't been resolved.
Comment 13 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-04-18 07:18:31 PDT
I have patches for these issues in my tree (wrote them on the airplane):

https://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/1f0dbcf5f443/border-image-short-serialization
https://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/1f0dbcf5f443/border-shorthand-dont-serialize
https://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/1f0dbcf5f443/remove-get-actual-border
https://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/1f0dbcf5f443/rename-get-actual-border-width
https://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/1f0dbcf5f443/unprefix-border-image

and also:
https://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/1f0dbcf5f443/computed-style-no-internal-moz-prefixes
which probably belongs on another bug.

I have not yet attempted to compile them.  I also need to do a lot more going through tests for the actual unprefixing patch.

(I suspect this is going to get harder and harder to back out; I think an optimization patch roc wrote recently may depend on not having the reflow code for border-image.)
Comment 14 Alex Keybl [:akeybl] 2012-04-24 13:07:33 PDT
Comment on attachment 596785 [details] [diff] [review]
Backout patch for aurora

[Triage Comment]
Approved for Beta 13 since this didn't make the merge.
Comment 15 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-24 13:07:35 PDT
Created attachment 618007 [details] [diff] [review]
Backout for 13
Comment 16 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-24 13:10:57 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/365f578a5bfb
Comment 18 Jason Smith [:jsmith] 2012-05-03 11:11:52 PDT
Marking qa+ - We need to verify this fix for beta.
Comment 19 Jason Smith [:jsmith] 2012-05-05 14:29:56 PDT
Nominating for kilimanjaro. This implementation of this bug is critical, as without it, it will end up breaking top sites/apps. Known partner apps this affects include:

- Lord of Ultima with EA
- Command and Conquer Tiberium Alliances
- Mobile Facebook

We may need to rethink bug 497995's requirement for border-style: solid, as I am already seeing the lack of use of that is breaking top sites (see the associated evangelism bugs with those 3 apps).
Comment 20 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-05 23:20:11 PDT
(In reply to Jason Smith [:jsmith] from comment #19)
> Nominating for kilimanjaro. This implementation of this bug is critical, as
> without it, it will end up breaking top sites/apps. Known partner apps this
> affects include:
> 
> - Lord of Ultima with EA
> - Command and Conquer Tiberium Alliances
> - Mobile Facebook
> 
> We may need to rethink bug 497995's requirement for border-style: solid, as
> I am already seeing the lack of use of that is breaking top sites (see the
> associated evangelism bugs with those 3 apps).

That's not what *this* bug is about.

However, this bug *is* about getting to the state that we want to be in per spec, and testing how sites deal with *that* state is a prerequisite for making any decisions about changes we want to push for in the spec.

(I could finish this with a few hours work, but I've been asked to spend 100% of my time on font size inflation.)
Comment 21 Jason Smith [:jsmith] 2012-05-06 02:00:11 PDT
Removing the k9o flag for now until we determine how to track the border-style: solid concern in linking to border-image.

(In reply to David Baron [:dbaron] from comment #20)
> (In reply to Jason Smith [:jsmith] from comment #19)
> > Nominating for kilimanjaro. This implementation of this bug is critical, as
> > without it, it will end up breaking top sites/apps. Known partner apps this
> > affects include:
> > 
> > - Lord of Ultima with EA
> > - Command and Conquer Tiberium Alliances
> > - Mobile Facebook
> > 
> > We may need to rethink bug 497995's requirement for border-style: solid, as
> > I am already seeing the lack of use of that is breaking top sites (see the
> > associated evangelism bugs with those 3 apps).
> 
> That's not what *this* bug is about.

Ah right, makes sense.

> 
> However, this bug *is* about getting to the state that we want to be in per
> spec, and testing how sites deal with *that* state is a prerequisite for
> making any decisions about changes we want to push for in the spec.
> 

Right. Should I track the border-style: solid concern in a separate bug in this component and link the evangelism bugs there? Just wondering cause bug comments such as https://bugzilla.mozilla.org/show_bug.cgi?id=730530#c7, https://bugzilla.mozilla.org/show_bug.cgi?id=715515#c15, https://bugzilla.mozilla.org/show_bug.cgi?id=748253#c25 all imply that top sites are going to need to add "border-style: solid" to avoid serious regressions in how they are using moz-border-image, even after this implementation lands. Just looking to identify that if we already know this could cause serious top site/app regressions, then let's identify it and log it.

> (I could finish this with a few hours work, but I've been asked to spend
> 100% of my time on font size inflation.)

Gotcha.

Side note - Should we update this doc - https://developer.mozilla.org/en/CSS/border-image to reflect the release change? That might explain why some confusion may be arising from some of the evangelism bugs attached to this bug.
Comment 22 JP Rosevear [:jpr] 2012-05-08 08:09:22 PDT
Jason, is there a particular reason you are nomming this?
Comment 23 Jason Smith [:jsmith] 2012-05-08 08:16:05 PDT
(In reply to JP Rosevear [:jpr] from comment #22)
> Jason, is there a particular reason you are nomming this?

Originally nominated it per comment 19 (the current implementation approach per the spec will lead to severe functionality regressions in at least 3 tier 1 apps - Mobile Facebook, Lord of Ultima, Command and Conquer), although per David's followup comment and email thread, I wanted to wait until we get final confirmation from the CSS working group meetings that the border-image implementation issue we have currently will still exist in the spec or not.
Comment 24 Jason Smith [:jsmith] 2012-05-08 08:18:04 PDT
(In reply to Jason Smith [:jsmith] from comment #23)
> (In reply to JP Rosevear [:jpr] from comment #22)
> > Jason, is there a particular reason you are nomming this?
> 
> Originally nominated it per comment 19 (the current implementation approach
> per the spec will lead to severe functionality regressions in at least 3
> tier 1 apps - Mobile Facebook, Lord of Ultima, Command and Conquer),
> although per David's followup comment and email thread, I wanted to wait
> until we get final confirmation from the CSS working group meetings that the
> border-image implementation issue we have currently will still exist in the
> spec or not.

Also - See bug 715515, bug 730530, and bug 748253 for more information.
Comment 25 Jason Smith [:jsmith] 2012-05-15 09:56:53 PDT
FYI - This is active on firefox mobile beta 14 on the market (it's confirmed to be active.
Comment 26 Jason Smith [:jsmith] 2012-05-15 10:03:38 PDT
Kyle - Could we get a backout for FF 14?
Comment 27 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-15 10:52:59 PDT
I think we should try to fix this and uplift to 14.  I'll look at dbaron's patches later this week and see what remains to be done.
Comment 28 Sheila Mooney 2012-05-15 11:42:02 PDT
David, has the spec been finalized, is this the implementation to the spec? Should we back this out until that happens?
Comment 29 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-15 12:00:38 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #27)
> I think we should try to fix this and uplift to 14.  I'll look at dbaron's
> patches later this week and see what remains to be done.

If you do, look at the versions in the tip of my patch queue, since they're more merged.

(In reply to Sheila Mooney from comment #28)
> David, has the spec been finalized, is this the implementation to the spec?
> Should we back this out until that happens?

The spec is in CR.  There's no spec reason to hesitate here.  There might be a Web-compat reason.
Comment 30 Jason Smith [:jsmith] 2012-05-15 13:20:40 PDT
(In reply to David Baron [:dbaron] from comment #29)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #27)
> > I think we should try to fix this and uplift to 14.  I'll look at dbaron's
> > patches later this week and see what remains to be done.
> 
> If you do, look at the versions in the tip of my patch queue, since they're
> more merged.
> 
> (In reply to Sheila Mooney from comment #28)
> > David, has the spec been finalized, is this the implementation to the spec?
> > Should we back this out until that happens?
> 
> The spec is in CR.  There's no spec reason to hesitate here.  There might be
> a Web-compat reason.

Right, the web compat reason is seen in bug 715515, bug 730530, and bug 748253. Is there anything we can do to handle the issues shown in those bugs other than evangelism? Maybe a fallback mechanism?

(I'm a bit nervous with the current proposed spec causing top gecko sites/apps to break)
Comment 31 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-17 09:51:30 PDT
Given the web compat concerns, I think we should probably back out for 14 again.  We should try to land the unprefixing patches with longer lead time so that we can actually try to evangelize with the state we want to be in.
Comment 32 Jason Smith [:jsmith] 2012-05-24 22:14:44 PDT
Sheila - Shouldn't the blocker bug be bug 747123, as this relates to web compatibility?
Comment 33 Jason Smith [:jsmith] 2012-05-24 22:21:58 PDT
(In reply to David Baron [:dbaron] from comment #31)
> Given the web compat concerns, I think we should probably back out for 14
> again.  We should try to land the unprefixing patches with longer lead time
> so that we can actually try to evangelize with the state we want to be in.

Right. Should we go forward with evangelizing border-style: solid usage for the three evangelism bugs attached to this bug (e.g. Mobile Facebook, Lord of Ultima, and Command and Conquer) and other areas? Also btw - I think John is looking into what sites are affected with the border-image requirement for border-style: solid.
Comment 34 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 12:06:23 PDT
To see which tests need adjusting: https://tbpl.mozilla.org/?tree=Try&rev=1a09797f4075
Comment 35 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 17:24:36 PDT
https://tbpl.mozilla.org/?tree=Try&rev=6efc0bb052a2 should have the orange fixed
Comment 36 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 20:33:39 PDT
Created attachment 628583 [details] [diff] [review]
Serialize border-image shorthand to shortest form, with the exception that we'll always serialize 'border-image-source'.  (, patch 1)
Comment 37 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 20:33:48 PDT
Created attachment 628584 [details] [diff] [review]
Make the serialization of the 'border' shorthand fail when we have a 'border-image' subproperty or a '-moz-border-*-colors' property with a non-default value.  (, patch 2)
Comment 38 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 20:33:59 PDT
Created attachment 628585 [details] [diff] [review]
Remove nsStyleBorder::GetActualBorder, since it now does the same thing as nsStyleBorder::GetComputedBorder.  (, patch 3)
Comment 39 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 20:34:10 PDT
Created attachment 628586 [details] [diff] [review]
Rename nsStyleBorder::GetActualBorderWidth to GetComputedBorderWidth.  (, patch 4)
Comment 40 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 20:34:23 PDT
Created attachment 628587 [details] [diff] [review]
Unprefix the border-image-* properties and add a temporary alias for -moz-border-image (but not for its subproperties, which we haven't shipped prefixed).  (, patch 5)
Comment 41 Boris Zbarsky [:bz] (TPAC) 2012-05-30 21:38:56 PDT
Comment on attachment 628583 [details] [diff] [review]
Serialize border-image shorthand to shortest form, with the exception that we'll always serialize 'border-image-source'.  (, patch 1)

I would mildly prefer it if DoAllSidesEqual were called AllSidesEqualTo, and similar for the other three new methods in nsCSSValue.h.

r=me either way.
Comment 42 Boris Zbarsky [:bz] (TPAC) 2012-05-30 21:42:35 PDT
Comment on attachment 628584 [details] [diff] [review]
Make the serialization of the 'border' shorthand fail when we have a 'border-image' subproperty or a '-moz-border-*-colors' property with a non-default value.  (, patch 2)

r=me
Comment 43 Boris Zbarsky [:bz] (TPAC) 2012-05-30 21:43:59 PDT
Comment on attachment 628585 [details] [diff] [review]
Remove nsStyleBorder::GetActualBorder, since it now does the same thing as nsStyleBorder::GetComputedBorder.  (, patch 3)

Please file a bug for that FIXME?

r=me
Comment 44 Boris Zbarsky [:bz] (TPAC) 2012-05-30 21:44:46 PDT
Comment on attachment 628586 [details] [diff] [review]
Rename nsStyleBorder::GetActualBorderWidth to GetComputedBorderWidth.  (, patch 4)

r=me
Comment 45 Boris Zbarsky [:bz] (TPAC) 2012-05-30 21:47:45 PDT
Comment on attachment 628587 [details] [diff] [review]
Unprefix the border-image-* properties and add a temporary alias for -moz-border-image (but not for its subproperties, which we haven't shipped prefixed).  (, patch 5)

r=me; I mostly skimmed the test changes.  I hope that's OK!  ;)
Comment 46 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 22:06:23 PDT
(In reply to David Baron [:dbaron] from comment #0)
> > We need to get a FOLLOWUP BUG filed on supporting
> > 'border-image-repeat: space', which is also new, and which this patch
> > does not add support for.

This is bug 720531.
Comment 47 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 22:09:57 PDT
(In reply to Boris Zbarsky (:bz) from comment #43)
> Comment on attachment 628585 [details] [diff] [review]
> Remove nsStyleBorder::GetActualBorder, since it now does the same thing as
> nsStyleBorder::GetComputedBorder.  (, patch 3)
> 
> Please file a bug for that FIXME?

Filed bug 759996.
Comment 49 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-05-30 22:48:55 PDT
Er, not sure why I resolved this given that I was landing on inbound.
Comment 51 Tony Chung [:tchung] 2012-06-02 10:35:16 PDT
Created attachment 629494 [details]
screenshot compare 6-02 nightly vs FF13RC1

Hi david, 
Im trying to verify if this backout patch applies correctly to FF13 RC1.   If so, i can mark the status-firefox13 flag verified.   Based on this screenshot, you can see border-image is still busted on 6-02 Nightly, but renders usable on FF13.  So two questions:

1) did the backout patch get correctly applied to FF13? 
2) should 6-02 nightly have a corrected fix?

Thanks for clarifying.
Comment 52 Jason Smith [:jsmith] 2012-06-02 23:23:12 PDT
(In reply to Tony Chung [:tchung] from comment #51)
> Created attachment 629494 [details]
> screenshot compare 6-02 nightly vs FF13RC1
> 
> Hi david, 
> Im trying to verify if this backout patch applies correctly to FF13 RC1.  
> If so, i can mark the status-firefox13 flag verified.   Based on this
> screenshot, you can see border-image is still busted on 6-02 Nightly, but
> renders usable on FF13.  So two questions:
> 
> 1) did the backout patch get correctly applied to FF13?

If FF 12 = FF 13 then the backout verifies.

> 2) should 6-02 nightly have a corrected fix?

See bug 748253. This is expected - the border-image syntax is different than the moz-border-image syntax (one example with lord of ultima is that the app developer will need to add "border-style: solid"). This is an evangelism problem now - although as stated above, we still need a backout for FF 14.
Comment 53 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-03 09:36:40 PDT
(In reply to Jason Smith [:jsmith] from comment #52)
> > 1) did the backout patch get correctly applied to FF13? 
> If FF 12 = FF 13 then the backout verifies.

So based on this I think we can call this fixed for Firefox 13. However, we'll just have to trust this is fixed for Firefox 15 until bug 748253 is resolved. Unless, of course, someone can provide a minimized testcase to verify.
Comment 54 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-03 09:58:52 PDT
[Triage Comment]
Looks like we still need to back this out of 14 - can someone confirm this and also prepare the backout?
Comment 55 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-04 11:25:34 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/13723b00e8ce
Comment 56 Claude Nobs 2012-06-06 07:44:09 PDT
just to make sure i understand correctly:
the new border-image syntax/implementation will only be available via unprefixed border-image, while the old -moz-border-image will continue to work as is. or is it that both only support the new syntax (like the current nightly)?
and is the support of border-image-* properties tied to this bug?

btw: https://developer.mozilla.org/en/CSS/CSS_Reference documents all of this to be implemented as of ffx 12/13 so i guess these need updating to avoid confusion.
Comment 57 Simona B [:simonab ] 2012-07-09 08:43:26 PDT
Verified that the backup applies on Firefox 14 beta 11 using the steps from Comment 51 - the render of the border-image on Firefox 14 beta 11 is the same as on Firefox 12 and Firefox 13.

Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0
Comment 58 rob64rock 2012-07-15 12:05:29 PDT
Will this be backed out of Fx Aurora 15.0a2 prior to it's build merge move to the Beta Channel, has done with previous Aurora -> Beta build merges?

Or has there been a work around found for -moz-border-image to appear the same as they do on the Fx Release Channel builds?
Comment 59 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-07-15 13:55:05 PDT
There are no plans for bug 497995 (or this) to be backed out on 15.
Comment 60 Simona B [:simonab ] 2012-08-14 01:29:39 PDT
(In reply to David Baron [:dbaron] from comment #59)
> There are no plans for bug 497995 (or this) to be backed out on 15.

The tracking flag still shows that this is fixed on 15. Does this mean that the back out will happen on Firefox 15 too, or will some other fix be implemented on it?
Comment 61 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-08-14 07:12:49 PDT
No, it means that we fixed the issues and unprefixed on 15, like the bug title says.

The earlier versions are marked fixed because there was no 'disabled' flag at the time.
Comment 62 Jean-Yves Perrier [:teoli] 2012-09-04 00:13:42 PDT
Documented at the same time as bug 497995.

Note You need to log in before you can comment on or make changes to this bug.