Closed Bug 730569 Opened 9 years ago Closed 9 years ago

"Video loading stopped" persists when a page is reloaded prematurely

Categories

(Toolkit :: Video/Audio Controls, defect)

11 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 712836

People

(Reporter: laurencedurant1, Unassigned)

References

Details

(Keywords: regression)

STR:

- Open page with video (I found this bug at http://blog.mozilla.com/verdi/121/ )
- Reload the page while the video is partially loaded
- Attempt to view the video normally

Result:

"Video loading stopped" is displayed and video is faded. Attempts by users to fix this themselves will probably fail; video controls are disabled, reloading the page (including a cache override refresh) does not fix it and closing/undo close tab makes things worse.

With the latter, I found that the audio track started playing twice. I know I've found other occasions where the video loading stopped message is invasive, but this is the most easily replicable one.
Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/fafaf614791f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111206 Firefox/11.0a1 ID:20111206031117
Fails:
http://hg.mozilla.org/mozilla-central/rev/338fae43b9d0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111205 Firefox/11.0a1 ID:20111205235717
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fafaf614791f&tochange=338fae43b9d0

Suspected; Bug 513405
Blocks: 513405
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: unspecified → 11 Branch
Given some of the other issues I've been reading in bugs related to this I think it could be worthwhile to have a way to dismiss these error messages. Perhaps simply clicking them? Might warrant a separate bug.

Fore example, Bug 723097 pointed out the fact that pressing the esc key is supposed to prompt the error message and halt video downloading. But that is also the case while the video is being played. In which case, there's no way to dismiss the message and pause the video or resume downloading.

Lots of hidden quirks with this feature. More will likely turn up in due course, so I'll try to keep my eye out for others.
I agree that we should probably include a way to hide these errors while the video is playing, although this bug is basically the same as bug 712836. I'll put my recommendation there as well.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712836
Ah fair enough! I don't think I would have ever found that duplicate. At least you now have a shorter STR for testing similar issues :D
You need to log in before you can comment on or make changes to this bug.