Bump DOM Inspector compatibility for SeaMonkey 2.10 / Firefox 13.0 / Thunderbird 13.0

VERIFIED FIXED in mozilla13

Status

Other Applications
DOM Inspector
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
mozilla13
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.8 verified, seamonkey2.9 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 600781 [details] [diff] [review]
patch [Checkin: Comment 1]

+++ This bug was initially created as a clone of Bug #702057 +++

Unfortunately we missed bumping the last two times.

The compatibility for SeaMonkey should be changed to 2.10.* and for Firefox and Thunderbird to 13.0.*. This is needed in order to allow users to disable compatible-by-default, and to stop a Toolkit test to succeed which checks the compatibility of all bundled add-ons (only an issue with SeaMonkey, obviously).

rs=sdwilsh
Attachment #600781 - Flags: review+
(Assignee)

Updated

6 years ago
Summary: Bump DOM Inspector compatibility for SeaMonkey 2.8 / Firefox 11.0 / Thunderbird 11.0 → Bump DOM Inspector compatibility for SeaMonkey 2.10 / Firefox 13.0 / Thunderbird 13.0
(Assignee)

Comment 1

6 years ago
Comment on attachment 600781 [details] [diff] [review]
patch [Checkin: Comment 1]

http://hg.mozilla.org/dom-inspector/rev/2997353553b9
Attachment #600781 - Attachment description: patch → patch [Checkin: Comment 1]
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
In SeaMonkey linux64 hourly build with the following (buildstamps) txt file
20120226151249
http://hg.mozilla.org/mozilla-central/rev/b98fc24ac54b
http://hg.mozilla.org/comm-central/rev/892d4207a0dd

seamonkey/distribution/extensions/inspector@mozilla.org.xpi includes an install.rdf with maxVersion set to 13.0a1 for Firefox and Thunderbird, 2.10a1 for SeaMonkey.

I'm setting this VERIFIED but shouldn't it be changed again to at least 13.0a2 / 2.10a2 at next Aurora merge, and to 13.0.* / 2.10.* for Beta six weeks later?
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

6 years ago
Shawn, Venkman and ChatZilla use 13.0.* for the maxVersion, which better matches the new compatible-by-default mode. Would it be OK from your side to have DOMI adapt to that maxVersion scheme, too? If yes, I'll push another update for that, assume rs=you for future bumps with that scheme, and update AMO accordingly.
["Mid-air collision detected!". Anyway:]

(In reply to Tony Mechelynck [:tonymec] from comment #2)
> shouldn't it be changed again to at least
> 13.0a2 / 2.10a2 at next Aurora merge, and to 13.0.* / 2.10.* for Beta six
> weeks later?

Good question.
I'm not too sure how branches are handled: bug 728651 will (soon) detect issues :-)
Should we already update DOMI_2_0_10 branch somehow too?
Should DOMi use 11.0.*/2.8.* syntax as CZ and Venkman do?
status-seamonkey2.8: --- → affected
status-seamonkey2.9: --- → affected
tracking-seamonkey2.8: --- → ?
Blocks: 732749
(In reply to Serge Gautherie (:sgautherie) from comment #4)
> Should we already update DOMI_2_0_10 branch somehow too?

Branch DOMI_2_0_10:
http://hg.mozilla.org/dom-inspector/0ff0b47c92b7
status-seamonkey2.8: affected → fixed
status-seamonkey2.9: affected → fixed
tracking-seamonkey2.8: ? → ---
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1330993224.1330997674.12028.gz
OS X 10.5 comm-aurora debug test mochitest-other on 2012/03/05 16:20:24
{
TEST-PASS | chrome://mochitests/content/browser/suite/browser/test/browser_bug728651.js | DOM Inspector 2.0.10 should be compatible
}

seamonkey2.9: verified.
status-seamonkey2.9: fixed → verified
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Beta/1331027590.1331031477.4635.gz&fulltext=1
OS X 10.5 comm-beta debug test mochitest-other on 2012/03/06 01:53:10

seamonkey2.8: verified.
status-seamonkey2.8: fixed → verified
Depends on: 702057
(In reply to Serge Gautherie (:sgautherie) from comment #4)
> Should DOMi use 11.0.*/2.8.* syntax as CZ and Venkman do?

I filed bug 733373.
Blocks: 733373
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #3)
> Shawn, Venkman and ChatZilla use 13.0.* for the maxVersion, which better
> matches the new compatible-by-default mode. Would it be OK from your side to
> have DOMI adapt to that maxVersion scheme, too? If yes, I'll push another
> update for that, assume rs=you for future bumps with that scheme, and update
> AMO accordingly.
Colby owns this code, so I'll defer to him.
Depends on: 721584
Blocks: 736347
No longer blocks: 732749
You need to log in before you can comment on or make changes to this bug.