Mozilla default icons are not available anymore in marketplace-dev when editing an app.

VERIFIED FIXED in 6.4.4

Status

P1
normal
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: vcarciu, Assigned: potch)

Tracking

unspecified
6.4.4

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 600915 [details]
Screenshot.

Prerequisites:
Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0

Steps to reproduce:
1.Go to https://marketplace-dev.allizom.org/en-US/developers/ and login.
2.Select My Submissions link (https://marketplace-dev.allizom.org/en-US/developers/submissions)
3.Open any owned app and click the Edit button in order to change app icon from Images section

Expected results:
A list of default icons provided by mozilla is displayed together with "Upload custom icon" button

Actual results:
The list with default icons is missing and only one icon (Puzzle) is displayed as default icon. Also, the puzzle icon is cannot be added (icon not available after selecting it and saving the changes)

Please see the attached screenshot for this bug.
(Reporter)

Updated

7 years ago
Blocks: 710074
Did we say there would be no default app icons or am I misremembering?
(Reporter)

Comment 2

7 years ago
I thought that the default apps icons are missing only during submission process, not when editing the app.

Also, if we will not have default icons for apps, please let me know how to consider the unusable "puzzle" icon .
I changed the ADDON_ICONS_DEFAULT_URL and ADDON_ICONS_DEFAULT_PATH for Marketplace, causing the other default icons to not show up. Either way, we agreed that these icons won't show up for Marketplace - in any place. We decided to leave it in for management pages because it was easier to keep them than remove them. But they obviously need to be removed now.
OS: Windows XP → All
Priority: -- → P1
Hardware: x86 → All
Target Milestone: --- → 6.4.4
Assignee: nobody → cvan
(Assignee)

Comment 4

7 years ago
steal'd!
Assignee: cvan → thepotch
(Assignee)

Comment 5

7 years ago
> Ran 442 tests in 267.261s
> 
> OK (SKIP=9)

https://github.com/mozilla/zamboni/commit/414e2bb
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

7 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

7 years ago
Created attachment 601262 [details]
Postfix Screenshot.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.