Last Comment Bug 731043 - Builds from mozilla-beta shouldn't default to official branding
: Builds from mozilla-beta shouldn't default to official branding
Status: RESOLVED FIXED
[qa!:esr10]
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 13
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-27 15:50 PST by Justin Dolske [:Dolske]
Modified: 2012-03-05 08:06 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed
unaffected
unaffected
11+
verified


Attachments
patch (1.10 KB, patch)
2012-02-27 16:20 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
dolske: review+
akeybl: approval‑mozilla‑beta+
akeybl: approval‑mozilla‑release+
akeybl: approval‑mozilla‑esr10+
Details | Diff | Review
m-c patch to add a clarifying comment (1.56 KB, patch)
2012-02-27 16:29 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
dolske: review+
Details | Diff | Review

Description Justin Dolske [:Dolske] 2012-02-27 15:50:21 PST
Earlier today a Gentoo developer dropped into #developers an grumbled about his build giving him official Firefox branding. I was all "lol ur build scripz are teh brok noob!" and shoo'd him away. A problem like that implies either the person building make some mistake, or we did something stupid. And since we _never_ do something stupid I spun up a build to check. Ahem.

Aaaanyway. My build from tip of hg://hg.mozilla.org/releases/mozilla-beta with a minimal mozconfig (just enabling debug and setting an objdir) gives me a build with offical artwork. Sigh. This is a problem on our end and should be fixed. :(

This does raise the question of what the branding _should_ be. Ideally we'd have a nice generic "browser" branding, ala bug 682415. In the meantime we should revert back to using the previous "Aurora" branding (or even Nightly).
Comment 1 Justin Dolske [:Dolske] 2012-02-27 16:10:15 PST
Just to be clear: this is about for the branding of builds people make themselves from the defaults. Official beta builds from Mozilla should have official branding, just as final releases do.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-27 16:15:14 PST
Looks like this was "broken" by:
https://hg.mozilla.org/releases/mozilla-beta/rev/72896fd70ab8

which was in itself a bustage fix to a previous change made during the merge:

https://hg.mozilla.org/releases/mozilla-beta/rev/e499e965029b

Short term fix is to just revert to using the Aurora or Nightly branding as the default for beta. The confvars.sh value isn't particularly important, since the release configs used for the builds shipped from the beta branch use the --enable-official-branding flag - it just affects what someone gets when they pull beta and build with a default config. Bug 659552 tracks fixing beta builds to have a suitable default branding that isn't confusing.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-27 16:20:13 PST
Created attachment 601114 [details] [diff] [review]
patch

I went with "Nightly", since that's the default on trunk.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-27 16:29:12 PST
Created attachment 601117 [details] [diff] [review]
m-c patch to add a clarifying comment
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-27 16:30:47 PST
Comment on attachment 601114 [details] [diff] [review]
patch

"Anarchy" (original reporter of this bug) mentioned on IRC that mozilla-release is also affected. I think we'll want to land this there as well, just to avoid any future confusion (e.g. from Linux distros pulling mozilla-release code and generating their own builds). It has no impact on our release builds, since this is fallback that is overridden by our passing of --enable-official-branding.
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-27 17:07:59 PST
Comment on attachment 601114 [details] [diff] [review]
patch

ESR is affected as well. Branch approval flag triagers: ping me on IRC if you need additional information. Just to recap:

- this doesn't affect our release builds in any way (they use the --enable-official-branding flag which overrides this default). There's no risk to our releases, but even if it did somehow manage to break something we'd notice it right away (the branding would be wrong).
- this affects people pulling code from these repos and building them with the default configuration (no --enable-official-branding flag specified). They're getting builds branded "Firefox" when they should be getting a build with unencumbered branding ("Nightly").
Comment 7 Alex Keybl [:akeybl] 2012-02-28 10:08:46 PST
For background here, I was using a script provided to me for the merge process which apparently took a hammer to some of these files, thus causing the breakage in https://hg.mozilla.org/releases/mozilla-beta/rev/72896fd70ab8 and the followup band-aid in https://hg.mozilla.org/releases/mozilla-beta/rev/e499e965029b.
Comment 8 Alex Keybl [:akeybl] 2012-02-28 10:10:05 PST
Comment on attachment 601114 [details] [diff] [review]
patch

[Triage Comment]
Approving for release as well for those pulling/building off of m-r in the future, since this wouldn't affect the builds coming out of RelEng.
Comment 10 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-28 12:28:36 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/428268749ad0

I also clobbered beta/release/ESR, given the change of branding.
Comment 11 Matt Brubeck (:mbrubeck) 2012-02-29 11:14:28 PST
https://hg.mozilla.org/mozilla-central/rev/428268749ad0
Comment 12 Simona B [:simonab] 2012-03-05 08:06:38 PST
Verified that after the patch landed the branding for the mozilla-esr10 is the "Nightly" branding. 
Marking as Verified on firefox-esr10.

Note You need to log in before you can comment on or make changes to this bug.