Closed Bug 731290 Opened 9 years ago Closed 9 years ago

Pivotal Tracker integration recently broke

Categories

(Bugzilla :: WebService, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 731219

People

(Reporter: camd, Unassigned)

Details

I use Pivotal Tracker to integrate with Bugzilla.  Some change over the last week or so has changed that breaks their integration.  Talked to their web support and they claim they haven't changed things on their end.

Here's the info from the support person:
=======================
We've been digging into this further and it seems that we're sending a header that your endpoint doesn't like. The error we're getting from your client is:
RuntimeError: wrong fault-structure: {"faultCode"=>"Client", "faultString"=>"Application failed during request deserialization: 32612: When using XML-RPC, you cannot send data as text/xml; charset=utf-8. Only text/xml and application/xml are allowed. at /usr/lib/perl5/vendor_perl/5.8.8/SOAP/Lite.pm line 2761.\n"}

Basically we're sending a header of   "text/xml; charset=utf-8"   and your Buzilla instance only accepts  "text/xml", so no charsets.

We haven't changed anything that should affect this, so I'm wondering what might have changed your side since this last worked for you?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731219
You need to log in before you can comment on or make changes to this bug.