XMLRPC content-type verification fails if a charset is provided

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
WebService
P1
blocker
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: glob, Assigned: glob)

Tracking

({regression})

4.0.5
Bugzilla 4.0
regression
Dependency tree / graph
Bug Flags:
approval +
approval4.2 +
blocking4.2.1 +
approval4.0 +
blocking4.0.6 +

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
following the change in bug 725663, if an xmlrpc client sets the charset as part of its content-type header, we're incorrect rejecting the request.

for example, ruby's xmlrpc library sends a content-type of "text/xml; charset=utf-8" which results in "Only text/xml and application/xml are allowed."
(Assignee)

Comment 1

6 years ago
Created attachment 601276 [details] [diff] [review]
patch v1
Assignee: webservice → glob
Status: NEW → ASSIGNED
Attachment #601276 - Flags: review?(dkl)

Updated

6 years ago
Target Milestone: --- → Bugzilla 4.0

Updated

6 years ago
Duplicate of this bug: 731290

Updated

6 years ago
Flags: blocking4.2.1+
Flags: blocking4.0.6+
Keywords: regression
Comment on attachment 601276 [details] [diff] [review]
patch v1

Review of attachment 601276 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and passes testing r=dkl
Attachment #601276 - Flags: review?(dkl) → review+

Updated

6 years ago
Flags: approval4.2+
Flags: approval4.0+
Flags: approval+
Duplicate of this bug: 731424
This needs to be immediately pushed to bmo, as it's causing major production issues for webtools that use the API.
Severity: major → blocker
Priority: -- → P1
(Assignee)

Comment 6

6 years ago
(In reply to Reed Loden [:reed] (very busy) from comment #5)
> This needs to be immediately pushed to bmo, as it's causing major production
> issues for webtools that use the API.

agreed; i'll liaise with IT and get this pushed soon.
we should also release 4.0.6 and 4.2.1
(Assignee)

Comment 7

6 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/WebService/Server/XMLRPC.pm
Committed revision 7699.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/4.2/
modified Bugzilla/WebService/Server/XMLRPC.pm
Committed revision 8042.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/WebService/Server/XMLRPC.pm
Committed revision 8138.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

6 years ago
(In reply to Byron Jones ‹:glob› from comment #6)
> (In reply to Reed Loden [:reed] (very busy) from comment #5)
> > This needs to be immediately pushed to bmo, as it's causing major production
> > issues for webtools that use the API.
> 
> agreed; i'll liaise with IT and get this pushed soon.

this fix is now live on bmo.

Updated

5 years ago
Blocks: 747755
You need to log in before you can comment on or make changes to this bug.