Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 731315 - Revert Fennec min SDK version back to 5
: Revert Fennec min SDK version back to 5
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Sebastian Kaspari (:sebastian)
Depends on: 662891 727142
  Show dependency treegraph
Reported: 2012-02-28 10:41 PST by Richard Newman [:rnewman]
Modified: 2013-01-17 14:39 PST (History)
11 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Richard Newman [:rnewman] 2012-02-28 10:41:19 PST
Back out per <>.

Can WONTFIX if that decision becomes permanent, but I figured a bug should exist and block release, just in case.
Comment 1 Johnathan Nightingale [:johnath] 2012-03-12 09:02:18 PDT
Doug/Mark/Brad - this feels like an easy blocker to clear, it just needs a decision. Who's got that call?
Comment 2 Johnathan Nightingale [:johnath] 2012-03-14 10:08:52 PDT
P1'ng is not a decision, blassey. :)

This is only needed if we want to support Eclair, right? Do we need to be making a product call right now?
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-03-14 10:12:06 PDT
(In reply to Johnathan Nightingale [:johnath] from comment #2)
> P1'ng is not a decision, blassey. :)
> This is only needed if we want to support Eclair, right? Do we need to be
> making a product call right now?

Sorry, I called out the decision specifically in the bug this depends on (bug 727142). We will support Eclair, need to get the crash fixed in bug 727142 before we re-enable support in the manifest (which is this bug).
Comment 4 Irina Sandu 2012-03-20 05:38:39 PDT
Adding some context:

1.76% of Fx users are on Android 2.1 and in the overall market 6.6% of Androids are on Eclair, most of them probably on ARMv6. 

I think we can easily drop Eclair if it takes resources.
Comment 5 Tony Chung [:tchung] 2012-03-21 08:47:02 PDT
So what's the product decision here for Fx13?   This is marked beta+ and P1, so i'd like to know soon if we are going to do with 2.1 devices.   QA is set up to test a few devices in house if this patch lands, and bug 727142 certainly needs to be fixed and raised in Priority as well.
Comment 6 Irina Sandu 2012-04-03 08:01:35 PDT
Here are today's numbers from the Play store:

stable: 1.64% or 59,675 users on Eclair
beta: 1.18% or 2,000 users on Eclair

The overall market numbers for March are confirming the downward trend: Eclair is now at 6% of all Androids. We cannot get them anyhow, since I suspect they are on ARMv6.
Comment 7 Johnathan Nightingale [:johnath] 2012-04-03 08:16:53 PDT
Moving this back to nom. I'd like us to reconsider it based on comment 6. We're facing no competitive pressure to go this far down the stack, and it doesn't help us reach many more users. But I know Brad's argued for it before, and may bring other information to bear.
Comment 8 John Hopkins (:jhopkins) 2012-06-04 07:17:47 PDT
FYI, I'm running Android 2.1 on my Samsung Galaxy S400 (bought the phone 2 years ago) and Fennec nightly was running very smoothly before the SDK requirements change prevented me from getting updates.
Comment 9 Kevin Brosnan [:kbrosnan] 2012-06-04 11:46:10 PDT
The hardware acceleration changes we took do not work on 2.1 devices. bug 727142 would need to be fixed before fixing this bug would be useful.

Note You need to log in before you can comment on or make changes to this bug.