Change print dialog posing for embedder override

VERIFIED DUPLICATE of bug 70950

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 70950
18 years ago
18 years ago

People

(Reporter: trudelle, Assigned: dcone)

Tracking

({embed})

Trunk
mozilla0.9
embed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Need to change how print dialog is invoked so it can be overridden by embedding 
clients.  Some details below, more at URL above; danm will be happy to help and 
answer questions.

UI Posed by Gecko (Up Calls)
============================
These are calls to window.open, in one form or another, which are relevant to 
embedding. They're split into calls and callers, where a call is considered to 
be a base-level call to window.open which should be API-ized like we're 
discussing, and a caller is something which currently uses window.open but 
should use one of these new APIs when they're created.

I've tried to categorize these sensibly... Each category implies a UI-posing 
component with methods for each item marked "CALL" in that category. Items 
marked "CALLER" in a given category may imply a new method in that component 
(eg. the print dialog stuff), or may just be a caller of some other extant 
method in a different component (eg. the uri loader opening a new window).

Print Dialog:
CALLER: /gfx/src/beos/nsDeviceContextSpecB.cpp#153
CALLER: /gfx/src/gtk/nsDeviceContextSpecG.cpp#187
CALLER: /gfx/src/qt/nsDeviceContextSpecQT.cpp#148
CALLER: /gfx/src/xlib/nsDeviceContextSpecXlib.cpp#143
  in ::Init for all device context specs, open 
chrome://global/content/printdialog.xul
(Reporter)

Comment 1

18 years ago
Adding mozilla0.9 keyword, dependency
Blocks: 71837
Keywords: mozilla0.9

Updated

18 years ago
No longer blocks: 71837

Updated

18 years ago
Blocks: 65233

Comment 2

18 years ago
Apologies for all the bug spam. For the detailed overview of this task, see
danm's document:

  http://www.mozilla.org/xpfe/embedding-dialogs.html

See my first cut at a component-wise categorization:

  http://bugzilla.mozilla.org/showattachment.cgi?attach_id=27972

And if you want to laugh, see also my brainless incomplete IDL for these components:

  http://bugzilla.mozilla.org/showattachment.cgi?attach_id=28175

dr
Keywords: embed
(Assignee)

Comment 3

18 years ago
Is this as simple as a silent parameter on our prining dialog, we already have a 
bug for this.. and are exposing this through the embedding API as we speak.  
This was discussed in the printing embedding meetings also..
Set milestone to mozilla0.9
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 5

18 years ago
This has been taken care of with the embedding API changes.. and there is a bug 
filed for this.

*** This bug has been marked as a duplicate of 70950 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
cool
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.