[meta] Dialog Posing APIs

RESOLVED FIXED in mozilla1.0

Status

enhancement
P1
normal
RESOLVED FIXED
19 years ago
2 months ago

People

(Reporter: danm.moz, Assigned: danm.moz)

Tracking

(4 keywords)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Assignee

Description

19 years ago
Mozilla poses dialogs and alerts from within. This is a fine way for a self-
contained application to do it, but somewhat at odds with an embeddable web 
widget. We should have a generalized extrafenestral* UI posing API that allows an 
embedding app to substitute its own, or to request us to pose a dialog at (its) 
will. (And then, we'd need to retrofit this API into Mozilla, but that's another 
(dependent) task).

* look it up. you won't find it. but it's a fine word.
Assignee

Updated

19 years ago
Status: NEW → ASSIGNED
Keywords: embed
Target Milestone: --- → mozilla0.8
Assignee

Updated

19 years ago
Blocks: 65231
Assignee

Updated

19 years ago
Blocks: 64846
Assignee

Comment 1

19 years ago
  This is the nsIKitchenSinkUI thing we've been discussing, and dr has been 
craving. Really. I've seen it. This is the part where I reassign it to him. I'm 
not yet removing it from Mozilla 0.8 radar because I'm afraid we'll need a 
simplified version (a wrapped window.open) for PSM. Heh. So you're potentially a 
little doomed by this. Waiting to hear back about the requirement...
Assignee: danm → dr
Status: ASSIGNED → NEW
Target Milestone: mozilla0.8 → mozilla1.0

Comment 2

19 years ago
danm: you changed the target milestone to 1.0. did you intend that? changed back
to 0.8. waiting to hear what the requirement *is* these days...
Status: NEW → ASSIGNED
Component: Browser-General → Embedding APIs
Priority: -- → P1
QA Contact: doronr → jrgm
Target Milestone: mozilla1.0 → mozilla0.8

Comment 3

19 years ago
yeesh. ok, i have the requirement. it's not needed for moz0.8, but i should be
able to have something for 0.9.
Target Milestone: mozilla0.8 → mozilla0.9

Comment 4

19 years ago
Back to 1.0...
Keywords: arch
Priority: P1 → P3
Target Milestone: mozilla0.9 → mozilla1.0

Comment 5

19 years ago
Why is it at 1.0? I need it for my favorite embedding customer to be done for 
mozilla0.9. Pleaaaseee, whenever Jud's here you'll get an extra doughnut :-) 

Comment 6

18 years ago
->danm/moz0.9/P1/enhancement, cc dr,self
Severity: normal → enhancement
Priority: P3 → P1
Target Milestone: mozilla1.0 → mozilla0.9

Comment 7

18 years ago
Changing summary, fixing cc's (it's assigned to me). This bug will track
development of UI-posing APIs per-component (or per-category, however it gets
split up), replacement of old calls to window.open() with calls to the new APIs,
and potentially other related tasks. This should *all* be done for 0.9.
Keywords: meta
Summary: new window posing API and implementation → Moz components that pose dialogs/windows must define UI APIs

Updated

18 years ago
Depends on: 71837

Updated

18 years ago
Blocks: 70229

Updated

18 years ago
No longer blocks: 65231

Updated

18 years ago
Depends on: 65231
Summary: Moz components that pose dialogs/windows must define UI APIs → [meta] Dialog Posing APIs

Updated

18 years ago

Comment 8

18 years ago
*** Bug 65231 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
good news, the nsGtkMozRemote stuff (73131) is a non-issue.
Assignee

Updated

18 years ago
Depends on: 72112
Assignee

Updated

18 years ago
Depends on: 70534, 71895, 72111

Comment 10

18 years ago
back to danm the mastermind for safekeeping...
Assignee: dr → danm
Status: ASSIGNED → NEW
Assignee

Updated

18 years ago
Depends on: 70950
Assignee

Updated

18 years ago
No longer depends on: 73139
Assignee

Updated

18 years ago
Depends on: 70228
Assignee

Comment 11

18 years ago
Removing dependency on bug 71895. See comments dated today in that bug.
No longer depends on: 71895
Assignee

Updated

18 years ago
No longer depends on: 72111
Assignee

Comment 12

18 years ago
Removing dependency on bug 72111. See today's comment in that bug.
Assignee

Comment 13

18 years ago
Removing dependency on bug 73127: see comments from today in that bug.
No longer depends on: 73127
Assignee

Comment 14

18 years ago
Restoring dependency on bug 73127. See bug 59748.
Depends on: 73127

Comment 15

18 years ago
clearing target
Target Milestone: mozilla0.9 → ---

Updated

18 years ago
Target Milestone: --- → mozilla0.9.1

Updated

18 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

18 years ago
Target Milestone: mozilla0.9.2 → ---

Updated

18 years ago
Depends on: 105083

Updated

18 years ago
Depends on: 105085

Updated

18 years ago
Blocks: 98995
Assignee

Updated

18 years ago
Target Milestone: --- → mozilla1.0

Comment 16

18 years ago
Dan, it looks like you accidentally removed me from the cc list...
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
don't move bugs that are in the 1.0 dependency tree. sorry.

Target Milestone: mozilla1.0.1 → mozilla1.0

Updated

18 years ago
Keywords: topembed

Updated

18 years ago
Keywords: mozilla1.0+

Comment 19

17 years ago
minusing to topembed- as per edt triage, since this is a meta bug and does not
concern a particular embedding customer.
Keywords: topembedtopembed-
Assignee

Comment 20

17 years ago
Closing, since all dependent bugs have been closed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.