importScripts_worker.js should not try to access "http://flippety*"

VERIFIED FIXED in Firefox 12

Status

()

Core
DOM
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
mozilla13
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox10 wontfix, firefox11 wontfix, firefox12 verified, firefox-esr10 affected)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Let's replace this by a known domain, fwiw.
The point is that it should fail though.
(Assignee)

Comment 2

6 years ago
Created attachment 601378 [details] [diff] [review]
(Av1) importScripts_worker.js: Do not try to access the network
[Checked in: Comments 5 and 9]

[Mozilla/5.0 (Windows NT 5.0; rv:12.0a1) Gecko/20120126 Firefox/12.0a1 SeaMonkey/2.9a1] (custom debug build for Windows 2000)

I can't reproduce bug 731266 by running test_importScripts.html alone, but anyway...
Attachment #601378 - Flags: review?(bent.mozilla)

Comment 3

6 years ago
(In reply to ben turner from comment #1)
> The point is that it should fail though.
Sure, but not because the domain happens not to be registered... now I could have screwed with philor's mind by registering the domain and creating a page that randomly fails or succeeds, but the point is you should fix the test.
(Assignee)

Comment 4

6 years ago
Comment on attachment 601378 [details] [diff] [review]
(Av1) importScripts_worker.js: Do not try to access the network
[Checked in: Comments 5 and 9]

Ping for review.
Attachment #601378 - Flags: review?(jst)

Updated

6 years ago
Attachment #601378 - Flags: review?(jst) → review+
(Assignee)

Comment 5

6 years ago
Comment on attachment 601378 [details] [diff] [review]
(Av1) importScripts_worker.js: Do not try to access the network
[Checked in: Comments 5 and 9]

https://hg.mozilla.org/mozilla-central/rev/26342266f309


[Approval Request Comment]
Regression caused by (bug #): Bug 450449.
User impact if declined: None, but related to bug 626999 (and might be involved in bug 731266)...
Testing completed (on m-c, etc.): this comment.
Risk to taking this patch (and alternatives if risky): None, test only.
String changes made by this patch: None.
Attachment #601378 - Attachment description: (Av1) importScripts_worker.js: Do not try to access the network → (Av1) importScripts_worker.js: Do not try to access the network [Checked in: Comment 5]
Attachment #601378 - Flags: review?(bent.mozilla) → approval-mozilla-aurora?
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-firefox-esr10: --- → affected
status-firefox10: --- → wontfix
status-firefox11: --- → wontfix
status-firefox12: --- → affected
Flags: in-testsuite+
Resolution: --- → FIXED
I wouldn't bother requesting approval for simple test fixes like this, just land it on Aurora. (If anyone complains, you can tell them I said it was ok.)
(Assignee)

Comment 7

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9907016&tree=Firefox
Rev3 Fedora 12 mozilla-central opt test mochitests-3/5 on 2012-03-08 04:42:21 PST for push 0337458a08ba
{
10735 INFO TEST-START | /tests/dom/workers/test/test_importScripts.html
10736 INFO TEST-PASS | /tests/dom/workers/test/test_importScripts.html | worker correctly stopped
10737 INFO TEST-END | /tests/dom/workers/test/test_importScripts.html | finished in 241ms
}

V.Fixed
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

6 years ago
(In reply to Ted Mielczarek [:ted] (away until ~March 7) from comment #6)
> I wouldn't bother requesting approval for simple test fixes like this, just
> land it on Aurora. (If anyone complains, you can tell them I said it was ok.)

Thanks for this one :-)

But I will keep requesting because of past contradictory experiences...
(For example, test-only fixes are not approved for beta until next cycle...)
Keywords: checkin-needed
Whiteboard: [c-n: 26342266f309 (+ comment 6) to m-a]
Comment on attachment 601378 [details] [diff] [review]
(Av1) importScripts_worker.js: Do not try to access the network
[Checked in: Comments 5 and 9]

http://hg.mozilla.org/releases/mozilla-aurora/rev/e62e4dc101c2
Attachment #601378 - Attachment description: (Av1) importScripts_worker.js: Do not try to access the network [Checked in: Comment 5] → (Av1) importScripts_worker.js: Do not try to access the network [Checked in: Comments 5 and 9]
status-firefox12: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: 26342266f309 (+ comment 6) to m-a]
(Assignee)

Updated

6 years ago
No longer blocks: 731266
(Assignee)

Comment 10

6 years ago
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=e62e4dc101c2
succeeded.

firefox12: verified.
status-firefox12: fixed → verified
(Assignee)

Updated

6 years ago
Attachment #601378 - Flags: approval-mozilla-aurora?
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.