Integrate the Add-on SDK loader and API libraries into Firefox

RESOLVED WONTFIX

Status

()

P1
normal
RESOLVED WONTFIX
7 years ago
a year ago

People

(Reporter: dietrich, Assigned: irakli)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 21+)

Details

(Whiteboard: [leave open], URL)

(Reporter)

Description

7 years ago
Meta-bug.

Comment 1

7 years ago
In conjunction with this, I'd suggest handling compatibility checking as follows: 

1. The add-on API should have two version numbers. The upper version number increases when a new feature is added to the API. The lower version number increases only when an old feature is removed or changed incompatibly. (Based on the documentation, that hasn't happened in the last year.) These numbers are independent of the Firefox version.

2. Add-ons have one API version number.

3. An add-on is compatible if its version number is within the upper and lower API version numbers.

This gives add-ons much longer lives, and eliminates much of the current fussing over version issues. Only deletion of an API feature should invalidate an add-on.  A major point of the Jetpack API was to have a reasonably stable API to work against. This has been achieved, but there's still too much frantic updating required, and too many add-ons dying off.
One good example of it would be the ESR releases. As for now (as what I have heard) we do not support them. It means with SDK 1.6 the minVersion will be bumped to 11.0 even with probably no older API getting removed.
OS: Mac OS X → All
Hardware: x86 → All
Assignee: nobody → jgriffiths
Priority: -- → P1
Status: NEW → ASSIGNED
This bug is now being treated as the top-level bug for tracking the landing and shipping of the Add-on SDK's loader and apis in Firefox. If work is being done to further this effort, it should block this bug.
Assignee: jgriffiths → rFobic
Duplicate of this bug: 659104
relnote-firefox: --- → ?
relnote-firefox: ? → 21+
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.