MOZ_SOURCESTAMP_FILE shouldn't depend on MOZ_PKG_PRETTYNAMES

RESOLVED FIXED in Firefox 12

Status

()

Core
Build Config
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

unspecified
mozilla14
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox12 fixed, firefox13 fixed, firefox-esr10 fixed)

Details

(Whiteboard: [Leave open after merge][qa-])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
if you use MOZ_PKG_PRETTYNAMES=1, "make package" generates a sourcestamp file with pretty names (only for Mac), but the output goes to a different file. I don't think that we want this:

$ wget -O- -q http://stage.mozilla.org/pub/mozilla.org/firefox/nightly/11.0b5-candidates/build1/mac/en-US/Firefox       
20120228210006 11.0b5.txt
http://hg.mozilla.org/releases/mozilla-beta/rev/8c9e4873d419 11.0b5.txt
(Assignee)

Comment 1

5 years ago
Created attachment 601774 [details] [diff] [review]
ignore pretty names

Try run: https://tbpl.mozilla.org/?tree=Try&rev=923a9135681e
(Assignee)

Comment 2

5 years ago
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

Try build looks good: https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/raliiev@mozilla.com-923a9135681e/
Attachment #601774 - Flags: review?(khuey)
Attachment #601774 - Flags: review?(khuey) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

http://hg.mozilla.org/integration/mozilla-inbound/rev/14b18863a61c
Attachment #601774 - Flags: checkin+
(Assignee)

Updated

5 years ago
Whiteboard: [Leave open after merge]
https://hg.mozilla.org/mozilla-central/rev/14b18863a61c
(Assignee)

Comment 5

5 years ago
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

This patch can be reproduced only in release builds and doesn't affect any CI builds. Worked fine in m-c and staging release builds.

Regression caused by (bug #): the current bug
Testing completed (on m-c, etc.): tested in dev environment by running staging releases 
Risk to taking this patch (and alternatives if risky): very low
String changes made by this patch: none
Attachment #601774 - Flags: approval-mozilla-beta?
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

[Triage comment]
Approved based on dev testing and low risk.
Attachment #601774 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 7

5 years ago
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

http://hg.mozilla.org/releases/mozilla-beta/rev/e6540031ea08
(Assignee)

Comment 8

5 years ago
Worked fine in 12.0b1 build2:

$ wget -q -O- http://stage.mozilla.org/pub/mozilla.org/firefox/nightly/12.0b1-candidates/build2/mac/en-US/firefox-12.0b1.txt
20120314195616
http://hg.mozilla.org/releases/mozilla-beta/rev/4027017bbaba
(Assignee)

Comment 9

5 years ago
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

I would like to land this patch on m-r and esr10 branches. 12.0b1 release passed without any problems. The risk is very low since the patch contains only cosmetic changes.
Attachment #601774 - Flags: approval-mozilla-release?
Attachment #601774 - Flags: approval-mozilla-esr10?
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

[Triage Comment]
wfm. low risk, go for it.
Attachment #601774 - Flags: approval-mozilla-release?
Attachment #601774 - Flags: approval-mozilla-release+
Attachment #601774 - Flags: approval-mozilla-esr10?
Attachment #601774 - Flags: approval-mozilla-esr10+
(Assignee)

Comment 11

5 years ago
Comment on attachment 601774 [details] [diff] [review]
ignore pretty names

http://hg.mozilla.org/releases/mozilla-esr10/rev/249bf7547c84
http://hg.mozilla.org/releases/mozilla-release/rev/134642a3f460
(Assignee)

Comment 12

5 years ago
Created attachment 608485 [details] [diff] [review]
xulrunner related part

This is a followup patch, which can be descried as "nobody loves xulrunner!". :)

It is similar to attachment 602897 [details] [diff] [review] from bug 732963: MOZ_SOURCESTAMP_FILE should contain platform name in its name since we upload all file in one directory.
Attachment #608485 - Flags: review?(khuey)
(Assignee)

Comment 13

5 years ago
Try (https://tbpl.mozilla.org/?tree=Try&rev=69c7ac90311a) and staging tests pass.
Attachment #608485 - Flags: review?(khuey) → review+
(Assignee)

Comment 14

5 years ago
Comment on attachment 608485 [details] [diff] [review]
xulrunner related part

http://hg.mozilla.org/integration/mozilla-inbound/rev/b25f7ea34460
Attachment #608485 - Flags: checkin+
(Assignee)

Comment 15

5 years ago
Comment on attachment 608485 [details] [diff] [review]
xulrunner related part

Merged from m-i: http://hg.mozilla.org/mozilla-central/rev/b25f7ea34460
(Assignee)

Updated

5 years ago
Duplicate of this bug: 740814
(Assignee)

Comment 17

5 years ago
Comment on attachment 608485 [details] [diff] [review]
xulrunner related part

I would land this trivial patch to m-a, m-b, m-r and esr10

Regression caused by (bug #): the current bug, xulrunner overwrites sourcestamp files
User impact if declined: N/A, the files affected are not used by end users
Testing completed (on m-c, etc.): ran a couple of staging releases
Risk to taking this patch (and alternatives if risky): very low
String changes made by this patch: None
Attachment #608485 - Flags: approval-mozilla-release?
Attachment #608485 - Flags: approval-mozilla-esr10?
Attachment #608485 - Flags: approval-mozilla-beta?
Attachment #608485 - Flags: approval-mozilla-aurora?
Comment on attachment 608485 [details] [diff] [review]
xulrunner related part

Thanks for the thorough risk assessment :)
Attachment #608485 - Flags: approval-mozilla-release?
Attachment #608485 - Flags: approval-mozilla-release+
Attachment #608485 - Flags: approval-mozilla-esr10?
Attachment #608485 - Flags: approval-mozilla-esr10+
Attachment #608485 - Flags: approval-mozilla-beta?
Attachment #608485 - Flags: approval-mozilla-beta+
Attachment #608485 - Flags: approval-mozilla-aurora?
Attachment #608485 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 19

5 years ago
Comment on attachment 608485 [details] [diff] [review]
xulrunner related part

http://hg.mozilla.org/releases/mozilla-aurora/rev/f7896dabf8a9
http://hg.mozilla.org/releases/mozilla-beta/rev/17cfd97cb859
http://hg.mozilla.org/releases/mozilla-release/rev/6504535d557b
http://hg.mozilla.org/releases/mozilla-esr10/rev/e23ec0355bf4
(Assignee)

Comment 20

5 years ago
All done here. Looks fine in 12.0b4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox-esr10: --- → fixed
status-firefox12: --- → fixed
status-firefox13: --- → fixed
Target Milestone: --- → mozilla14
Rail, is there anything QA can do to verify this fix? Apart from checking for the changes in the source code of course.
(Assignee)

Comment 22

5 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #21)
> Rail, is there anything QA can do to verify this fix? Apart from checking
> for the changes in the source code of course.

I don't think that you need to verify something here:

1) I verified that we don't generate pretty named source stamp files on ftp anymore
2) End users has nothing to do with this files

Thanks!
Okay, thanks Rail. Marking qa- to remove from my queries.
Whiteboard: [Leave open after merge] → [Leave open after merge][qa-]
You need to log in before you can comment on or make changes to this bug.