[SeaMonkey, Debug] Exception and assertion in Places which break building, since "Feb 29 10:48:10 2012 -0800" m-c merge

VERIFIED FIXED in mozilla13

Status

()

P1
blocker
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: sgautherie, Assigned: espindola)

Tracking

({assertion, regression})

Trunk
mozilla13
assertion, regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 732368])

(Reporter)

Description

7 years ago
Before:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1330513667.1330522942.5826.gz&fulltext=1
OS X 10.6 comm-central-trunk leak test build on 2012/02/29 03:07:47
{
[...]
resource:///modules/CSPUtils.jsm
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/xpcom/base/nsExceptionService.cpp, line 199
nsStringStats
 => mAllocCount:          17702
 => mReallocCount:         1754
 => mFreeCount:           17702
 => mShareCount:          17624
 => mAdoptCount:           2600
 => mAdoptFreeCount:       2600
Archive:  startupCache.zip
[...]
}

After:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1330551535.1330557626.9976.gz&fulltext=1
OS X 10.6 comm-central-trunk leak test build on 2012/02/29 13:38:55
{
[...]
resource:///modules/CSPUtils.jsm
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/xpcom/base/nsExceptionService.cpp, line 199
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/toolkit/components/places/Database.cpp, line 503
WARNING: NS_ENSURE_TRUE(mDB) failed: file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/toolkit/components/places/nsNavHistory.cpp, line 341
uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 232"  data: no]
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/toolkit/components/places/Database.cpp, line 503
WARNING: NS_ENSURE_TRUE(mDB) failed: file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/toolkit/components/places/nsNavHistory.cpp, line 341
###!!! ASSERTION: Shutdown was not observed!: 'shutdownObserved', file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/storage/src/mozStorageService.cpp, line 474
mozilla::storage::Service::~Service()+0x00000152 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x012BEA58]
mozilla::storage::Service::Release()+0x0000009D [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x012BCC7F]
nsCOMPtr_base::assign_assuming_AddRef(nsISupports*)+0x00000069 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x00005135]
nsCOMPtr_base::assign_with_AddRef(nsISupports*)+0x00000038 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x000142F6]
nsCOMPtr<nsISupports>::operator=(nsISupports*)+0x0000001D [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x0103281D]
FreeFactoryEntries(nsID const&, nsFactoryEntry*, void*)+0x00000038 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x01C6325F]
nsBaseHashtable<nsIDHashKey, nsFactoryEntry*, nsFactoryEntry*>::s_EnumReadStub(PLDHashTable*, PLDHashEntryHdr*, unsigned int, void*)+0x00000058 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x01C67306]
PL_DHashTableEnumerate+0x000000FB [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x00014B36]
nsBaseHashtable<nsIDHashKey, nsFactoryEntry*, nsFactoryEntry*>::EnumerateRead(PLDHashOperator (*)(nsID const&, nsFactoryEntry*, void*), void*) const+0x0000007B [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x01C68EAB]
nsComponentManagerImpl::FreeServices()+0x00000075 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x01C629D5]
mozilla::ShutdownXPCOM(nsIServiceManager*)+0x0000038F [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x01C0A0C3]
NS_ShutdownXPCOM_P+0x00000015 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/XUL +0x01C0A4B8]
NS_ShutdownXPCOM+0x00000015 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/libxpcom.dylib +0x00001102]
main+0x00001172 [/builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/mozilla/dist/bin/xpcshell +0x00006E70]
###!!! ASSERTION: Shutdown was not observed!: 'shutdownObserved', file /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/storage/src/mozStorageService.cpp, line 474
/bin/sh: line 1: 51932 Segmentation fault      /builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/suite/installer/../../mozilla/dist/bin/run-mozilla.sh /builds/slave/comm-cen-trunk-osx64-dbg/build/objdir/mozilla/dist/bin/xpcshell -g "$PWD" -a "$PWD" -f /builds/slave/comm-cen-trunk-osx64-dbg/build/mozilla/toolkit/mozapps/installer/precompile_cache.js -e "populate_startupcache('GreD', 'omni.ja', 'startupCache.zip');"
make[2]: *** [make-package] Error 139
[...]
}

Regression timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb01e23f83cf&tochange=3812d0ce274e
"Matt Brubeck — Merge last green changeset from inbound to mozilla-central"
+
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=271f2a50cfbb&tochange=bb995ee9fa3
(4 unrelated changesets.)
(Reporter)

Comment 1

7 years ago
Ftr, OSX (64) and Windows is affected,
but not Linux:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1330590475.1330605004.25566.gz
Linux comm-central-trunk leak test build on 2012/03/01 00:27:55
using revisions: comm-central/3de041a65fc1, mozilla-central/1c3b291d0830
is still green.
a couple tests were moved from browser to toolkit in
http://hg.mozilla.org/mozilla-central/rev/322e727576c8

apart this I'm not sure what should make a difference in that range, from the error looks like history is unable to create a database, but there are no cpp changes ni the range
(Reporter)

Comment 3

7 years ago
(In reply to Marco Bonardo [:mak] from comment #2)

> a couple tests were moved from browser to toolkit in
> http://hg.mozilla.org/mozilla-central/rev/322e727576c8

I'll file a bug to port bug 575955.
But that (Firefox and/or xpcshell) changeset is unrelated here.

> apart this I'm not sure what should make a difference in that range, from
> the error looks like history is unable to create a database, but there are
> no cpp changes ni the range

Afaict, this build step loads all *.jsm files ... and now fails at its end.

The only other change in /toolkit/components/places is bug 714261, which modifies PlacesUtils.jsm...
Blocks: 714261
(Reporter)

Comment 4

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #3)
> Afaict, this build step loads all *.jsm files ... and now fails at its end.
> 
> The only other change in /toolkit/components/places is bug 714261, which
> modifies PlacesUtils.jsm...

Ftr, the only uses in SeaMonkey are in PlacesUIUtils.jsm.
http://mxr.mozilla.org/comm-central/search?string=PlacesUtils.transactionManager&case=1&find=%2Fsuite%2F
the scope of bug 575955 was to remove all uses of the PlacesUIUtils calls. though shouldn't matter.
ok this also happened in bug 732314

I have an alternative theory, Bug 720493 may be firing idle-daily after xpcom-shutdown.
Blocks: 720493

Updated

7 years ago
Depends on: 732368

Updated

7 years ago
No longer blocks: 720493
(Reporter)

Comment 8

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #3)
> I'll file a bug to port bug 575955.

I filed bug 732027.
(Reporter)

Comment 9

7 years ago
SeaMonkey tree is very badly affected.
Any chance the triggering changeset could be backed out until bug 732368 is fixed?
(Reporter)

Comment 10

7 years ago
Ftr, 1 OSX_64 build succeeded unexpectedly:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1330797597.1330807562.6732.gz
OS X 10.6 comm-central-trunk leak test build on 2012/03/03 09:59:57
(Reporter)

Comment 11

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #10)
> Ftr, 1 OSX_64 build succeeded unexpectedly:

That one was a 'periodic clobber'.
The next build, on another slave, succeeded too...

***

Requesting clobber of:
the 2 'OS X 10.5 comm-central-trunk leak test build',
the 5 'WINNT 5.2 comm-central-trunk leak test build',
at "2012-03-04 06:29:21 PST".

NB: We loose the possibility to narrow down the exact cause, but if this can solve this 4-days major bustage :-|
(Reporter)

Comment 12

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #11)

> (In reply to Serge Gautherie (:sgautherie) from comment #10)
> > Ftr, 1 OSX_64 build succeeded unexpectedly:
> 
> That one was a 'periodic clobber'.
> The next build, on another slave, succeeded too...

These were on cb-sea-miniosx64-03 then cb-sea-miniosx64-02.
(Maybe these 2 builds were just lucky?)

Then cb-sea-miniosx64-01 failed twice.
Requesting clobber of 'OS X 10.6 comm-central-trunk leak test build > cb-sea-miniosx64-01', at "2012-03-04 10:32:31 PST", fwiw.

> ***
> 
> Requesting clobber of:
> the 2 'OS X 10.5 comm-central-trunk leak test build',
> the 5 'WINNT 5.2 comm-central-trunk leak test build',
> at "2012-03-04 06:29:21 PST".

Clobber happened on cb-sea-miniosx01, cb-sea-miniosx02 and cn-sea-qm-win2k3-01, but did not help :-/
(Reporter)

Comment 13

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #12)
> These were on cb-sea-miniosx64-03 then cb-sea-miniosx64-02.
> (Maybe these 2 builds were just lucky?)
> 
> Then cb-sea-miniosx64-01 failed twice.
> Requesting clobber of 'OS X 10.6 comm-central-trunk leak test build >
> cb-sea-miniosx64-01', at "2012-03-04 10:32:31 PST", fwiw.

Expected but so weird: -02 and -03 continue to succeed, -01 still fails.
I just clobbered EVERYTHING a bit ago, and hopefully stuff turns out sane. I'll make this issue my priority this week though.
(Reporter)

Comment 15

7 years ago
(In reply to Justin Wood (:Callek) from comment #14)
> I just clobbered EVERYTHING a bit ago

Ftr: all "comm-central-trunk" builds at "2012-03-05 13:23:27 PST".
(Reporter)

Comment 16

7 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #15)
> (In reply to Justin Wood (:Callek) from comment #14)
> > I just clobbered EVERYTHING a bit ago
> 
> Ftr: all "comm-central-trunk" builds at "2012-03-05 13:23:27 PST".

As my previous clobber(s), that didn't help:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1330991060.1330998982.14320.gz&fulltext=1
WINNT 5.2 comm-central-trunk leak test build on 2012/03/05 15:44:20
s: cb-seamonkey-win32-03
(Reporter)

Comment 17

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1331212601.1331221551.3860.gz
OS X 10.5 comm-central-trunk leak test build on 2012/03/08 05:16:41

V.Fixed, by bug 732368.
Assignee: nobody → respindola
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Whiteboard: [fixed by bug 732368]
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.