If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Warning messages should be positioned under mandatory fields, not above in Confirm Details page.

VERIFIED FIXED in 6.4.6

Status

addons.mozilla.org Graveyard
Discovery Pane
--
enhancement
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Victor Carciu, Assigned: potch)

Tracking

unspecified
6.4.6

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 601947 [details]
Screenshot

Prerequisites:
Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0

Steps to reproduce:
1.Go to apps marketplace and sign in : https://marketplace-dev.allizom.org/en-US/developers/submissions
2.Select any premium owned app and select "Manage PayPal" from the left side of the screen
3.Click "Set up permissions" button
4.Login to PayPal , grant permissions and return to marketplace
5.At confirm details page delete all fields and press Continue.

Expected Results:
"Country" and "Address one" fields are mandatory, so the warning messages should be positioned under these fields.

Actual Results:
The warning message("This field is required.") is positioned above the mandatory fields.

Note:The issue here is that this positioning is confusing because in the rest of marketplace-dev the warning messages are positioned under mandatory fields and the user will try to fill "Last Name " and "Country" in this page.

Please see attached screenshot.
This is because we use django's default forms layout to print `form.as_p()`. We should use our styling, and this should fix itself.
Assignee: nobody → cvan
Target Milestone: --- → 6.4.5
Assignee: cvan → thepotch
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: 6.4.5 → 6.4.6
(Assignee)

Comment 2

6 years ago
fixed by https://github.com/mozilla/zamboni/commit/38a471c
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

6 years ago
Created attachment 604921 [details]
Postfix Screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.