Closed Bug 732119 Opened 10 years ago Closed 10 years ago

MAPLE: parts of background never drawn on graph server

Categories

(Firefox for Android Graveyard :: General, defect, P2)

13 Branch
ARM
Android
defect

Tracking

(blocking-fennec1.0 soft)

RESOLVED DUPLICATE of bug 746120
Tracking Status
blocking-fennec1.0 --- soft

People

(Reporter: nhirata, Assigned: cwiiis)

References

()

Details

(Whiteboard: maple [layout])

Attachments

(1 file)

Attached image screenshot
1. go to http://graphs-new.mozilla.org/graph.html#tests=[[16,65,20],[16,53,20],[16,27,20],[16,52,20],[16,63,20]]&sel=none&displayrange=7&datatype=running
2. while the page is loading, continually zoom out

Expected: things load according to relative position in the zoom level
Actual: things are loaded according to relative position of original zoom level

Note:
1. nexus Captivate, Maple build 3/1/2012
This page seems to load the same broken way regardless of zooming.
Summary: MAPLE: continual zooming while a page is loading may cause misplacement of web objects → MAPLE: parts of background never drawn on graph server
nom for triage.   retest this after more changes land in maple
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → beta+
Priority: -- → P2
Whiteboard: maple → maple [gfx]
I feel like this would be solved by the recent changes to viewport.
Unfortunately it is not fixed, and I don't know offhand what's wrong. It doesn't seem like a viewport problem, maybe layout?
Whiteboard: maple [gfx] → maple [layout]
Panning is an issue on this page this time.  The viewport only shows a portion of the page, and you cannot pan in either directions.  As kats stated in comment 4, this bug is not fixed.
Assignee: nobody → chrislord.net
Copying my comment from bug 737021:

"I think this may be related to the android-specific code in CompositorParent - it finds the root-scrollable frame and applies the transform to the associated layer, but perhaps there are situations where this is the incorrect layer?"
(In reply to Chris Lord [:cwiiis] from comment #6)
> Copying my comment from bug 737021:
> 
> "I think this may be related to the android-specific code in
> CompositorParent - it finds the root-scrollable frame and applies the
> transform to the associated layer, but perhaps there are situations where
> this is the incorrect layer?"

The "CompositorParent" issue seems to have popped up in recent chatter on IRC as well. Is there a specific bug for the "CompositorParent" issue?
If this bug is relegated to the graph server and we are not seeing this reported on other pages, let's not block on this.
(In reply to Chris Lord [:cwiiis] from comment #6)
> Copying my comment from bug 737021:
> 
> "I think this may be related to the android-specific code in
> CompositorParent - it finds the root-scrollable frame and applies the
> transform to the associated layer, but perhaps there are situations where
> this is the incorrect layer?"

Chris, so is this related to bug 732971?
(In reply to Brad Lassey [:blassey] from comment #9)
> (In reply to Chris Lord [:cwiiis] from comment #6)
> > Copying my comment from bug 737021:
> > 
> > "I think this may be related to the android-specific code in
> > CompositorParent - it finds the root-scrollable frame and applies the
> > transform to the associated layer, but perhaps there are situations where
> > this is the incorrect layer?"
> 
> Chris, so is this related to bug 732971?

I wouldn't have thought so, but possibly?

I think it'd fix this if we could apply the transform to the root frame instead of the root scroll frame, but doing so causes odd redrawing issues (likely due to calculated visibility in layers?)

I need to experiment more with this.
blocking-fennec1.0: beta+ → +
blocking-fennec1.0: + → soft
Martijn - can you try to create a minimal testcase?
Keywords: testcase-wanted
Is it possible that this is due to the overflow: hidden styling - I put up a test-case in bug 746120 where I see the same thing.

I also see this on duckduckgo.com when pinch-zooming inwards. If it is than my bug 746120 is a duplicate of this.
Yeah, I agree, the page has overflow:hidden on the html element, that makes it basically the same as bug 746120.
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: testcase-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 746120
No longer blocks: omtclayerbugs
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.