Last Comment Bug 732528 - image/test/reftest/jpeg tests fails on android when we turn browser.tabs.remote=false
: image/test/reftest/jpeg tests fails on android when we turn browser.tabs.remo...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 732494 732498
  Show dependency treegraph
 
Reported: 2012-03-02 12:07 PST by Joel Maher ( :jmaher)
Modified: 2012-03-27 09:52 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joel Maher ( :jmaher) 2012-03-02 12:07:00 PST
On android xul, we run with e10s and our reftest harness will setup the xul window to have the remote=true attribute.  For native fennec we have the preference to turn on e10s set, but we don't read it.  This means that reftest is still thinking we are remote, but in reality we are not.  

In trying to turn this off, I found that the 17 tests which pass normally on android xul and native now fail.  There are only 4 tests which do pass:
jpg-size-1x1.jpg
jpg-size-6x6.jpg
jpg-srgb-icc.jpg
webcam-simulacrum.mjpg

The log file showing this is here:
http://people.mozilla.org/~jmaher/android_reftests/jpeg.log
Comment 1 Joel Maher ( :jmaher) 2012-03-27 09:52:07 PDT
these appear to be running fine in a more recent build.

Note You need to log in before you can comment on or make changes to this bug.