remove browser.tabs.remote=true pref from native fennec

RESOLVED DUPLICATE of bug 748088

Status

()

RESOLVED DUPLICATE of bug 748088
7 years ago
6 years ago

People

(Reporter: jmaher, Assigned: bugs)

Tracking

(Depends on: 5 bugs, Blocks: 2 bugs)

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
currently we have browser.tabs.remote=true in native fennec, but we do not use this pref.  Our reftest harness keys off this and runs all the reftests in remote tabs as a result.
(Reporter)

Updated

7 years ago
Blocks: 732494
(Reporter)

Updated

7 years ago
Depends on: 732506
(Reporter)

Updated

7 years ago
Depends on: 732521
(Reporter)

Updated

7 years ago
Depends on: 732524
(Reporter)

Updated

7 years ago
Depends on: 732528
(Reporter)

Updated

7 years ago
Depends on: 732532
(Reporter)

Updated

7 years ago
Depends on: 732533
(Reporter)

Updated

7 years ago
Depends on: 732535
(Reporter)

Updated

7 years ago
Depends on: 732541
(Reporter)

Updated

7 years ago
Depends on: 732542
(Reporter)

Updated

7 years ago
Depends on: 732544
(Reporter)

Updated

7 years ago
Depends on: 732547
(Reporter)

Updated

7 years ago
Depends on: 732549
(Reporter)

Updated

7 years ago
Depends on: 732565
(Reporter)

Updated

7 years ago
Depends on: 732566
(Reporter)

Updated

7 years ago
Depends on: 732568
(Reporter)

Updated

7 years ago
Depends on: 732569

Updated

7 years ago
Blocks: 734456
(Assignee)

Comment 1

7 years ago
Picking this up...
Assignee: nobody → jet
(Reporter)

Comment 2

7 years ago
most of these failures that we depend on pass on later builds of fennec.  I have a try server run going with browser.tabs.remote=false and we will see how that goes.  I will cleanup these bugs when the time comes.
(Reporter)

Updated

7 years ago
Depends on: 739708
(Reporter)

Updated

7 years ago
Depends on: 739711
(Reporter)

Updated

7 years ago
Depends on: 739714
(Reporter)

Comment 3

7 years ago
Created attachment 609813 [details] [diff] [review]
remove browser.tabs.remote and cleanup a few manifest files (1.0)

Updated

6 years ago
Blocks: 748088
(Reporter)

Updated

6 years ago
Depends on: 756481
(Reporter)

Updated

6 years ago
Depends on: 756485
(Reporter)

Updated

6 years ago
Depends on: 756526
(Reporter)

Updated

6 years ago
Depends on: 756530
(Reporter)

Updated

6 years ago
Depends on: 756540
(Reporter)

Updated

6 years ago
Depends on: 756563
(Reporter)

Updated

6 years ago
No longer depends on: 739708
(Reporter)

Updated

6 years ago
Depends on: 760264
(Reporter)

Updated

6 years ago
Depends on: 760266
(Reporter)

Updated

6 years ago
Depends on: 760269
(Reporter)

Updated

6 years ago
Depends on: 760270
(Reporter)

Updated

6 years ago
Depends on: 760271
(Reporter)

Updated

6 years ago
Depends on: 760275
(Assignee)

Comment 4

6 years ago
(In reply to Joel Maher (:jmaher) from comment #3)
> Created attachment 609813 [details] [diff] [review]
> remove browser.tabs.remote and cleanup a few manifest files (1.0)

Following up on this one: will this patch (or similar manifest tweakage) do the trick for the remaining failures?
(Reporter)

Comment 5

6 years ago
It has been so long, I would honestly have no idea.  Reftest and fennec have both changed enough, that we should reevaluate this, basically start from scratch and retest.
(Reporter)

Comment 6

6 years ago
odd, this landed Jun 1st (I believe to work around some b2g stuff).  So we can actually close this out.  I would say we are good to go
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748088
You need to log in before you can comment on or make changes to this bug.