Drag and drop images into message window is broken

VERIFIED FIXED in Firefox 13

Status

()

Core
Editor
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Bozz, Assigned: Ehsan)

Tracking

({regression})

Trunk
mozilla14
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(firefox13+ verified, firefox14 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120228210006

Steps to reproduce:

Drag and drop images into message compose window.

Using current Daily nightly build Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120302 Thunderbird/13.0a1

Regression range is unknown.


Actual results:

When message is sent or saved as draft, the images do not show up in the message window. The attachment pane shows an attachment but with unknown file type and no size.

Example of content from view source...

Content-Type: application/x-moz-file;
name="jdjedfbj."
Content-Transfer-Encoding: base64
Content-ID: <part1.02080207.02020008@comcast.net>
Content-Disposition: inline;
filename="jdjedfbj."



Expected results:

Images should display in the message window.

Comment 1

5 years ago
Confirmed.
This exists as far back as 2012-02-20
Regression range needs refined.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
Regression range
2012-02-17 Works
2012-02-18 No win build
2012-02-19 No win build
2012-02-20 Fails

Comment 3

5 years ago
bug 499008 landed in the regression range.
Ehsan, drag and drop images was fixed for thunderbird in bug 609632
could the new API have broken that fix.

Updated

5 years ago
Keywords: regression

Comment 4

5 years ago
Some further diagnostic info:
Here is what the data url looks like in the compose window (before sending)
In a working build:
<img src="data:image/gif;base64
after the regression:
<img src="data:application/x-moz-file;base64
(Reporter)

Updated

5 years ago
Severity: normal → major

Updated

5 years ago
tracking-thunderbird13: --- → ?

Comment 5

5 years ago
This is also reproducible on  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120302 SeaMonkey/2.10a1, in both Mail/News and Composer. Thus, either something is missing in comm-central or it's indeed a Core issue.

Note that drag-and-drop produces a "data:application/x-moz-file" URI whereas copy-and-paste still generates a correct "data:image/..." source.
Component: Message Compose Window → Composition
Product: Thunderbird → MailNews Core
QA Contact: message-compose → composition

Comment 6

5 years ago
Additional testing:
Downloaded current Firefox trunk
Found a conteneditable test page on the web
Dragged a local image into that.
The image "appears" normally the same as it does in Thunderbird.
(I found no easy way to look at the source at this point)
Copy/paste that content into TB compose window.
The resulting source is: src="data:application/x-moz-file;base64
Since the actual drag was performed in Firefox, I conclude that the bug is Core.
Blocks: 499008
Component: Composition → Editor
Product: MailNews Core → Core
QA Contact: composition → editor
Target Milestone: --- → mozilla13
Duplicate of this bug: 732940
Setting tracking for Firefox cause this is core , but it really affects Thunderbird a lot more than firefox.
tracking-firefox13: --- → ?
Whiteboard: duptome

Updated

5 years ago
tracking-firefox13: ? → +
I can reproduce.
Assignee: nobody → ehsan
Whiteboard: duptome
Created attachment 608913 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Regression caused by (bug #): bug 499008
User impact if declined: Dragging images to editable content will be broken.
Testing completed (on m-c, etc.): Tested locally, under a debugger.
Risk to taking this patch (and alternatives if risky): Very minimal, this is caused by a typo!
String changes made by this patch: none
Attachment #608913 - Flags: review?(roc)
Attachment #608913 - Flags: approval-mozilla-aurora?
Attachment #608913 - Flags: review?(roc) → review+
Temporary move back to c-c component to clear obsolete thunderbird tracking flag as it is now being tracked via core.
Component: Editor → Composition
Product: Core → MailNews Core
QA Contact: editor → composition
Target Milestone: mozilla13 → ---
tracking-thunderbird13: ? → ---
Component: Composition → Editor
Product: MailNews Core → Core
QA Contact: composition → editor
https://hg.mozilla.org/integration/mozilla-inbound/rev/f805ebc90a30
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/f805ebc90a30
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

5 years ago
This is not fixed in todays Earlybird 13.0a2.

Verified fixed in todays Daily 14.0a1.

Comment 15

5 years ago
Thanks for verifying. This yet has to be approved and checked in to mozilla-aurora to become visible in 13.0a2 builds.
Status: RESOLVED → VERIFIED

Updated

5 years ago
status-firefox13: --- → affected
status-firefox14: --- → verified
Comment on attachment 608913 [details] [diff] [review]
Patch (v1)

[Triage Comment]
Low risk regression in FF13 - approving for Aurora.
Attachment #608913 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Duplicate of this bug: 740022
http://hg.mozilla.org/releases/mozilla-aurora/rev/afb7d64a4013
status-firefox13: affected → fixed
(Reporter)

Comment 19

5 years ago
Verified fixed in todays Earlybird 13.0a2.

Updated

5 years ago
status-firefox13: fixed → verified
You need to log in before you can comment on or make changes to this bug.