Intermittent tpr_responsiveness, ts_places_generated_med "AttributeError: 'module' object has no attribute '_is_running'"

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure, regression})

Trunk
x86
Linux
intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Following the merge of bug 731893 to inbound (like 5 and 7 pushes later, looking rather suspicious and furtive and generally up-to-no-good):

https://tbpl.mozilla.org/php/getParsedLog.php?id=9769617&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound talos tpr_responsiveness on 2012-03-02 01:00:38 PST for push 21ce98516c3a

NOISE: Cycle 9(1): loaded http://localhost/page_load_test/tp5/yahoo.co.jp/www.yahoo.co.jp/index.html (next: http://localhost/page_load_test/tp5/amazon.com/www.amazon.com/Kindle-Wireless-Reader-Wifi-Graphite/dp/B002Y27P3M/507846.html)
NOISE: RSS: Main: 103641088
NOISE: 
Traceback (most recent call last):
  File "run_tests.py", line 666, in <module>
    main()
  File "run_tests.py", line 663, in main
    test_file(arg, options, parser.parsed)
  File "run_tests.py", line 585, in test_file
    browser_dump, counter_dump, print_format = mytest.runTest(browser_config, test)
  File "/home/cltbld/talos-slave/talos-data/talos/ttest.py", line 455, in runTest
    self.cleanupAndCheckForCrashes(browser_config, profile_dir)
  File "/home/cltbld/talos-slave/talos-data/talos/ttest.py", line 157, in cleanupAndCheckForCrashes
    browser_config['browser_wait']) 
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess.py", line 83, in cleanupProcesses
    terminate_result = self.TerminateAllProcesses(browser_wait, process_name, child_process, "crashreporter", "dwwin", "talkback")
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess_linux.py", line 118, in TerminateAllProcesses
    ret = self.TerminateProcess(pid, timeout)
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess_linux.py", line 93, in TerminateProcess
    if utils._is_running(pid):
AttributeError: 'module' object has no attribute '_is_running'
Corrupt JPEG data: 8 extraneous bytes before marker 0xe1
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Error: The name org.freedesktop.UPower was not provided by any .service files
Corrupt JPEG data: 8 extraneous bytes before marker 0xe1
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Error: The name org.freedesktop.UPower was not provided by any .service files
program finished with exit code 1
elapsedTime=4601.396757


https://tbpl.mozilla.org/php/getParsedLog.php?id=9771004&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound talos tpr_responsiveness on 2012-03-02 02:45:34 PST for push 4069a04e8e81

NOISE: Cycle 9(1): loaded http://localhost/page_load_test/tp5/yahoo.co.jp/www.yahoo.co.jp/index.html (next: http://localhost/page_load_test/tp5/amazon.com/www.amazon.com/Kindle-Wireless-Reader-Wifi-Graphite/dp/B002Y27P3M/507846.html)
NOISE: RSS: Main: 100773888
NOISE: 
Traceback (most recent call last):
  File "run_tests.py", line 666, in <module>
    main()
  File "run_tests.py", line 663, in main
    test_file(arg, options, parser.parsed)
  File "run_tests.py", line 585, in test_file
    browser_dump, counter_dump, print_format = mytest.runTest(browser_config, test)
  File "/home/cltbld/talos-slave/talos-data/talos/ttest.py", line 455, in runTest
    self.cleanupAndCheckForCrashes(browser_config, profile_dir)
  File "/home/cltbld/talos-slave/talos-data/talos/ttest.py", line 157, in cleanupAndCheckForCrashes
    browser_config['browser_wait']) 
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess.py", line 83, in cleanupProcesses
    terminate_result = self.TerminateAllProcesses(browser_wait, process_name, child_process, "crashreporter", "dwwin", "talkback")
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess_linux.py", line 118, in TerminateAllProcesses
    ret = self.TerminateProcess(pid, timeout)
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess_linux.py", line 93, in TerminateProcess
    if utils._is_running(pid):
AttributeError: 'module' object has no attribute '_is_running'
Corrupt JPEG data: 8 extraneous bytes before marker 0xe1
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Error: The name org.freedesktop.UPower was not provided by any .service files
Corrupt JPEG data: 8 extraneous bytes before marker 0xe1
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Corrupt JPEG data: 40 extraneous bytes before marker 0xee
Error: The name org.freedesktop.UPower was not provided by any .service files
program finished with exit code 1
elapsedTime=4595.470854
(Reporter)

Updated

7 years ago
Blocks: 731893
Keywords: regression
(Reporter)

Comment 2

7 years ago
Oh, I recognize that "next: " page - you're blowing up when we hit bug 722941.
(Reporter)

Comment 5

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9789623&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound pgo talos dirty on 2012-03-02 13:02:38 PST for push e29cdf5839e3

Running test ts_places_generated_med: 
		Started Fri, 02 Mar 2012 13:11:00
NOISE: __metrics	Screen width/height:1600/1200
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1024/647
NOISE: __metrics
Traceback (most recent call last):
  File "run_tests.py", line 666, in <module>
    main()
  File "run_tests.py", line 663, in main
    test_file(arg, options, parser.parsed)
  File "run_tests.py", line 585, in test_file
    browser_dump, counter_dump, print_format = mytest.runTest(browser_config, test)
  File "/home/cltbld/talos-slave/talos-data/talos/ttest.py", line 455, in runTest
    self.cleanupAndCheckForCrashes(browser_config, profile_dir)
  File "/home/cltbld/talos-slave/talos-data/talos/ttest.py", line 157, in cleanupAndCheckForCrashes
    browser_config['browser_wait']) 
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess.py", line 83, in cleanupProcesses
    terminate_result = self.TerminateAllProcesses(browser_wait, process_name, child_process, "crashreporter", "dwwin", "talkback")
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess_linux.py", line 118, in TerminateAllProcesses
    ret = self.TerminateProcess(pid, timeout)
  File "/home/cltbld/talos-slave/talos-data/talos/ffprocess_linux.py", line 93, in TerminateProcess
    if utils._is_running(pid):
AttributeError: 'module' object has no attribute '_is_running'

command timed out: 21600 seconds without output, attempting to kill
program finished with exit code 1

Presumably planning on being a bug 730186, since despite branching out from Windows, bug 647595 still mostly avoids Linux64.
Summary: Intermittent tpr_responsiveness "AttributeError: 'module' object has no attribute '_is_running'" → Intermittent tpr_responsiveness, ts_places_generated_med "AttributeError: 'module' object has no attribute '_is_running'"

Comment 6

7 years ago
Should be 'is_running' without the leading underscore: http://hg.mozilla.org/build/talos/file/8197dc094fe3/talos/utils.py#l185

Comment 8

7 years ago
Created attachment 602639 [details] [diff] [review]
fix

this should also fix Bug 732656
Attachment #602639 - Flags: review?(jmaher)
Attachment #602639 - Flags: review?(jmaher) → review+

Comment 9

7 years ago
Try run for 45fba7751f50 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=45fba7751f50
Results (out of 72 total builds):
    success: 72
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jhammel@mozilla.com-45fba7751f50

Comment 10

7 years ago
Untested on android
Whiteboard: [orange] → [orange][talos-checkin-needed]
(Reporter)

Comment 11

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9810696&tree=Mozilla-Inbound

And it took considerably retrying, but I did finally hit bug 722941 on your try push, and https://tbpl.mozilla.org/php/getParsedLog.php?id=9810604&tree=Try handled it nicely.

Comment 12

7 years ago
tested on android: ts, tsvg

Comment 13

7 years ago
pushed: http://hg.mozilla.org/build/talos/rev/6694f881a3fb
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [orange][talos-checkin-needed] → [orange]
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.