Last Comment Bug 732757 - Firefox sometimes doesn't properly go into full screen mode from normal window on Win7 Aero
: Firefox sometimes doesn't properly go into full screen mode from normal windo...
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 10 Branch
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 21:24 PST by KLB
Modified: 2014-06-16 09:15 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description KLB 2012-03-03 21:24:43 PST
With some themes, when Firefox is sent from a normal (non-maximized) window to fullscreen it will not go to full screen mode properly and instead will leave a large black area around s smaller window (please see: http://fritzfam.com/gallery/v/jeremy/ClassicCompact/ for screen captures). Of the dozen or so themes I have tried, I have been able to replicate this issue on the following themes:
* Classic Compact - https://addons.mozilla.org/en-US/firefox/addon/classic-compact/
* Lava Fox - https://addons.mozilla.org/en-US/firefox/addon/lavafox-v1/
* NASA Night Launch - https://addons.mozilla.org/en-US/firefox/addon/nasa-night-launch/
* FXChrome - https://addons.mozilla.org/en-US/firefox/addon/fxchrome/
 (Oddly FXChrome caused FF to start to flicker when returning from full screen to a normal window)

Sometimes when going to full screen mode the browser window will disappear all together and F11 will have to be pressed again to restore the window back to normal mode, which will cause it to reappear and display normally. It seems the themes that more completely support the Aero effect are more proned to expierence problems going int full screen mode from the normal window.

 Apparently disabling 'Aero peek' and 'desktop composition' visual effects will make this issue go away.

On the default theme I'm not seeing the black background area, but sometimes there is a bad flicker as if Firefox is hanging slightly when going into full screen mode.

I tested this issue in both FF10 and FF11 and saw it in both browsers.
Comment 1 KLB 2012-03-04 11:56:16 PST
When I disable Aero Glass transparency the Firefox will go int full screen correctly, but there is still a momentary flicker of a black screen around the normal window area.  So it seems that the transparency is the trigger that prevents Firefox from going into full screen properly.
Comment 2 KLB 2012-03-05 05:01:04 PST
It appears this bug is related to bug 724354. One work around to this issue seems to be for themes that support aero glass to add the following code to their browser.css file somewhere below where the main-window is made transparent to support Aero glass:

==CODE==
@media all and (-moz-windows-compositor) {
  /* Make transition to Fullscreen mode seamlessly in Firefox 10+ */
  #main-window[inFullscreen="true"] {
    -moz-appearance: none;
     background-color: -moz-dialog!important;
  }
}
==/CODE==
Comment 3 Wayne Mery (:wsmwk, NI for questions) 2014-05-30 11:01:06 PDT
(In reply to KLB from comment #2)
> It appears this bug is related to bug 724354. 

bug 724354 was closed invalid.
so this is also invalid, correct?
Comment 4 KLB 2014-06-16 09:15:37 PDT
I have not observed this bug for a very long time so maybe it got resolved. Closing it is okay by me.

Note You need to log in before you can comment on or make changes to this bug.