The default bug view has changed. See this FAQ.

Implement signing on demand for xulrunner

RESOLVED FIXED

Status

()

Core
Build Config
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox-esr10 fixed)

Details

(Whiteboard: [Leave open after merge])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 602895 [details] [diff] [review]
sign xulrunner

* xulrunner shouldn't be codesigned internally (our current practice)
* GPG sign SDK
Attachment #602895 - Flags: review?(ted.mielczarek)
Attachment #602895 - Flags: review?(catlee)

Updated

5 years ago
Attachment #602895 - Flags: review?(catlee) → review+
Attachment #602895 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 1

5 years ago
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

http://hg.mozilla.org/integration/mozilla-inbound/rev/5b2ba557ec83
Attachment #602895 - Flags: checkin+
(Assignee)

Updated

5 years ago
Whiteboard: [Leave open after merge]
https://hg.mozilla.org/mozilla-central/rev/5b2ba557ec83
(Assignee)

Comment 3

5 years ago
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

This patch implements signing on demand for xulrunner. Xulrunner isn't a part of Firefox CI process (only nightlies) and exists in release builds. The patch simplifies the release build procedure by removing xulrunner signing step which is manual right now.

Regression caused by (bug #): none
Testing completed (on m-c, etc.): tested in dev environment by running staging releases 
Risk to taking this patch (and alternatives if risky): very low
String changes made by this patch: none
Attachment #602895 - Flags: approval-mozilla-beta?
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

[Triage comment]
Approval for low-risk, non-CI affecting.
Attachment #602895 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 5

5 years ago
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

http://hg.mozilla.org/releases/mozilla-beta/rev/438dd47e6f69
(Assignee)

Comment 6

5 years ago
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

I would like to land this patch on m-r and esr10 branches. 12.0b1 release passed without any problems. The patch will remove error-prone manual steps used by releng.
Attachment #602895 - Flags: approval-mozilla-release?
Attachment #602895 - Flags: approval-mozilla-esr10?
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

[Triage Comment]
Looks foo, low risk, please go ahead.
Attachment #602895 - Flags: approval-mozilla-release?
Attachment #602895 - Flags: approval-mozilla-release+
Attachment #602895 - Flags: approval-mozilla-esr10?
Attachment #602895 - Flags: approval-mozilla-esr10+
(Assignee)

Comment 8

5 years ago
Comment on attachment 602895 [details] [diff] [review]
sign xulrunner

http://hg.mozilla.org/releases/mozilla-esr10/rev/2ef0aaa7a70d
http://hg.mozilla.org/releases/mozilla-release/rev/c3be4bb8ba93
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox-esr10: --- → fixed
You need to log in before you can comment on or make changes to this bug.