The default bug view has changed. See this FAQ.

[Necko] nsIWebShellServices::StopLoadingDocument is not reentr safe

RESOLVED FIXED in M10

Status

()

Core
XPCOM
P3
normal
RESOLVED FIXED
18 years ago
15 years ago

People

(Reporter: Frank Tang, Assigned: Frank Tang)

Tracking

Trunk
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Should be fixed by Necko landing)

(Assignee)

Description

18 years ago
The StopLoadingDocuemnt of nsWebShell is not safe to be called from the
nsMetaCharsetObserver. It crash on Mac and Linux when the first block of data
contained the full META charset tag.

I temp fix this by comment out the call to StopLoadingDocument in the
intl/chardet/src/nsMetaCharsetObserber.cpp . if you uncomment out that two line
you can easily reproduce problem on Linux and Mac. Not easy to see the problem
on window.
Related bug 7239, 7241, 7242, 3921, 7240

Comment 1

18 years ago
This bug is happening because on Mac and Unix, netlib callbacks can happen
before the load url call stack unwinds.  This will get fixed by the Necko
landing because all three platforms will start using the same threading
architecture.  Right now, on Mac and Unix, netlib and layout run on a single
thread while on Windows, they are on separate threads.

Rick, please correct me if I am goofing up here.  Thanks.

Setting target milestone to M8 and accepting bug.
Status: NEW → ASSIGNED
Summary: nsIWebShellServices::StopLoadingDocument is not reentr safe → [Necko] nsIWebShellServices::StopLoadingDocument is not reentr safe
Whiteboard: Should be fixed by Necko landing

Updated

18 years ago
Target Milestone: M8

Comment 2

18 years ago
*** Bug 7208 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 7232

Updated

18 years ago
Target Milestone: M8 → M9

Comment 3

18 years ago
Moving out Necko related bugs to M9...

Updated

18 years ago
Target Milestone: M9 → M10

Comment 4

18 years ago
Moving bugs blocked by Necko to M10...

Updated

18 years ago
Assignee: nisheeth → ftang
Status: ASSIGNED → NEW

Comment 5

18 years ago
Now that Necko has landed, this bug should be fixed.  Frank, I'm assigning this
to you so that you can see what happens on Mac and Unix when you re-enable your
code.  Please pass it back to me if you run into problems.  Thanks.

Updated

18 years ago
Blocks: 11094
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
check in the remove of the work around. Mark this fixed
Moving all threading bugs to XPCOM. See bug 160356.
Component: Threading → XPCOM
You need to log in before you can comment on or make changes to this bug.