Closed Bug 733196 Opened 9 years ago Closed 9 years ago

Landscape VKB should not be fullscreen when entering text into a web form

Categories

(Firefox for Android Graveyard :: Keyboards and IME, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox13 verified, firefox14 verified)

VERIFIED FIXED
Firefox 14
Tracking Status
firefox13 --- verified
firefox14 --- verified

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

(Keywords: inputmethod)

Attachments

(1 file, 2 obsolete files)

STR:
1. Load google.com and tap text input form.
2. Rotate device to landscape mode.

AR:
The web page is obscured by the fullscreen VKB.

ER:
The landscape VKB should be half-height like in portrait mode, not fullscreen.
Change widget.ime.android.landscape_fullscreen preference from 1 to 0.
Attachment #603093 - Flags: review?(doug.turner)
Set IME_FLAG_NO_FULLSCREEN on Honeycomb to disable fullscreen tablet VKBs. ICS's WebKit sets this IME flag, too.
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED
Attachment #603094 - Flags: review?(doug.turner)
Blocks: 733153
Comment on attachment 603093 [details] [diff] [review]
bug-733196-part-1-landscape-fullscreen-0.patch

This patch has been obsoleted by r+'d bug 733153.
Attachment #603093 - Flags: review?(doug.turner)
Comment on attachment 603094 [details] [diff] [review]
bug-733196-part-2-no-honeycomb-fullscreen.patch

This patch has been obsoleted by r+'d bug 733153.
Attachment #603094 - Flags: review?(doug.turner)
No longer blocks: 733153
Depends on: 733153
Triage, this bug needs a priority.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → ---
Component: General → IME
QA Contact: general → ime
Blocks: 733153
No longer depends on: 733153
Do not use the fullscreen keyboard on Native Fennec (in portrait or landscape orientations).

This patch does not change any XUL Fennec code or behavior.
Attachment #603093 - Attachment is obsolete: true
Attachment #603094 - Attachment is obsolete: true
Attachment #605545 - Flags: review?(blassey.bugs)
Attachment #605545 - Flags: review?(blassey.bugs) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/cb66ae517284
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Comment on attachment 605545 [details] [diff] [review]
bug-733196-no-fullscreen-keyboard-v2.patch

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: Fullscreen text entry is confusing for users.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Android Java only.
String changes made by this patch: N/A
Attachment #605545 - Flags: approval-mozilla-aurora?
Comment on attachment 605545 [details] [diff] [review]
bug-733196-no-fullscreen-keyboard-v2.patch

[Triage Comment]
Mobile only - approved for Aurora 13.
Attachment #605545 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
checkin-needed for mozilla-aurora
Keywords: checkin-needed
Verified/fixed on:

Nightly Fennec 14.0a1 (2012-03-22)
Device: Samsung Nexus S
OS: Android 2.3.6
Status: RESOLVED → VERIFIED
erified/fixed on:

Aurora Fennec 13.0a2 (2012-03-25)
Device: Samsung Nexus S
OS: Android 2.3.6
Removing checkin-needed keyword because this bug fix has landed in both mozilla-central and mozilla-aurora.
Keywords: checkin-needed
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.