Tab group misalignment under certain conditions

RESOLVED FIXED in Firefox 40

Status

defect
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: ckurecka, Assigned: Res, NeedInfo)

Tracking

12 Branch
Firefox 40
x86_64
Windows 7

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a2) Gecko/20120305 Firefox/12.0a2
Build ID: 20120305042014

Steps to reproduce:

On Windows 7, I hid the menu bar (just showing the menu button) and maximized Firefox/Aurora.  I then made two tab groups, one taking up about 1/3 of the available horizontal space and the other taking up about 2/3.  I filled each with tabs as I used the browser (9 tabs in the left, 1/3 one and about 90 in the right one, though it should be reproducible with far fewer).  I then pinned Gmail as an app tab so that it's smaller and on the far left of both groups.


Actual results:

By doing the above, if I open the Panorama view, the tab groups are misaligned to partly appear above the top of the screen. It was 100% reproducible for me when I was documenting all of this, but after toggling and trying a bunch of permutations of window state (unpinning and repinning app tab, restoring/maximizing window, showing/hiding menu bar), at least for now it has stopped misbehaving, and I don't want to quit Firefox to re-test because I'd lose my state on this bug report.  This is not a lone incident though; it's been bugging me for several weeks across numerous browser sessions.


Expected results:

The tab groups should just appear like normal, taking the space they were dragged/aligned to cover.
(Reporter)

Comment 1

7 years ago
In case what I said about 1/3 vs. 2/3 is ambiguous and/or relevant, I mean each group taking up virtually all of the vertical space and having two groups side-by-side of a 1:2 horizontal ratio (left:right), meaning the right one is twice as wide as the left one.  The problem happens to me whether I label the groups or not, and has also happened to me if I simply have a single large group, though I don't have quite as specific information as to the conditions (they are very similar though - no menu bar, maximized).
(Assignee)

Comment 2

7 years ago
I found this bug as well. Here is my scenario to reproduce it:
1. Open several tabs.
2. Enter the Panorama view.
3. Enlarge the group to cover about 90+% of the window vertically.
4. Switch off Panorama view.
5. Close one tab.
6. Reopen Panorama view.
7. See that the tab group moved past the top window border.
Hope it helps to narrow down the cause.
Do you still see this problem when using a current version?
Component: Untriaged → Panorama
Flags: needinfo?(pat.d.mail)
Flags: needinfo?(ckurecka)
(Assignee)

Comment 4

5 years ago
Just checked in 27.0.1 and yes - it can be reproduced the way I described.
Flags: needinfo?(pat.d.mail)
can you post a screen shot?
(Assignee)

Comment 6

5 years ago
Posted image Bug's occurence
Posting "2014-02-16 14_27_44.jpg" where you can see this effect. It doesn't seem to matter if the browser's window is maximized or not, as it happens in both cases. To "fix" the tab group, I have to drag it a little and it jumps right where it should be, i.e. several pixels down.
(Assignee)

Comment 7

5 years ago
I've just checked on Aurora 29.0a2 and it's there too. I've also made some measurements. It seems, that problem arises, once the tab group overlaps the bottom ~80 px of the client area of the window. The more of those pixels are covered, the higher the group will "jump" during the test. Just enough to stay away from that area. What's more, the group doesn't have to be large. Drag a small one to the bottom of the window and it will "jump" as well.
(Assignee)

Comment 8

4 years ago
I think I found the cause: revision 50343 in ui.js from bug 581813. I'll check if undoing it fixes the issue.
(Assignee)

Comment 9

4 years ago
Reverting the workaround from revision 50343, which seems no longer necessary.
Attachment #8600308 - Flags: review?(ttaubert)
Comment on attachment 8600308 [details] [diff] [review]
Margin-top is no longer set when leaving Panorama.

Review of attachment 8600308 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch Patryk! Unfortunately, we still need this code.

It took me a while to build and get Aero running in my Windows VM but here's what it looks like after opening Panorama: http://imgur.com/0swdGch . You can see that there is a now grey border behind the tabs itself, and that shouldn't be there.
Attachment #8600308 - Flags: review?(ttaubert) → review-
(Assignee)

Comment 11

4 years ago
Thanks for the extra effort taken. But... Firefox looks like that even without my patch. And without opening Panorama. It doesn't strike so odd if you hide the title bar (there would be no hard cut from glass to gray), but the gray area is still behind the tabs. I even looked up some random screenshots of Firefox on Windows 7 to make sure it's not a problem with my system. Are you sure it should look different? I'll try to find out, what that gray shape is.
Comment on attachment 8600308 [details] [diff] [review]
Margin-top is no longer set when leaving Panorama.

Review of attachment 8600308 [details] [diff] [review]:
-----------------------------------------------------------------

You are right, there is no difference. Should have double-checked what the normal version looks like, sorry. This grey bar looked weird to me but it seems that that's the default.
Attachment #8600308 - Flags: review- → review+
Assignee: nobody → pat.d.mail
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/21fdba79d6bd
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
(Assignee)

Comment 15

4 years ago
I found the gray background (glass fog) was introduced in rev 155158 for bug 738491. My tiny patch doesn't seem to break anything even with that effect removed, so I assume it's safe to be applied.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.