"JavaScript error: http://mochi.test:8888/tests/parser/htmlparser/tests/mochitest/file_bug594730-4.html, line 3: parent.is_not is not a function"

VERIFIED FIXED in Firefox 12

Status

()

P3
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Depends on: 1 bug)

Trunk
mozilla13
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox11 wontfix, firefox12 verified)

Details

(URL)

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

7 years ago
Created attachment 603678 [details] [diff] [review]
(Av1) file_bug594730-4.html: s/is_not()/isnot()/
[Checked in: Comments 5 and 9]
Attachment #603678 - Flags: review?(jonas)
(Assignee)

Comment 2

7 years ago
Comment on attachment 603678 [details] [diff] [review]
(Av1) file_bug594730-4.html: s/is_not()/isnot()/
[Checked in: Comments 5 and 9]

Succeeded as
https://tbpl.mozilla.org/php/getParsedLog.php?id=9881585&tree=Try
{
62 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should not have matched the Unicode escape. - "ø" should not equal "ř"
}

Comment 3

7 years ago
Try run for 7d681ec6adeb is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=7d681ec6adeb
Results (out of 28 total builds):
    exception: 2
    success: 23
    warnings: 2
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-7d681ec6adeb
(Assignee)

Comment 4

7 years ago
(In reply to Mozilla RelEng Bot from comment #3)
>     https://tbpl.mozilla.org/?tree=Try&rev=7d681ec6adeb

Succeeded.
(Assignee)

Comment 5

7 years ago
Comment on attachment 603678 [details] [diff] [review]
(Av1) file_bug594730-4.html: s/is_not()/isnot()/
[Checked in: Comments 5 and 9]

https://hg.mozilla.org/mozilla-central/rev/0337458a08ba

[Approval Request Comment]
Regression caused by (bug #): Bug 594730.
User impact if declined: None, but this broken check doesn't run.
Testing completed (on m-c, etc.): Comment 3, this comment.
Risk to taking this patch (and alternatives if risky): None, test-only.
String changes made by this patch: None.
Attachment #603678 - Attachment description: (Av1) file_bug594730-4.html: s/is_not()/isnot()/ → (Av1) file_bug594730-4.html: s/is_not()/isnot()/ [Checked in: Comment 5]
Attachment #603678 - Flags: approval-mozilla-beta?
Attachment #603678 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
(Assignee)

Comment 6

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9906949&tree=Firefox
Rev3 Fedora 12 mozilla-central opt test mochitests-5/5 on 2012-03-08 04:42:21 PST for push 0337458a08ba
{
62 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should not have matched the Unicode escape. - "ø" should not equal "ř"
}
Status: RESOLVED → VERIFIED
(Assignee)

Comment 7

7 years ago
V.Fixed

Comment 8

7 years ago
Comment on attachment 603678 [details] [diff] [review]
(Av1) file_bug594730-4.html: s/is_not()/isnot()/
[Checked in: Comments 5 and 9]

[Triage Comment]
Approved for Aurora 12, but we're frozen on Beta 11 at this point in preparation for Tuesday's release.
Attachment #603678 - Flags: approval-mozilla-beta?
Attachment #603678 - Flags: approval-mozilla-beta-
Attachment #603678 - Flags: approval-mozilla-aurora?
Attachment #603678 - Flags: approval-mozilla-aurora+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Whiteboard: [c-n: 0337458a08ba to m-a]
Comment on attachment 603678 [details] [diff] [review]
(Av1) file_bug594730-4.html: s/is_not()/isnot()/
[Checked in: Comments 5 and 9]

http://hg.mozilla.org/releases/mozilla-aurora/rev/bc72b5aaf9e5
Attachment #603678 - Attachment description: (Av1) file_bug594730-4.html: s/is_not()/isnot()/ [Checked in: Comment 5] → (Av1) file_bug594730-4.html: s/is_not()/isnot()/ [Checked in: Comments 5 and 9]
status-firefox12: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: 0337458a08ba to m-a]
(Assignee)

Comment 10

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=9958269&tree=Mozilla-Aurora&full=1
Rev3 MacOSX Leopard 10.5.8 mozilla-aurora opt test mochitests-5/5 on 2012-03-09 18:05:44 PST for push bc72b5aaf9e5
{
59 INFO TEST-PASS | /tests/parser/htmlparser/tests/mochitest/test_bug594730.html | Decoded bytes should not have matched the Unicode escape. - "ø" should not equal "ř"
}

firefox12: verified.
status-firefox12: fixed → verified
You need to log in before you can comment on or make changes to this bug.