Last Comment Bug 733810 - If last line of folded Subject: header is Tab char only line, following header is shown as subject text at thread pane
: If last line of folded Subject: header is Tab char only line, following heade...
Status: RESOLVED WORKSFORME
: testcase
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: 13 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 09:33 PST by J2m06
Modified: 2014-09-22 05:44 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
incorrect subject line.eml (243.88 KB, application/octet-stream)
2012-03-07 09:33 PST, J2m06
no flags Details
Screenshots of the problem (3.72 KB, text/plain)
2012-03-07 09:51 PST, J2m06
no flags Details
Screenshots of the problem (81.60 KB, image/jpeg)
2012-03-07 10:07 PST, J2m06
no flags Details
The subject line in imap ok (22.55 KB, image/jpeg)
2012-03-16 02:09 PDT, J2m06
no flags Details

Description J2m06 2012-03-07 09:33:35 PST
Created attachment 603758 [details]
incorrect subject line.eml

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

NOTHING


Actual results:

The subject line displays infomartions more in the message list!
But it's good in the preview window


Expected results:

The subject line should display the same as in the preview window

These are:
-the messages come from IncrediMail!
-It's the same with TB5 / TB8 / TB10 / TB13
-But it's good with TB3
Comment 1 J2m06 2012-03-07 09:51:14 PST
Created attachment 603765 [details]
Screenshots of the problem
Comment 2 J2m06 2012-03-07 10:07:54 PST
Created attachment 603773 [details]
Screenshots of the problem
Comment 3 WADA 2012-03-07 17:10:42 PST
(In reply to J2m06 from comment #0)
> Created attachment 603758 [details]
> incorrect subject line.eml

Message source. Broken mail(broken Subject: header, Null/Tab-only folded line which is prohibited by mail related RFC).
> ( [CRLF] = 0x0D0A, [Tab] = 0x09 )
> Subject: =?ISO-8859-1?B?UulmLiA6IGdhbGV0dGUgZGVzIHJvaXM=?=[CRLF]
> [Tab][CRLF]	
> X-Antivirus: avast! (VPS 120218-0, 18/02/2012), Outbound message[CRLF]
If POP3 and mail is saved in local mail folder, X-Mozilla-Status: header etc. is also shown/saved by View/Message Source or Save As to .eml file.
IMAP?

Subject at message header pane is shown using above downloaded message header data of mail.
If POP3, subject at thread pane is also extracted from above downloaded headers.
However, if IMAP, subject at thread pane is obtained from data returned to "fetch  BODY.PEEK[HEADER.FIELDS (... Subject ...)". Because X-Antivirus: header is usually not requested by BODY.PEEK[HEADER.FIELDS command, data in X-Antivirus: header usually can't appear in Tb's Subject column at thread pane.

(In reply to J2m06 from comment #1)
> Created attachment 603765 [details]
> Screenshots of the problem

Confirming per screen shot.
Comment 4 WADA 2012-03-07 17:31:42 PST
Phenomeno was observed with mail in local mail folder, in Tb 10.0.2.
If Subject: header is modified like next(last folded line is not Null/Tab-only-line), problem doesn't occur even when prohibited Null/Tab-only-line is inserted at mid of folded Subject: header lines.
> Subject: =?ISO-8859-1?B?UulmLiA6IGdhbGV0dGUgZGVzIHJvaXM=?=[CRLF]
> [Tab][CRLF]	
> [Tab]End-of-subject[CRLF]	
> X-Antivirus: avast! (VPS 120218-0, 18/02/2012), Outbound message[CRLF]
IIRC, it's already known phenomenon.
Comment 5 Joe Sabash [:JoeS1] 2012-03-07 18:46:24 PST
(In reply to WADA from comment #4)
To deduce that,
> [Tab][CRLF]	
> X-Antivirus: avast! (VPS 120218-0, 18/02/2012), Outbound message[CRLF]
was the problem, just looking at the message source (and not the original mail)
Quite frankly, was astounding triage.
Thanks for helping WADA
Comment 6 WADA 2012-03-07 19:27:44 PST
Problem occurs with next header. i.e. RFC2047 is irrelevant.
> Subject: Text-before-Null-line[CRLF]
> [Tab][CRLF]	
> X-Antivirus: avast! (VPS 120218-0, 18/02/2012), Outbound message[CRLF]
Removing Bug 673092 from dependency.

Problem is RFC 5822 relevant(folding, prohibited blank only header line).
"prohibited blank only header line" is apparently mail seder side bug.
"Thread pane display of this bug by Tb" is a kind of Tb's intorelance with malformed mail around unfolding.
If unfolding is correctly executed first according to RFC 5822, Subject: header is interpreted as next;
> Subject: =?ISO-8859-1?B?...?= ...[Tab][CRLF]
> X-Antivirus: avast! (VPS 120218-0, 18/02/2012), Outbound message[CRLF]
If correctly unfolded first, the [Tab] is merely a tab character in Subject text.
Comment 7 J2m06 2012-03-08 02:16:51 PST
Comment on attachment 603765 [details]
Screenshots of the problem

SORRY/ PAGE HTML !!!
Comment 8 J2m06 2012-03-08 02:17:49 PST
Comment on attachment 603773 [details]
Screenshots of the problem

POP account.
Comment 9 J2m06 2012-03-15 11:39:37 PDT
hello
for information: the same messages from an IMAP account statements shall be prominently displayed

--------------------------
bonjour
pour infomartion: les memes messages releves par un compte imap sont bien affichés
Comment 10 J2m06 2012-03-16 02:09:50 PDT
Created attachment 606502 [details]
The subject line in imap ok

hi

The subject line in imap ok with the same message
-------------------------
bonjour
La ligne sujet est ok en imap avec le même messages
--
Comment 11 Wayne Mery (:wsmwk, NI for questions) 2014-09-22 05:44:21 PDT
sshagarwal is unable to reproduce. If anyone else can reproduce then please updat the bug

Note You need to log in before you can comment on or make changes to this bug.