Closed Bug 734027 Opened 8 years ago Closed 8 years ago

Non-ASCII filename is shown as escaped unicode when saving a snapshot from video

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 13

People

(Reporter: mihaelav, Assigned: ananuti)

References

()

Details

(Whiteboard: [good first bug][mentor=jwein][lang=js])

Attachments

(2 files)

Attached image screenshot
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120307 Firefox/13.0a1

Steps to reproduce:
1. Give video file Non-ASCII filename, for example: Basilique du Sacré-Cœur de Montmartre.ogg
2. Play this file in Firefox
3. Right click on the video and select "Save Snapshot as..."

Actual result:
Snapshot file shows escaped unicode instead of non ASCII characters

Expected result:
Snapshot file name should contain the correct non-ascii characters.
This bug is very similar to bug 694434.

It looks like we will need to use |decodeURI| on the fileBaseName at 
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/nsContextMenu.js#853
Whiteboard: [good first bug][mentor=jwein][lang=js]
Comment on attachment 604004 [details] [diff] [review]
Added decodeURI to decode percent encoding on non-ASCII filename when saving a snapshot from video

Review of attachment 604004 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! I tested this out and it works great.
Attachment #604004 - Flags: review?(jwein) → review+
Assignee: nobody → ananuti
Status: NEW → ASSIGNED
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/299e9dc61190
Component: Video/Audio Controls → Menus
Keywords: checkin-needed
Product: Toolkit → Firefox
QA Contact: video.audio → menus
Target Milestone: --- → Firefox 13
https://hg.mozilla.org/mozilla-central/rev/299e9dc61190
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.