Last Comment Bug 734812 - Make the linker error out when text relocations are defined with DF_TEXTREL
: Make the linker error out when text relocations are defined with DF_TEXTREL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: mozglue (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla13
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 00:34 PDT by Mike Hommey [:glandium]
Modified: 2012-03-13 07:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make the linker error out when text relocations are defined with DF_TEXTREL (1.70 KB, patch)
2012-03-12 00:35 PDT, Mike Hommey [:glandium]
nfroyd: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-03-12 00:34:21 PDT
Since bug 733087 added support for DT_FLAGS, we can add a test for DF_TEXTREL to do the same as DT_TEXTREL.
Comment 1 Mike Hommey [:glandium] 2012-03-12 00:35:28 PDT
Created attachment 604849 [details] [diff] [review]
Make the linker error out when text relocations are defined with DF_TEXTREL
Comment 3 Marco Bonardo [::mak] 2012-03-13 07:00:23 PDT
https://hg.mozilla.org/mozilla-central/rev/28920721ac6d

Note You need to log in before you can comment on or make changes to this bug.